Bug 506213 - audio / volume control very, very buggy
audio / volume control very, very buggy
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 23:30 EDT by Denny Crane
Modified: 2010-01-13 01:20 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-19 11:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Denny Crane 2009-06-15 23:30:16 EDT
Description of problem:
The new volume icon in the notification area:
1) Mouse scroll wheel now only de/increments volume by 1, which is annoyingly slow.
2) The volume control stops functioning quite often for no apparent reason. Usually I notice while (attempting to) listen to music using Rhythmbox -- attempting to adjust the volume by scrolling the mouse wheel produces no tooltip, no icon state change, and no volume change; clicking on the icon and then attempting to adjust the volume has no effect ... the indicator moves but the volume does not change, and when clicking back to the desktop and then re-clicking the volume icon, the volume level indicator returns to its previous spot.
3) The volume control seems to be incredibly inconsistent while adjusting (when it does in fact work) -- for example, if I am starting at 100% volume level and begin scrolling my mouse wheel over the volume icon, the volume level is lowered very slowly until about 55-40, then the volume suddenly goes down much much more than it was going down up to that point (apparently a larger change in volume level for the same increment).
4) This may be a Rhythmbox bug or some other bug?? ... while attempting to play music, switching to next and previous tracks with my keyboard shortcuts, some songs just don't play (they are all mp3 format). I'm not sure if the volume might not be working at these points or what.
5) As has been mentioned in another bug (https://bugzilla.redhat.com/show_bug.cgi?id=505711), the volume control icon is no longer independent of the notification area applet.


Version-Release number of selected component (if applicable):


How reproducible:
Often

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Bugginess

Expected results:
Non-bugginess

Additional info:
Comment 1 Denny Crane 2009-06-18 10:29:35 EDT
For point #2, the volume controls (both the notification area icon and the keyboard shortcuts) will not function again until logging off and then back on.

For point #4, after the most recent Fedora updates, it seems that Rhythmbox now "only" doesn't play whichever first song you choose. This does seem to be tied to the volume in some way, as the volume icon changes to the mute symbol when attempting to begin playing a song through the Rhythmbox GUI (but the icon does not change if I simply use my keyboard shortcut).
Comment 2 Denny Crane 2009-06-18 10:44:41 EDT
6) The volume level remembered by the notification area icon versus the keyboard shortcuts is different. If I adjust the volume with one and then the other, the actual volume level changes very abruptly to (apparently) whatever volume level was remembered by the control I'm using, not the real volume level.
Comment 3 Chris Hubick 2009-06-19 21:18:30 EDT
I don't know where to put this, so I will describe my experience here...

Problem 1:
 After a reboot, the master volume applet slider indicates ~25% (inaudible), even though it was at ~75% (audible) before I reboot.  Adjusting it back to ~75% makes sound audible again.

Problem 2:

So, if I start by muting the master volume applet output and then start Rhythmbox (also displays muted when started)...

  - If I raise the Rhythmbox volume to ~75%, I would have expected (I RTFM'd about Flat Volumes) sound to be produced and master volume changed accordingly, but it remains unchanged - no sound is produced and panel still shows muted.
  - If I then raise master volume to ~75%, sound is produced quietly - hovering over the Rhythmbox volume control then shows only ~10%.  I would have expected sound to be produced louder at 75% of the maximum.
  - If I then raise Rhythmbox volume control to ~50%, sound is produced very loudly, and hovering over the master volume applet shows ~90%.  I would have expected sound to be produced quieter at only ~50% of maximum.
  - If I then mute Rhythmbox, sound is no longer produced, and the master control shows as muted as well, both as expected.
  - If I then change the master volume slider, no sound is produced as expected, and it briefly displays the setting I asked for before unexpectedly resetting itself to muted.
  - If I then change the Rhythmbox volume slider to ~50%, sound is produced unexpectedly loudly as before, the master volume applet jumps back to showing ~90%.
  - If I then reduce master volume to ~50%, expecting half of maximum output, sound volume is decreased far more than expected, and Rhythmbox then shows 1% output.

All in all, this leaves me totally confused - I have two volume controls that have different values to be set, yet where doing so affects each other in some undecipherable fashion, leaving me with no real idea what order I need to move what slider in to actually get what I want.  I'm sorry, but as it stands now, I feel the previously *independently* controlled "Mater System Volume" and "Application Volume" were far more intelligible before they started mucking with each other.
Comment 4 Kieran Clancy 2009-06-26 05:27:24 EDT
I have similar problems, and another one to add to the list:
7) If playing songs with audacious at 70% volume (or similar), if I skip manually to the next song, the volume spontaneously drops to 46% (inaudible), then if I skip again, it drops to 19%, and on the next skip it mutes the volume entirely!

My guess is that it is saving that audacious had it's volume at 70%, but then audacious is saving this too, starts playing a new PA stream with 70% and the volume remembering somehow sets this to 70% of 70% ~= 46%.

This only happens when the notification area volume applet is functioning properly. When it stops working (which it does regularly as mentioned in the summary), I am actually very happy because I can skip songs without having to keep pulling the volume back up.
Comment 5 Matt Chan 2009-07-09 10:18:27 EDT
I'm going to suggest that we move these problems to their individual bug reports. This would make it easier for Lennart to fix each and mark them as fixed, instead of having some fixed but not being able to update the bugzilla status.

If I don't see any opposition to this idea in a week, I'll split this up into individual bugs.
Comment 6 Lennart Poettering 2009-08-19 11:29:50 EDT
Nate, please file seperate bugs about seperate issues.

Please file your bug #1 against gnome-media.

Your bug #2 is probably a duplicate of bug 506075.

Your bug #3 is probably fixed in F12. We changed the mapping between percent/pixels and actual dB to make it more natural.

Please file your bug #4 against rhythmbox.

Your bug #5 is already filed.

I will ignore all other issues mentioned in comments here.

So please: seperate issues need to be posted in seperate bugs. And dn't hijack bug reports by adding comments unrelated to the original topic. Thanks.

I will close this now.
Comment 7 Denny Crane 2009-08-19 11:36:51 EDT
No one should have to report 50 different bugs when the whole thing seems to be ridiculously broken. Didn't anyone bother to test this (AT ALL)? I've seen a lot more problems and inconsistencies since originally posting this bug, and as you can probably tell, I haven't bothered to file bug reports since this is all stuff that should jump right out at any idiot who takes half a minute to test the seemingly needless changes which caused all these and many other problems.
Comment 8 Lennart Poettering 2009-08-19 12:57:56 EDT
Hey, you are getting something for free. First you get the software for free, and then secondly we even try to fix problems you might encounter also for free. 

All what we ask from you in return for this is that you file seperate issues seperately. And even though you didn't I politely responded to all issues you raised.

But what's your reply to this? Just insults and complaints.

Also, I don't see 50 issues mentioned above. Heck, against all of PA only 46 reports are open in total. I am pretty sure most of them are completely unrelated to your bugs.
Comment 9 Denny Crane 2009-08-19 13:02:48 EDT
According to your logic, you should not be complaining about free bug reports you are getting then. It's free quality assurance testing and reporting. And you respond with complaints? Hypocritical, yes?

Have a nice day.
Comment 10 Lennart Poettering 2009-08-19 13:09:02 EDT
The different is that I replied politely and you didn't.
Comment 11 Denny Crane 2009-08-19 13:32:01 EDT
So we can agree that you're a polite hypocrite while I'm just rude. Seems fair enough. I'm compromising, of course, out of sheer politeness -- I do not believe I was being rude at all.

But isn't it rude to call someone rude? Or to imply that they are so? Perhaps rudeness is best defined as telling someone something they do not want to hear.

Anyway, being a generally well-mannered gentleman, I'll give you the last word.

Best Regards. And thank you, kind sir, for calling me rude. For I wouldn't have known the fault if I had not seen it myself.
Comment 12 Chris Hubick 2009-08-19 13:44:06 EDT
Lennart, thanks for filing your bug report "It's ALL FUBAR, I almost died!!" regarding your new Time Machine software.

We are sorry that you almost got squashed by a dinosaur when you entered the date 1907 to meet your great great grandparents.  Unfortunately, your single *user* level report against our product actually covers several specific *highly technical* issues, which you should have somehow known how to identify and file as separate bugs.

The first problem is actually regarding the Soleniod Tachion Dispersion Field, and should obviously be filed against that component.

The second problem is a known issue with the Inverse-Arch Tillium Relay component of the Flux Capacitor product, which is already fixed in the 2035.4 version, which should be released in just 25 short years from now.

You also seem to be experiencing an issue with some aspects of the new Advanced Double Decrementing Laurier-Transform Decoder we use.  That is a product of GeospatialWare Inc. - so please file that problem with them.

I'm afraid the issue you described, "I pressed the emergency 'Take Me Home Now' button and ended up in the Ice Age and froze my feet off", is actually part of the expected behavior of the new Staged-Reset Chrono-Interial Dampener system.  It is designed to now restore you to the current time period using several smaller hops, minimizing nausea.  We are adding a hidden GConf preference to modify the default behavior in the next release, should you wish to change it.

We have chosen to ignore your other comment regarding "My pet cat Fluffy was eaten by a raptor", and ask that you not spam our bug system regarding problems which are obviously beyond our control.

Thanks.
Comment 13 Sergio Monteiro Basto 2009-08-19 13:46:13 EDT
Where I can find how remove pulseaudio from system , pulseaudio just sucks .
on all intel sound card that I found . 
Don't keep sound
Comment 14 Jane Dogalt 2010-01-13 01:20:57 EST
Lennart,

As someone who is a bit bipolar, and who just nearly blew out their eardrums because of issues described in this bug report, I would like to suggest the following-

Yes, free, no warranty, not even the implied warranties of merchantability or fitness for a particular purpose.  

Redhat employees have been fond of the phrase 'eating babies'.

But seriously, I get all that, but this

is

a

HEALTH HAZARD

People are suffering real excruciating, PAIN because of this bug.

Please forgive us for being rude, irate, insensitive, and perhaps having unrealistic expectations above the whole 'not even fit for a particular purpose'.

Maybe I should be focusing my attention and complains on SONY and INTEL for building products that are physically capable, via buggy software, of permanently damaging my hearing.

No, I'm not talking about kids and ipods and subtle long term damage.  I'm talking about the physical pain endured during the 0.75 seconds it takes my brain to get my hands to move up and pull the earbuds out of my ears, after rhythmbox manages to get my pulse volume control to show "gain 138%" which oddly I can't get it to do interacting with it with the mouse.

And then the feeling for hours and days afterwords, that I don't want to listen to any audio anywhere, because my brain has literally suffered so much from the experience of the bug here.

So I IMPLORE you, be forgiving of irrational bug reports, that relate to serious

HEALTH HAZARDS

Note You need to log in before you can comment on or make changes to this bug.