Bug 513736 - Compiz crash if dual monitor & compiz on i915 driver
Summary: Compiz crash if dual monitor & compiz on i915 driver
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 12
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 585705 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-07-25 02:37 UTC by Adam Drew
Modified: 2018-04-11 08:02 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-05 06:41:00 UTC


Attachments (Terms of Use)
Portion of messages log pertinent to issue (383.07 KB, text/plain)
2009-07-25 02:37 UTC, Adam Drew
no flags Details
compiz backtrace on F13 (61.54 KB, text/plain)
2010-04-28 08:00 UTC, Robert de Rooy
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 419328 None None None Never
Red Hat Bugzilla 583471 None None None Never

Internal Links: 583471

Description Adam Drew 2009-07-25 02:37:43 UTC
Created attachment 355125 [details]
Portion of messages log pertinent to issue 

Description of problem:
System reliably kernel panics if I attempt to use "Desktop Effects" and dual monitors at the same time. "Desktop Effects" and dual monitors work fine mutually exclusively. 

Version-Release number of selected component (if applicable):
kernel-2.6.29.5-191.fc11.i586
kernel-2.6.29.6-213.fc11.i586

Verified on PAE versions of above kernels; erased PAE kernels as diagnostic step. Did not retain version numbers.


How reproducible:
100% reproductive. I was able to reproduce the kernel panic under a myriad of testing sequences. Changing the order of the steps does not resolve the issue.

Steps to Reproduce:
0. Connect external display
1. Boot system (observe plymouth on both monitors)
2. Log into GDM. GDM login shown on both monitors.
3. Get to GNOME desktop. Observe external monitor is now off.
4. Enable desktop effects
5. Launch gnome-display-properties
6. Enable second display and hit "Apply"
7. Observe kernel panic

Note: Steps 0, 4, and 6, can put put in any order and issue will persists. Verified various times.
  
Actual results:
System appears to "hang." Caps lock and num lock lights non operational. BIOS controlled hardware control keys (e.g. WLAN off) non operational. Suspend to disk non operational. Hard power-off required. 

Expected results:
To be able to use dual monitors (spanned desktop) and "Desktop Effects" together.

Additional info:
Disabling "Desktop Effects", activating the second monitor, and then enabling "Desktop Effects" results in same issue.

Examples of data from messages log:
Jul 24 21:58:24 windbuddy kernel: [drm:i915_gem_object_unbind] *ERROR* Attempting to unbind pinned buffer
Jul 24 21:58:24 windbuddy kernel: ------------[ cut here ]------------
Jul 24 21:58:24 windbuddy kernel: WARNING: at drivers/gpu/drm/i915/i915_gem_tiling.c:473 i915_gem_set_tiling+0x4a0/0x4f2 [i915]() (Not tainted)
Jul 24 21:58:24 windbuddy kernel: Hardware name: U-100
Jul 24 21:58:24 windbuddy kernel: failed to unbind object for tiling switchModules linked in: michael_mic arc4 ecb aes_i586 aes_generic r8180 ieee80211_rtl ieee80211_crypt_ccmp_rtl ieee80211_crypt_tkip_rtl ieee80211_crypt_wep_rtl ieee80211_crypt_rtl fuse sco bridge stp llc bnep l2cap bluetooth sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep usb_storage snd_pcm iTCO_wdt snd_timer iTCO_vendor_support pcspkr r8169 i2c_i801 mii snd soundcore snd_page_alloc wmi ata_generic pata_acpi i915 drm i2c_algo_bit i2c_core video output [last unloaded: scsi_wait_scan]
Jul 24 21:58:24 windbuddy kernel: Pid: 1794, comm: Xorg Not tainted 2.6.29.6-213.fc11.i586 #1
Jul 24 21:58:24 windbuddy kernel: Call Trace:
Jul 24 21:58:24 windbuddy kernel: [<c042ebc6>] warn_slowpath+0x7c/0xa4
Jul 24 21:58:24 windbuddy kernel: [<c055a733>] ? idr_remove+0x11a/0x128
Jul 24 21:58:24 windbuddy kernel: [<c055a733>] ? idr_remove+0x11a/0x128
Jul 24 21:58:24 windbuddy kernel: [<c0705a10>] ? printk+0x14/0x1c
Jul 24 21:58:24 windbuddy kernel: [<f7de1193>] ? i915_gem_object_unbind+0x43/0x1f9 [i915]
Jul 24 21:58:24 windbuddy kernel: [<f7d86405>] ? drm_gem_object_reference+0xd/0xf [drm]
Jul 24 21:58:24 windbuddy kernel: [<f7de5441>] i915_gem_set_tiling+0x4a0/0x4f2 [i915]
Jul 24 21:58:24 windbuddy kernel: [<f7d85602>] drm_ioctl+0x202/0x292 [drm]
Jul 24 21:58:24 windbuddy kernel: [<f7de4fa1>] ? i915_gem_set_tiling+0x0/0x4f2 [i915]
Jul 24 21:58:24 windbuddy kernel: [<c04e2bfd>] ? ext3_file_write+0x21/0x90
Jul 24 21:58:24 windbuddy kernel: [<c04a0123>] ? do_sync_write+0xb0/0xeb
Jul 24 21:58:24 windbuddy kernel: [<c04aa494>] vfs_ioctl+0x5a/0x74
Jul 24 21:58:24 windbuddy kernel: [<c04aad3d>] do_vfs_ioctl+0x480/0x4ba
Jul 24 21:58:24 windbuddy kernel: [<c0707b79>] ? _spin_lock_irq+0x21/0x25
Jul 24 21:58:24 windbuddy kernel: [<c049fe7a>] ? fsnotify_modify+0x59/0x64
Jul 24 21:58:24 windbuddy kernel: [<c046517f>] ? audit_syscall_entry+0x163/0x185
Jul 24 21:58:24 windbuddy kernel: [<c04aadbd>] sys_ioctl+0x46/0x66
Jul 24 21:58:24 windbuddy kernel: [<c0403f72>] syscall_call+0x7/0xb
Jul 24 21:58:24 windbuddy kernel: ---[ end trace 718be2b3a724220b ]---

Portion of messages log pertinent to issue attached to BZ.

Hardware:
MSI Wind u100
2GB RAM (single so-dimm)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

Comment 1 Adam Drew 2009-07-25 02:40:28 UTC
Issue is not high priority. Using one display is acceptable work around. Wanted to document issue.

Comment 2 Robert de Rooy 2009-11-09 22:28:44 UTC
I seem to have the same issue on a ThinkPad T60 with 945GM running F12 x86_64.
When I have compiz enabled, enabling extended desktop freezes the system hard. Extended desktop or compiz can be used independent of each other, but not together.

nothing in syslog as to the failure.

kernel-2.6.31.5-122.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
xorg-x11-server-Xorg-1.7.1-7.fc12.x86_64

Comment 3 Stefan Mayer 2009-11-18 08:28:41 UTC
I have the same problem on my Asus EEEPC 1000H. Connecting an external monitor causes the system to hang when compiz is enabled. When I disable compiz everything works fine.
I'm using Fedora 12, 
kernel-2.31.5.-127.fc12.i686
xorg-x11-drv-intel-2.9.1-1.fc12.i686
xorg-x11-server-Xorg-1.7.1-7.fc12.i686

Comment 4 Peter Dieth 2010-01-06 21:40:34 UTC
I have the same problem on my Dell D420 subnotebook running Fedora 12 with latest patches.
Connecting my Sony LCD TV (1360x768) using a VGA cable causes
the system to hang when compiz is enabled.


Linux foxy 2.6.31.9-174.fc12.i686.PAE #1 SMP Mon Dec 21 06:04:56 UTC 2009 i686 i686 i386 GNU/Linux

kernel-PAE-2.6.31.9-174.fc12.i686
xorg-x11-drv-intel-2.9.1-1.fc12.i686
xorg-x11-server-Xorg-1.7.1-7.fc12.i686

Cheers,
Peter

Comment 5 Robert de Rooy 2010-01-14 09:59:10 UTC
I just tried it with the latest builds, and the situation has changed.

When I already have a secondary monitor set for "extended desktop", and then try to enable compiz, it fails with a message that it failed to start, and reverts to the previous settings. This is obviously preferable to the hang experienced previously.

But when I already have compiz enabled, and then add a secondary monitor and enable extended desktop, compiz crashes and I no longer have a window manager.

Here is what I see in syslog, in either case;
compiz[21756]: segfault at 0 ip (null) sp 00007fff8a2e3618 error 14 in compiz[400000+3b000]
Process 21756(compiz) has RLIMIT_CORE set to 0
Aborting core

kernel-2.6.32.3-24.fc12.x86_64
libdrm-2.4.17-1.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
xorg-x11-server-Xorg-1.7.4-1.fc12.x86_64
compiz-0.8.2-21.fc12.x86_64

Comment 6 Sitsofe Wheeler 2010-03-06 18:29:30 UTC
This sounds like https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/419328 ...

Comment 7 Robert de Rooy 2010-03-10 13:48:16 UTC
I just tried F13 Alpha, and there is no change from comment #5

xorg-x11-drv-intel-2.10.0-4.fc13
kernel-2.6.33-8.fc13

Comment 8 Matěj Cepl 2010-03-12 08:31:25 UTC
OK, but comment 5 sounds very much like compiz crashing, not Xorg crashing. Reassigning.

Comment 9 Robert de Rooy 2010-03-12 09:54:37 UTC
Yes, with the latest updates on F12, or with F13alpha the system no longer freezes, but compiz crashes.

Not sure what should happen. The problem is that compiz on the i945GM does not work if horizontal or vertical desktop resolution exceeds 2048. Which is typically something you will trigger if your running a dual-monitor (extended desktop) config.

There are various limitations currently on the i945 chips when exceeding 2048 pixels (e.g. Xvideo breaks bz497069).

So there are really two issues as I see them
* if compiz unexpectedly crashes you end up without a window manager. Perhaps somehow metacity should be started in such cases. This is already checked for in the case where you start Compiz from "Desktop Effects", and in that case you get an error and Metacity is restarted. But when Compiz is running and you add a second monitor and exceed the 2048 limit it crashes and nothing is there to start Metacity as a fall-back.
* i945 limitations, from various ML posts it would seem some driver workarounds may be possible, but is anyone interested in doing them...

Comment 10 Jeff Raber 2010-04-28 00:58:58 UTC
Could somebody able to reproduce this bug please attach a stacktrace showing the compiz crash?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Robert de Rooy 2010-04-28 06:58:45 UTC
libdrm-2.4.18-2.fc12.x86_64
xorg-x11-drv-intel-2.9.1-1.fc12.x86_64
compiz-0.8.2-24.fc12.x86_64
kernel-2.6.32.11-102.fc12.x86_64

Graphics chip is the i945 in this case, and resolution was 3000x1200 (1400x1050 + 1600x1200), which exceeds the 2048 limit.

"debuginfo-install compiz" claims there are no updated packages to install, yet abrt complains the backtrace is unusable.

Core was generated by `compiz --ignore-desktop-hints glib gconf gnomecompat --replace'.
Program terminated with signal 11, Segmentation fault.
#0  0x0000000000000000 in ?? ()

Thread 1 (Thread 8692):
#0  0x0000000000000000 in ?? ()
No symbol table info available.
#1  0x00007fe00a25c7c0 in sample_nearest_2d (ctx=0x17b1190, tObj=0x1c1a050, 
    n=<value optimized out>, texcoords=0x7fff0c00c6c0, 
    lambda=<value optimized out>, rgba=<value optimized out>)
    at swrast/s_texfilter.c:1289
        i = 0
        image = 0x1c18d60
#2  0x00007fe00a25135c in fetch_texel_deriv (ctx=<value optimized out>, 
    texcoord=0x7fff0c00c6c0, texdx=<value optimized out>, 
    texdy=<value optimized out>, lodBias=<value optimized out>, 
    unit=<value optimized out>, color=0x7fff0c00c6d0)
    at swrast/s_fragprog.c:122
        texImg = <value optimized out>
        texW = Cannot access memory at address 0x2c0

From                To                  Syms Read   Shared Object Library
0x00000033fa200b40  0x00000033fa201918  Yes (*)     /usr/lib64/libXcomposite.so.1.0.0
0x00000033f8600a90  0x00000033f8601638  Yes (*)     /usr/lib64/libXdamage.so.1.1.0
0x00000033f8e01370  0x00000033f8e04178  Yes (*)     /usr/lib64/libXfixes.so.3.1.0
0x00000033f7601720  0x00000033f7606828  Yes (*)     /usr/lib64/libXrandr.so.2.2.0
0x00000033f7a00a20  0x00000033f7a01508  Yes (*)     /usr/lib64/libXinerama.so.1.0.0
0x00000033fee019f0  0x00000033fee062a8  Yes (*)     /usr/lib64/libSM.so.6.0.0
0x00000033fea04d70  0x00000033fea137a8  Yes (*)     /usr/lib64/libICE.so.6.3.0
0x000000340aa0a9e0  0x000000340aa2eed8  Yes (*)     /usr/lib64/libxslt.so.1.1.26
0x00000033f2a01ef0  0x00000033f2a0d228  Yes (*)     /lib64/libz.so.1.2.3
0x00000033fde2c600  0x00000033fdf07ef8  Yes (*)     /usr/lib64/libxml2.so.2.7.6
0x0000003408e030a0  0x0000003408e06938  Yes (*)     /usr/lib64/libstartup-notification-1.so.0.0.0
0x00000033fd61f410  0x00000033fd653958  Yes (*)     /usr/lib64/libGL.so.1.2
0x00000033f1e03ea0  0x00000033f1e44318  Yes (*)     /lib64/libm-2.11.1.so
0x00000033f1a1e860  0x00000033f1b2615c  Yes (*)     /lib64/libc-2.11.1.so
0x00000033f421dd80  0x00000033f42ab8c8  Yes (*)     /usr/lib64/libX11.so.6.3.0
0x00000033f5603580  0x00000033f560e768  Yes (*)     /usr/lib64/libXext.so.6.4.0
0x00000033f2600de0  0x00000033f2601998  Yes (*)     /lib64/libdl-2.11.1.so
0x00000033f6e018c0  0x00000033f6e07f58  Yes (*)     /usr/lib64/libXrender.so.1.3.0
0x00000033fc6013d0  0x00000033fc6029e8  Yes (*)     /lib64/libuuid.so.1
0x0000003408601160  0x0000003408601b28  Yes (*)     /usr/lib64/libxcb-aux.so.0
0x00000034092018e0  0x0000003409201c78  Yes (*)     /usr/lib64/libxcb-event.so.1
0x0000003408201690  0x0000003408201d38  Yes (*)     /usr/lib64/libxcb-atom.so.1
0x00000033f4a08650  0x00000033f4a13898  Yes (*)     /usr/lib64/libxcb.so.1
0x00000033fce00e30  0x00000033fce03d08  Yes (*)     /usr/lib64/libXxf86vm.so.1
0x00000033fbe02f90  0x00000033fbe07858  Yes (*)     /usr/lib64/libdrm.so.2
0x00000033f2205390  0x00000033f2210918  Yes (*)     /lib64/libpthread-2.11.1.so
0x00000033f1600af0  0x00000033f1618434  Yes (*)     /lib64/ld-2.11.1.so
0x00000033f4600dd0  0x00000033f4601b68  Yes (*)     /usr/lib64/libXau.so.6
0x00000033f2e02140  0x00000033f2e05578  Yes (*)     /lib64/librt-2.11.1.so
0x00000033fb602880  0x00000033fb607658  Yes (*)     /usr/lib64/libXcursor.so.1
0x00007fe00a54bec0  0x00007fe00a5a07d8  Yes (*)     /usr/lib64/dri/i915_dri.so
0x00007fe00a14b6f0  0x00007fe00a2920a8  Yes (*)     /usr/lib64/dri/libdricore.so
0x00000033f3605550  0x00000033f3615028  Yes (*)     /lib64/libselinux.so.1
0x00000033f6603b70  0x00000033f661c9d8  Yes (*)     /lib64/libexpat.so.1
0x00007fe009f16790  0x00007fe009f1bce8  Yes (*)     /usr/lib64/libdrm_intel.so.1
0x00007fe009848c20  0x00007fe009849298  Yes (*)     /usr/lib64/compiz/libglib.so
0x00000033f32132f0  0x00000033f328a1f8  Yes (*)     /lib64/libglib-2.0.so.0
0x00007fe009645dc0  0x00007fe0096470b8  Yes (*)     /usr/lib64/compiz/libgconf.so
0x00000033fd211ae0  0x00000033fd22d9e8  Yes (*)     /usr/lib64/libgconf-2.so.4
0x00000033f4e01080  0x00000033f4e01fd8  Yes (*)     /lib64/libgmodule-2.0.so.0
0x00000033fca278c0  0x00000033fca4b418  Yes (*)     /usr/lib64/libORBit-2.so.0
0x00000033f8a070a0  0x00000033f8a2e328  Yes (*)     /lib64/libdbus-1.so.3.4.0
0x00000033f3a08890  0x00000033f3a31e18  Yes (*)     /lib64/libgobject-2.0.so.0
0x00000033f5a01590  0x00000033f5a029e8  Yes (*)     /lib64/libgthread-2.0.so.0
0x00000033f7e01270  0x00000033f7e02d88  Yes (*)     /lib64/libcap-ng.so.0
0x00007fe009439110  0x00007fe009440a08  Yes (*)     /lib64/libnss_files-2.11.1.so
0x00007fe009235e00  0x00007fe009236468  Yes (*)     /usr/lib64/compiz/libgnomecompat.so
(*): Shared library is missing debugging information.
$1 = 0x0
No symbol "__glib_assert_msg" in current context.
rax            0x4ae	1198
rbx            0x1c1a050	29466704
rcx            0x0	0
rdx            0x4ae	1198
rsi            0x288	648
rdi            0x1c18d60	29461856
rbp            0x17b1190	0x17b1190
rsp            0x7fff0c00c568	0x7fff0c00c568
r8             0x7fff0c00c610	140733394765328
r9             0x0	0
r10            0x0	0
r11            0x8001	32769
r12            0x0	0
r13            0x0	0
r14            0x7fff0c00c6c0	140733394765504
r15            0x1c18d60	29461856
rip            0x0	0
eflags         0x10246	[ PF ZF IF RF ]
cs             0x33	51
ss             0x2b	43
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
fctrl          0x37f	895
fstat          0x0	0
ftag           0xffff	65535
fiseg          0x0	0
fioff          0x0	0
foseg          0x0	0
fooff          0x0	0
fop            0x0	0
mxcsr          0x1fa5	[ IE ZE PE IM DM ZM OM UM PM ]
No function contains program counter for selected frame.

Comment 12 Robert de Rooy 2010-04-28 08:00:29 UTC
Created attachment 409710 [details]
compiz backtrace on F13

On Fedora 13 Beta I was able to get a full backtrace.

Comment 13 Jeff Raber 2010-04-28 15:25:02 UTC
Looks like a driver issue.  Assigned to xorg-x11-drv-intel

This bug has been triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Jeff Raber 2010-04-28 20:48:51 UTC
*** Bug 585705 has been marked as a duplicate of this bug. ***

Comment 15 Jeff Raber 2010-07-06 21:14:02 UTC
Robert; Looks like you are experiencing bug 557027.

Is anyone with an updated system still experiencing the original bug (the kernel oops + freeze)?

Comment 16 Robert de Rooy 2010-07-07 09:42:26 UTC
Jeff,

Yes, I guess that bug should be marked a duplicate of this one. They are clearly running into the 2048 limit of the 945GM chip.

As to the kernel crash I have not experienced that since the 2.6.32 kernels. But I also have to add that I just got a new ThinkPad and as such no longer have suitable hardware to help test or debug this issue.

Comment 17 Jeff Raber 2010-07-07 13:03:37 UTC
The bug reported here is regarding a Kernel oops and a freeze (which I suspect has been resolved).  The root cause may be the same as bug 557027, but they are not the same bug.  I recommend that you add yourself to the CC list of bug 557027.  If nobody is still experiencing this bug I will close it as ERRATA.

NEEDINFO:

Is anyone with fully updated system still experiencing the bug reported here (the
kernel oops + freeze)?  Unless someone is still able to reproduce the crash, I will close this bug in 30days as ERRATA.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 Bug Zapper 2010-11-04 10:41:25 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 19 Bug Zapper 2010-12-05 06:41:00 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.