Bug 704863 - virt-manager error caused by connect_cdrom() : unsupported driver name 'file'
virt-manager error caused by connect_cdrom() : unsupported driver name 'file'
Status: CLOSED DUPLICATE of bug 641858
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.6
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-15 10:48 EDT by Johnny Hughes
Modified: 2011-07-12 19:22 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 516116
Environment:
Last Closed: 2011-07-12 19:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Hughes 2011-05-15 10:48:54 EDT
+++ This bug was initially created as a clone of Bug #516116 +++

virt-manager-0.8.0-1.fc12.noarch

In v-m-m
create a vm attaching a livecd iso as the insall media
do not attach any storage.
Try to boot.
Turn it off.
go to vm->details->Disk vda
clicked the 'disconnect' button
click 'connect'
choose the same file you just disconnected.
try to start the vm
get this error


Error starting domain: internal error unsupported driver name 'file' for disk '/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 567, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 652, in startup
    self.vm.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 293, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unsupported driver name 'file' for disk '/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso'

--- Additional comment from markmc@redhat.com on 2009-08-11 14:12:39 EDT ---

Could you include ~/.virt-manager/virt-manager.log and
/var/log/libvirt/qemu/$guest.log ?

--- Additional comment from eparis@redhat.com on 2009-08-11 15:49:53 EDT ---

Created attachment 357071 [details]
virt-manager.log

--- Additional comment from eparis@redhat.com on 2009-08-11 15:50:59 EDT ---

The guest.log is empty.

--- Additional comment from markmc@redhat.com on 2009-08-14 12:55:11 EDT ---

Here's the interesting bit:

 connect_cdrom produced: 
   <disk type="file" device="cdrom">
      <driver name="file" type=""/>
      <target dev="vda" bus="virtio"/>
      <readonly/>
      <source file="/var/lib/libvirt/images/Fedora-11-x86_64-Live.iso"/>
   </disk>

it should be name="qemu", not name="file"

The code causing the problem was introduced in:

  http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virt-manager--devel/rev/f4107609ab7d

Need to consider the Xen implications when fixing

--- Additional comment from crobinso@redhat.com on 2009-08-31 09:30:03 EDT ---

*** Bug 520171 has been marked as a duplicate of this bug. ***

--- Additional comment from kevin@scrye.com on 2009-09-07 16:32:42 EDT ---

I'm seeing this here as well, any idea when a fix might land? 

virt-install doesn't seem to have this issue.

--- Additional comment from crobinso@redhat.com on 2009-09-14 11:21:10 EDT ---

*** Bug 522307 has been marked as a duplicate of this bug. ***

--- Additional comment from crobinso@redhat.com on 2009-09-14 12:04:30 EDT ---

Fixed in virt-manager-0.8.0-3.fc12

===============================================================
This bug now seems to be in the latest version of virt-manager for RHEL 5.6, version virt-manager-0.6.1-13.el5
Comment 1 Cole Robinson 2011-07-12 19:22:52 EDT

*** This bug has been marked as a duplicate of bug 641858 ***

Note You need to log in before you can comment on or make changes to this bug.