Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 519784 - installation to harddisk creating parition from free disk space
Summary: installation to harddisk creating parition from free disk space
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 12
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:a4f67a05ff4599138...
: 518894 519789 520031 520188 520778 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-27 19:16 UTC by Dennis
Modified: 2012-09-05 09:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-23 19:29:23 UTC
Type: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (83.50 KB, text/plain)
2009-08-27 19:16 UTC, Dennis
no flags Details
report saved through gui (211.41 KB, text/plain)
2009-09-02 14:24 UTC, IBM Bug Proxy
no flags Details
tar.gz files from /tmp/ directory (56.41 KB, application/octet-stream)
2009-09-02 14:24 UTC, IBM Bug Proxy
no flags Details
Attached traceback automatically from anaconda. (92.88 KB, text/plain)
2012-09-05 09:00 UTC, leejiwon
no flags Details
Attached traceback automatically from anaconda. (92.93 KB, text/plain)
2012-09-05 09:08 UTC, leejiwon
no flags Details

Description Dennis 2009-08-27 19:16:35 UTC
The following was filed automatically by anaconda:
anaconda 11.5.0.59-1.fc11 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 183, in addPartition
    constraint.getPedConstraint())
  File "/usr/lib/anaconda/storage/partitioning.py", line 827, in allocatePartitions
    constraint=constraint)
  File "/usr/lib/anaconda/storage/partitioning.py", line 587, in doPartitioning
    allocatePartitions(disks, partitions)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1017, in refresh
    doPartitioning(self.storage)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1125, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 974, in newCB
    self.editPartition(device, isNew=1)
PartitionException: Too many primary partitions.

Comment 1 Dennis 2009-08-27 19:16:52 UTC
Created attachment 358946 [details]
Attached traceback automatically from anaconda.

Comment 2 Chris Lumens 2009-08-27 19:29:40 UTC
*** Bug 519789 has been marked as a duplicate of this bug. ***

Comment 3 Dennis 2009-08-27 19:40:15 UTC
I have 2 300GB HDDs
on disk0  I have ntfs partitions with windows XP installed on one of the
partition.  There is a 200GB free space.
on disk1 I have ntfs partitions

Booted the fedora 11 from DVD
onced logged into the fedora core desktop
clicked on the install 'to hard drive' icon.
fedora installer windows comes up, clicked next
selected language, clicked next
created the hostname, clicked next
selected the time zone, clicked next
created the root password, clicked next
create custom layout, clicked next
selected the free space, clicked 'new'

mount point - selected root

gives me the error

Comment 4 Chris Lumens 2009-08-28 13:44:41 UTC
*** Bug 520031 has been marked as a duplicate of this bug. ***

Comment 5 David Lehman 2009-08-28 16:04:03 UTC
There was a bug that caused anaconda to try to create another primary partition in the case where the disk starts out with four primaries.

A fix will be in anaconda-12.18-1.

Comment 6 Chris Lumens 2009-08-28 20:00:38 UTC
*** Bug 520188 has been marked as a duplicate of this bug. ***

Comment 7 Chris Lumens 2009-08-31 18:25:08 UTC
*** Bug 518894 has been marked as a duplicate of this bug. ***

Comment 8 Dennis 2009-09-01 20:14:17 UTC
Hi Dave and Chris

When will the Anaconda-12.18-1 fix be out for download?

Thanks

Comment 9 Chris Lumens 2009-09-02 14:13:11 UTC
*** Bug 520778 has been marked as a duplicate of this bug. ***

Comment 10 IBM Bug Proxy 2009-09-02 14:24:03 UTC
Created attachment 359533 [details]
report saved through gui

Comment 11 IBM Bug Proxy 2009-09-02 14:24:12 UTC
Created attachment 359534 [details]
tar.gz files from /tmp/ directory

Comment 12 Bug Zapper 2009-11-16 11:47:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 IBM Bug Proxy 2010-06-14 22:10:50 UTC
------- Comment From edpollar@linux.ibm.com 2010-06-14 18:02 EDT-------
reassigning...

Poornima, you had taken a look at this one previously it looks like.

Comment 14 leejiwon 2012-09-05 09:00:12 UTC
Created attachment 609910 [details]
Attached traceback automatically from anaconda.

Comment 15 leejiwon 2012-09-05 09:08:27 UTC
Created attachment 609915 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.