Bug 526035 - entertainer crashes on start
entertainer crashes on start
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: entertainer (Show other bugs)
12
All Linux
high Severity urgent
: ---
: ---
Assigned To: Julian Aloofi
Fedora Extras Quality Assurance
: StudentProject
: 543264 563244 568994 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-28 09:03 EDT by Rahul Sundaram
Modified: 2013-03-13 01:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 08:29:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 441515 None None None Never

  None (edit)
Description Rahul Sundaram 2009-09-28 09:03:28 EDT
Description of problem:

in rawhide, entertainer doesn't start

Traceback (most recent call last):
  File "/usr/bin/entertainer", line 12, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/__init__.py", line 22, in main
    from entertainerlib.frontend.frontend_client import FrontendClient
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/frontend_client.py", line 13, in <module>
    from entertainerlib.frontend.gui.user_interface import UserInterface
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/user_interface.py", line 20, in <module>
    from entertainerlib.frontend.gui.screens.factory import ScreenFactory
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/screens/factory.py", line 7, in <module>
    from entertainerlib.frontend.gui.screens.artist import Artist
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/screens/artist.py", line 9, in <module>
    from entertainerlib.frontend.gui.screens.screen import Screen
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/screens/screen.py", line 14, in <module>
    from entertainerlib.frontend.gui.widgets.tab_group import TabGroup
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/widgets/tab_group.py", line 10, in <module>
    from entertainerlib.frontend.gui.widgets.label import Label
  File "/usr/lib/python2.6/site-packages/entertainerlib/frontend/gui/widgets/label.py", line 11, in <module>
    class Label(Base, clutter.Label):
AttributeError: 'module' object has no attribute 'Label'

$ rpm -q entertainer clutter pyclutter pyclutter-gtk 
entertainer-0.4.2-6.fc12.noarch
clutter-1.0.6-1.fc12.i686
pyclutter-0.9.2-1.fc12.i686
pyclutter-gtk-0.9.2-1.fc12.i686
Comment 1 Julian Aloofi 2009-09-28 09:38:01 EDT
Thank you very much, I'm working on the update!
Comment 2 Julian Aloofi 2009-09-28 10:33:16 EDT
I issued an update, it should help.
Comment 3 Rahul Sundaram 2009-09-28 10:50:34 EDT
Just to be clear, I filed a separate bug report on the missing dependency issue at #526033. This one is a unrelated traceback that doesnt get fixed by merely installing the missing dependency.
Comment 4 Julian Aloofi 2009-09-28 11:54:47 EDT
Oh sorry, mixed the URL's. I'm working on this one now.
Comment 5 Julian Aloofi 2009-09-28 12:19:45 EDT
Looks like clutter.Label was dropped in newer pyclutter versions and replaced with clutter.Text.
I will set up a VM with rawhide, try to rewrite the class to use clutter.Text and push the changes upstream.
I don't know whether Rawhide still knows about older package versions, but would it help to explicitly require pyclutter 0.8? If not the package is unusable until I got a patch working or upstream releases a new version that fixes this.
Comment 6 Rahul Sundaram 2009-09-28 14:38:14 EDT
I don't think pulling in a older version of pyclutter (and deps) is desirable. It would be better to talk to upstream about this issue and send a patch if necessary.
Comment 7 Julian Aloofi 2009-10-03 12:55:22 EDT
Reported the bug upstream, will try to write a patch if I can. Unfortunately I'm not a very experienced coder.
Comment 8 Bug Zapper 2009-11-16 08:02:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Rahul Sundaram 2009-11-16 14:57:43 EST
Upstream report at 

https://bugs.launchpad.net/entertainer/+bug/441515
Comment 10 Julian Aloofi 2009-11-18 09:53:43 EST
Looks like the API break in label.py was only the tip of the iceberg., there were even more changes.
An upstream developer fixed the massive API changes. However he only does so in an unofficial branch ( https://code.launchpad.net/~francesco-marella/entertainer/future-fixes ) that is not included in the main branch yet, and also requires the "future" series of the package, which is their development playground.
I tried to backport the changes to the stable version, but they are pretty extensive, I can't do it.

This app does not work in Fedora 12. Is updating to the "future" branch and using the unofficial patches (which hopefully will get merged into the main branch soon) a reasonable solution? (after extensive testing of course)
After first tests, the version from "future" rather feels like beta software, so I'd not really be happy with that.


If not, what can I do to get this excluded from the repos as long as upstream doesn't release a stable release that works with our pyclutter version?
Comment 11 Rahul Sundaram 2009-11-18 19:11:19 EST
"Future" branch update would be improvement over what we have now - just a straight crash. It isn't possible to exclude this package at this point.
Comment 12 Julian Aloofi 2009-11-19 12:02:52 EST
I'll update the package to the future branch then.
Comment 13 Fedora Update System 2009-11-25 09:09:56 EST
entertainer-0.4.2-8.20091120bzr.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/entertainer-0.4.2-8.20091120bzr.fc12
Comment 14 Rahul Sundaram 2009-11-27 14:52:39 EST
This doesn't fix the problem. It still crashes but with a different error


$ rpm -q entertainer
entertainer-0.4.2-8.20091120bzr.fc12.noarch
$ entertainer
/usr/lib/python2.6/site-packages/twisted/internet/_sslverify.py:5: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import itertools, md5
/usr/lib/python2.6/site-packages/twisted/python/filepath.py:12: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
Traceback (most recent call last):
  File "/usr/bin/entertainer", line 9, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/entertainerlib/client/__init__.py", line 29, in main
    config = Configuration()
  File "/usr/lib/python2.6/site-packages/entertainerlib/configuration.py", line 54, in __init__
    self.theme = Theme(self.theme_path)
  File "/usr/lib/python2.6/site-packages/entertainerlib/configuration.py", line 127, in theme_path
    theme = self.content.get("General", "theme")
  File "/usr/lib/python2.6/ConfigParser.py", line 531, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'General'
Comment 15 Fedora Update System 2009-11-27 16:38:32 EST
entertainer-0.4.2-8.20091120bzr.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update entertainer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12206
Comment 16 Julian Aloofi 2009-11-27 17:53:30 EST
For some strange reason I can't reproduce that.
$ rpm -q entertainer
entertainer-0.4.2-8.20091120bzr.fc12.noarch

$ entertainer
/usr/lib/python2.6/site-packages/twisted/internet/_sslverify.py:5:
DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import itertools, md5
/usr/lib/python2.6/site-packages/twisted/python/filepath.py:12:
DeprecationWarning: the sha module is deprecated; use the hashlib module
instead
  import sha
Entertainer backend starting...

And it starts all right, although it produces some warnings like:

(/usr/bin/entertainer:5856): Clutter-WARNING **: Attempting to map a child that does not meet the necessary invariants: the actor has no parent
Comment 17 Rahul Sundaram 2009-11-27 18:14:39 EST
This is what I have

rpm -q clutter pyclutter

clutter-1.0.6-1.fc12.i686
pyclutter-0.9.2-1.fc12.i686
Comment 18 Shreyank Gupta 2009-11-27 18:25:08 EST
I got a crash too!

/usr/lib/python2.6/site-packages/twisted/internet/_sslverify.py:5: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import itertools, md5
/usr/lib/python2.6/site-packages/twisted/python/filepath.py:12: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
  import sha
Entertainer backend starting...
Exception in thread IndexerThread (most likely raised during interpreter shutdown):Exception in thread IndexerThread (most likely raised during interpreter shutdown):

Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_innerTraceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/entertainerlib/backend/components/mediacache/indexer_thread.py", line 65, in run
  File "/usr/lib/python2.6/site-packages/entertainerlib/backend/components/mediacache/video_cache.py", line 127, in addDirectory

  File "/usr/lib/python2.6/os.py", line 284, in walk
  File "/usr/lib/python2.6/genericpath.py", line 44, in isdir  File "/usr/lib/python2.6/threading.py", line 525, in __bootstrap_inner
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'S_ISDIR'

entertainer-0.4.2-8.20091120bzr.fc12.noarch
pyclutter-0.9.2-1.fc12.i686
clutter-1.0.6-1.fc12.i686
Comment 19 Julian Aloofi 2009-11-27 18:45:07 EST
I suppose I have to wait until upstream releases a fixed version? I can't do anything about it.
Comment 20 Rahul Sundaram 2009-11-27 19:44:24 EST
The least you can do is make them aware of it.
Comment 21 Julian Aloofi 2009-12-02 11:10:59 EST
*** Bug 543264 has been marked as a duplicate of this bug. ***
Comment 22 Julian Aloofi 2010-01-23 05:57:08 EST
Upstream fixed this in trunk now. I currently don't have the time to update the package, but I will get this ready in Rawhide before Alpha freeze if no further problems with the package appear.
Comment 23 Alfredo Pons Menargues 2010-02-09 11:31:20 EST
*** Bug 563244 has been marked as a duplicate of this bug. ***
Comment 24 Julian Aloofi 2010-02-16 08:21:05 EST
I have checked out the upstream code several times now, and it only got one update since my last comment. The program starts up now and shows the interface, but playing music for example completely fails for me, and it also doesn't overlap the Gnome panels. I was able to produce backtrace and will push that upstream. So what's the preferred solution now? There currently is a release version that doesn't work at all and a trunk version that doesn't provide any functionality except of a nice clutter main menu, and RSS headlines.
When starting the entertainer-backend before the program itself it's possible to rebuild the media library cache with the entertainer-manager, but then the media center itself doesn't work anymore (crashes with another error before displaying anything at all).

I personally would just like to get this package out of the release, as it obviosuly doesn't match any quality criterias one would have. Should I file a ticket at releng?
Comment 25 Julian Aloofi 2010-02-16 08:21:54 EST
(In reply to comment #24)

> I personally would just like to get this package out of the release, as it

Clarification: F13 release
Comment 26 Rahul Sundaram 2010-02-16 08:29:10 EST
Sad but yes retire it and file it with rel-eng
Comment 27 Julian Aloofi 2010-02-16 09:13:00 EST
I filed a ticket: https://fedorahosted.org/rel-eng/ticket/3410
Comment 28 Julian Aloofi 2010-02-27 14:05:22 EST
*** Bug 568994 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.