Bug 526377 - Depsolving problem with latest updates (ibus and rubygem-activerecord)
Summary: Depsolving problem with latest updates (ibus and rubygem-activerecord)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 526358 526417 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-30 03:36 UTC by bugfinder
Modified: 2009-11-04 01:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-04 01:38:59 UTC


Attachments (Terms of Use)

Description bugfinder 2009-09-30 03:36:03 UTC
ibus-m17n-1.1.0.20090211-5.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-m17n-1.1.0.20090211-5.fc11.i586 (installed)
ibus-chewing-1.2.0.20090917-1.fc11.i586 from updates has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-chewing-1.2.0.20090917-1.fc11.i586 (updates)
ibus-rawcode-1.0.0.20090303-3.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-rawcode-1.0.0.20090303-3.fc11.i586 (installed)
rubygem-activerecord-2.3.2-1.fc11.noarch from installed has depsolving problems
  --> Missing Dependency: rubygem(activesupport) = 2.3.2 is needed by package rubygem-activerecord-2.3.2-1.fc11.noarch (installed)
ibus-hangul-1.1.0.20090328-2.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-hangul-1.1.0.20090328-2.fc11.i586 (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-hangul-1.1.0.20090328-2.fc11.i586 (installed)
Error: Missing Dependency: rubygem(activesupport) = 2.3.2 is needed by package rubygem-activerecord-2.3.2-1.fc11.noarch (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-chewing-1.2.0.20090917-1.fc11.i586 (updates)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-m17n-1.1.0.20090211-5.fc11.i586 (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-rawcode-1.0.0.20090303-3.fc11.i586 (installed)

Comment 1 James Antill 2009-09-30 03:51:10 UTC
I just saw the ibus one myself, you can work around by removing bits of ibus (or just removing ibus-libs :).

You'll want to open a second BZ for the ruby stuff (against the ruby packages).

Comment 2 Mamoru TASAKA 2009-09-30 04:42:56 UTC
For rubygem-activerecord, see bug 520843

Comment 3 Jens Petersen 2009-09-30 07:42:05 UTC
ibus updates are on their way:
https://admin.fedoraproject.org/updates/search/ibus

Comment 4 Rex Dieter 2009-09-30 16:00:37 UTC
*** Bug 526358 has been marked as a duplicate of this bug. ***

Comment 5 Rex Dieter 2009-09-30 16:00:43 UTC
*** Bug 526417 has been marked as a duplicate of this bug. ***

Comment 6 Andre Robatino 2009-10-01 05:51:22 UTC
Fixed for me with latest F11 updates (I'm on x86_64, so the Platform should be "All Linux").


Note You need to log in before you can comment on or make changes to this bug.