Bug 526377 - Depsolving problem with latest updates (ibus and rubygem-activerecord)
Depsolving problem with latest updates (ibus and rubygem-activerecord)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
: 526358 526417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-29 23:36 EDT by bugfinder
Modified: 2009-11-03 20:38 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-03 20:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bugfinder 2009-09-29 23:36:03 EDT
ibus-m17n-1.1.0.20090211-5.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-m17n-1.1.0.20090211-5.fc11.i586 (installed)
ibus-chewing-1.2.0.20090917-1.fc11.i586 from updates has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-chewing-1.2.0.20090917-1.fc11.i586 (updates)
ibus-rawcode-1.0.0.20090303-3.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-rawcode-1.0.0.20090303-3.fc11.i586 (installed)
rubygem-activerecord-2.3.2-1.fc11.noarch from installed has depsolving problems
  --> Missing Dependency: rubygem(activesupport) = 2.3.2 is needed by package rubygem-activerecord-2.3.2-1.fc11.noarch (installed)
ibus-hangul-1.1.0.20090328-2.fc11.i586 from installed has depsolving problems
  --> Missing Dependency: libibus.so.0 is needed by package ibus-hangul-1.1.0.20090328-2.fc11.i586 (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-hangul-1.1.0.20090328-2.fc11.i586 (installed)
Error: Missing Dependency: rubygem(activesupport) = 2.3.2 is needed by package rubygem-activerecord-2.3.2-1.fc11.noarch (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-chewing-1.2.0.20090917-1.fc11.i586 (updates)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-m17n-1.1.0.20090211-5.fc11.i586 (installed)
Error: Missing Dependency: libibus.so.0 is needed by package ibus-rawcode-1.0.0.20090303-3.fc11.i586 (installed)
Comment 1 James Antill 2009-09-29 23:51:10 EDT
I just saw the ibus one myself, you can work around by removing bits of ibus (or just removing ibus-libs :).

You'll want to open a second BZ for the ruby stuff (against the ruby packages).
Comment 2 Mamoru TASAKA 2009-09-30 00:42:56 EDT
For rubygem-activerecord, see bug 520843
Comment 3 Jens Petersen 2009-09-30 03:42:05 EDT
ibus updates are on their way:
https://admin.fedoraproject.org/updates/search/ibus
Comment 4 Rex Dieter 2009-09-30 12:00:37 EDT
*** Bug 526358 has been marked as a duplicate of this bug. ***
Comment 5 Rex Dieter 2009-09-30 12:00:43 EDT
*** Bug 526417 has been marked as a duplicate of this bug. ***
Comment 6 Andre Robatino 2009-10-01 01:51:22 EDT
Fixed for me with latest F11 updates (I'm on x86_64, so the Platform should be "All Linux").

Note You need to log in before you can comment on or make changes to this bug.