Bug 527426 - (plymouth) No text prompt for encryption password (but keyboard input is accepted)
(plymouth) No text prompt for encryption password (but keyboard input is acce...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: Reopened
: 528300 528880 529006 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-06 07:29 EDT by Tim Waugh
Modified: 2009-10-26 23:00 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 23:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-10-06 07:29:54 EDT
Description of problem:
When booting an encrypted system that does not have KMS available, there is no text prompt for the encryption password.  The boot just stops with a blank screen.

Entering the password and pressing Return continues the boot, so if you know that's why it's paused it's OK.

Version-Release number of selected component (if applicable):
plymouth-0.8.0-0.2009.29.09.3.fc12.x86_64

How reproducible:
100%
Comment 1 Michal Hlavinka 2009-10-12 02:16:44 EDT
the same here, with plymouth-0.8.0-0.2009.29.09.9.fc12.x86_64

if esc is pressed when there is blank screen waiting for passphrase, the passphrase prompt shows up
Comment 2 Ray Strode [halfline] 2009-10-14 10:18:48 EDT
*** Bug 528300 has been marked as a duplicate of this bug. ***
Comment 3 Ray Strode [halfline] 2009-10-14 10:19:24 EDT
*** Bug 528880 has been marked as a duplicate of this bug. ***
Comment 4 Ray Strode [halfline] 2009-10-14 11:36:48 EDT
A fix for this is building into koji now:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1746140
Comment 5 Ray Strode [halfline] 2009-10-14 11:38:35 EDT
*** Bug 529006 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2009-10-14 15:11:38 EDT
.12.fc12 did not fix this issue.
Comment 7 Tim Waugh 2009-10-14 16:06:28 EDT
Same here.  Updated the initrd with dracut, but no password prompt.
Comment 8 Tim Waugh 2009-10-26 05:12:38 EDT
Oh, it works fine now.  The kernel update must have done something I didn't do when testing before.
Comment 9 Ray Strode [halfline] 2009-10-26 11:15:23 EDT
I don't think it's fixed.  Warren showed it to me still broken, and I've got a stream of dupes coming in daily that I plan to dupe to this report when I get to triaging them.
Comment 10 Michal Hlavinka 2009-10-26 11:32:04 EDT
It's fixed for me too
Comment 11 Ray Strode [halfline] 2009-10-26 23:00:18 EDT
I spent some time trying to reproduce this today, as well, and was unsucessful.  I'm going to close this one out.  If anyone still sees this, please reopen.

Note You need to log in before you can comment on or make changes to this bug.