Bug 545307 - [abrt] crash detected in xen-runtime-3.4.1-5.fc12
[abrt] crash detected in xen-runtime-3.4.1-5.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Paolo Bonzini
Fedora Extras Quality Assurance
abrt_hash:b7f44d9ac1ff3eba2c34500c25f...
: Triaged
: 545480 550472 587239 589623 (view as bug list)
Depends On:
Blocks: F13VirtPonies
  Show dependency treegraph
 
Reported: 2009-12-08 00:27 EST by Dacong Yan
Modified: 2010-06-21 17:47 EDT (History)
12 users (show)

See Also:
Fixed In Version: xen-3.4.3-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-21 17:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (997 bytes, text/plain)
2009-12-08 00:27 EST, Dacong Yan
no flags Details
patch to fix the bug (1.73 KB, patch)
2009-12-11 08:34 EST, Paolo Bonzini
no flags Details | Diff

  None (edit)
Description Dacong Yan 2009-12-08 00:27:35 EST
abrt 1.0.0 detected a crash.

How to reproduce: run xen-detect

backtrace
-----
Debuginfo absent: 90443f32ac92d3a670e7ee9e427d0ab2f6b6d9c2
Core was generated by `xen-detect'.
Program terminated with signal 4, Illegal instruction.
#0  0x080486af in exit () at exit.c:99
99	{

Thread 1 (Thread 3046):
#0  0x080486af in exit () at exit.c:99
No symbol table info available.
#1  0x00962bb6 in __libc_start_main (main=<value optimized out>, 
    argc=<value optimized out>, ubp_av=<value optimized out>, 
    init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=<value optimized out>)
    at libc-start.c:220
        result = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {11259892, 0, 0, 
                -1081811224, 1434121963, 1888543125}, mask_was_saved = 0}}, 
          priv = {pad = {0x0, 0x0, 0x1, 0x8048470}, data = {prev = 0x0, 
              cleanup = 0x0, canceltype = 1}}}
        not_first_call = <value optimized out>
#2  0x08048491 in exit () at exit.c:99
No symbol table info available.

cmdline: xen-detect
component: xen
executable: /usr/bin/xen-detect
kernel: 2.6.31.6-162.fc12.i686.PAE
package: xen-runtime-3.4.1-5.fc12
rating: 4
reason: Process was terminated by signal 4
Comment 1 Dacong Yan 2009-12-08 00:27:41 EST
Created attachment 376838 [details]
File: backtrace
Comment 2 Justin M. Forbes 2009-12-10 14:13:23 EST
*** Bug 545480 has been marked as a duplicate of this bug. ***
Comment 3 Paolo Bonzini 2009-12-11 08:07:29 EST
The SIGILL appears in a forked child; but the caller is exactly checking if the child is dying with SIGILL or not.

It's still possible to fix it to avoid the SIGILL, though.
Comment 4 Paolo Bonzini 2009-12-11 08:34:16 EST
Created attachment 377732 [details]
patch to fix the bug

Not yet upstream, will be sent soon.
Comment 5 Paolo Bonzini 2009-12-14 06:25:08 EST
Patch sent and approved upstream.
Comment 6 Paolo Bonzini 2010-05-05 12:11:19 EDT
*** Bug 587239 has been marked as a duplicate of this bug. ***
Comment 7 Paolo Bonzini 2010-05-05 12:11:29 EDT
*** Bug 550472 has been marked as a duplicate of this bug. ***
Comment 8 Paolo Bonzini 2010-05-05 12:14:16 EDT
Patch included upstream, and abrt apparently cannot catch duplicates of this bug so it's been reported 4 times. :-)

jforbes/kraxel, I'm making my best puss-in-boots look.
Comment 9 Paolo Bonzini 2010-05-14 05:32:34 EDT
*** Bug 589623 has been marked as a duplicate of this bug. ***
Comment 10 Michael Young 2010-06-01 18:05:11 EDT
This looks to be fixed in the xen-3.4.3-1 build now in koji at
http://koji.fedoraproject.org/koji/buildinfo?buildID=176128
Comment 11 Fedora Update System 2010-06-03 14:40:37 EDT
xen-3.4.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/xen-3.4.3-1.fc13
Comment 12 Fedora Update System 2010-06-03 14:43:37 EDT
xen-3.4.3-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/xen-3.4.3-1.fc12
Comment 13 Fedora Update System 2010-06-04 14:48:12 EDT
xen-3.4.3-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xen-3.4.3-1.fc13
Comment 14 Fedora Update System 2010-06-04 14:50:48 EDT
xen-3.4.3-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/xen-3.4.3-1.fc12
Comment 15 Fedora Update System 2010-06-21 17:33:18 EDT
xen-3.4.3-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-06-21 17:47:02 EDT
xen-3.4.3-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.