Bug 569664 - (missing-vbox) unable to do graphical install of F13 Alpha in VirtualBox
unable to do graphical install of F13 Alpha in VirtualBox
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Triaged
: 540785 567893 568441 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 19:06 EST by Andre Robatino
Modified: 2010-03-28 21:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-28 18:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2010-03-01 19:06:48 EST
Description of problem:
When I try to do an RC4 graphical install (either i386 or x86_64 DVD, and choosing either the default or the basic video driver on the initial install screen) as a VirtualBox 3.1.4 guest, shortly after printing the line

Running anaconda 13.32, the Fedora system installer - please wait.

it then prints the time and the message

X startup failed, falling back to text mode

and starts the text-based installer (and a text-based install completes successfully).  I'm using Sun's version of VirtualBox (not the rpmfusion OSE version).

Version-Release number of selected component (if applicable):
anaconda 13.32 (see above)
Comment 2 Matěj Cepl 2010-03-04 12:18:50 EST
> Yes, it is. Adam and I tracked this one down last week; we don't have
> the vboxvideo driver in Fedora, but we did have the autodetect code in
> the X server which tries to use it when it detects a VirtualBox
> 'graphics adapter'. And for some reason, X wasn't falling back to vesa
> when it noticed vboxvideo wasn't present, it just fell over. So we
> changed the autodetect code to go straight to vesa, for now.
Comment 3 Matěj Cepl 2010-03-05 13:58:23 EST
*** Bug 567893 has been marked as a duplicate of this bug. ***
Comment 4 Matěj Cepl 2010-03-06 04:53:34 EST
*** Bug 540785 has been marked as a duplicate of this bug. ***
Comment 5 Matěj Cepl 2010-03-06 04:55:12 EST
*** Bug 568441 has been marked as a duplicate of this bug. ***
Comment 6 Milan Kerslager 2010-03-11 08:06:55 EST
Fedora 13 Alpha has still the problem.
Comment 7 Andre Robatino 2010-03-11 08:19:58 EST
Actually, F13 Alpha == RC4.  Changing the Summary.
Comment 8 karl kleinpaste 2010-03-11 21:46:53 EST
Aside from not being able to install using X, F13a also does not install X at all.  And it is not installed so as to be able to bring up eth0 (using bridged interface, with dhcp server in nearby typical Linksys device) -- eth0 does not come up on its own at all, and "ifup eth0" results in nothing but eth0 being "UP" without becoming configured with an address.
Comment 9 Didier G 2010-03-11 23:19:44 EST
In this configuration with VirtualBox, Anaconda installs only 187 packages and do not install X.

Using an internet box it is possible to enable networking after installation to install additionnal package from repo.

To enable networking using internet box at address 192.168.1.1 

1/ ifconfig eth0 up 192.168.1.xxx
2/ route add default gw 192.168.1.1
3/ edit /etc/resolv.conf and add a line with just "nameserver 192.168.1.1"

After that, it is possible to use yum to update the systen and install new packages.
Comment 10 Matěj Cepl 2010-03-12 11:28:15 EST
(In reply to comment #8)
> Aside from not being able to install using X, F13a also does not install X at
> all.  And it is not installed so as to be able to bring up eth0 (using bridged
> interface, with dhcp server in nearby typical Linksys device) -- eth0 does not
> come up on its own at all, and "ifup eth0" results in nothing but eth0 being
> "UP" without becoming configured with an address.    

Aren't you able to install vboxvideo driver from rpmfusion repo? What's broken on it? Of course, it is a bug of our Xserver, that it pretends it can use vbox driver when it cannot, but it should work even with the third party driver.
Comment 11 Andre Robatino 2010-03-12 11:43:10 EST
I'm a little confused, I got a needinfo message, but you're responding to comment #8 which is not from me, and which is unrelated to the original bug (X not working DURING install).  Do you need info from me?
Comment 12 karl kleinpaste 2010-03-12 12:14:12 EST
never mind, and i'm sorry i commented at all.  i thought it might be useful or interesting to know that, having first failed to install /using/ X, F13a didn't even get around to installing /anything/ related to X.  there is not one package in this new F13a whose name includes the string "xorg".  it doesn't matter if i am "able to install vboxvideo driver from rpmfusion repo" or anywhere else, if the substrate on which such extras would live is absent.

ergo, just forget it.  nothing to see here, citizen, move along, move along.
Comment 13 Didier G 2010-03-12 15:19:29 EST
I just did a new install from scratch in a VirtualBox virtual machine.

At start of installation, Anaconda says 187 packages will be installed.

At the end of installation, only groups "Mail server" and "Network server" are installed but group "Base" and other usual groups are not installed.

So independently of problem with X, there is  an other problem in Anaconda installation process in a virtual machine.

If I enable network (see my previous message bellow) I am able to install group Base and other groups from repos.
Comment 14 Andre Robatino 2010-03-12 15:34:49 EST
When X fails to start, this forces a standard text-based install, which installs a fixed small number of packages.  If X had started, there would have been a standard GUI install which would have installed a much larger set of packages by default, and allowed for package customization.  So the only problem here is the failure of X to start during the install - the behavior of the text-based installer itself is normal.  (The text-based installer used to allow package customization as well, but somewhere around F10 or F11 it was dumbed way down to what you've just experienced.)
Comment 15 Didier G 2010-03-12 16:24:05 EST
So after manual installation of all necessary groups, I run VBoxLinuxAdditions-amd64.run.

During VirtualBox build process I get following message :

Installing the Window System drivers
Warning: unsupported pre-release version of X.Org Server installed. Not installing the X.Org drivers.

and of course I cannnot start X.

VirtualBox version is Oracle VM VirtualBox 3.1.4 (not OSE form Fedora repo).
Comment 16 Andre Robatino 2010-03-12 16:37:21 EST
You can create an xorg.conf file specifying the vesa driver by installing system-config-display and then running (as root) "system-config-display --noui".  Then X should work.  The problem with the guest additions will eventually get fixed with an updated version of VirtualBox.
Comment 17 Didier G 2010-03-12 17:12:47 EST
I created /etc/X11/xorg.conf with system-config-display and I am now running Fedora 13 alpha in a virtaul machine under VirtualBox 3.1.4.
Comment 18 Matěj Cepl 2010-03-13 05:07:37 EST
(In reply to comment #15)
> VirtualBox version is Oracle VM VirtualBox 3.1.4 (not OSE form Fedora repo).    

That's I believe your problem. Try it with rpmfusion VB. If it doesn't work, file a bug at bugzilla.rpmfusion.org.
Comment 19 Andre Robatino 2010-03-13 05:12:33 EST
I have the same issues with Sun's version, which should be the most up-to-date.
Comment 20 Didier G 2010-03-13 09:21:53 EST
rpmfusion just packages the OSE version from Oracle (formerly Sun) and  bug should be open at http://www.virtualbox.org/wiki/Bugtracker
Comment 21 Didier G 2010-03-13 09:31:59 EST
I just opened ticket http://www.virtualbox.org/ticket/6370
Comment 22 Andre Robatino 2010-03-16 09:31:48 EDT
For what it's worth, still broken in Beta TC0.  See

http://lists.fedoraproject.org/pipermail/test/2010-March/088878.html

which says it should be fixed in xorg-x11-server 1.7.99.901-10.20100223, but Beta TC0 only has 1.7.99.901-8.20100223.
Comment 23 Milan Kerslager 2010-03-17 04:28:12 EDT
I confirm comment #22 that 13-Beta.TC0 does not solve the problem yet.
Comment 24 Andre Robatino 2010-03-21 11:05:01 EDT
Just checked and F13 Branched still has the older version of xorg-x11-server (1.7.99.901-8.20100223), but Rawhide has a newer version (1.7.99.902-2.20100319).  So it ought to be possible to do a network graphical install of Rawhide in VirtualBox, though I haven't tried it.
Comment 25 Andre Robatino 2010-03-21 13:07:18 EDT
Using

http://serverbeach1.fedoraproject.org/pub/alt/stage/Fedora-rawhide-x86_64-netinst.iso

I got the initial graphical (stage2) install screen to appear using VirtualBox, although the VM immediately froze at that point.  So this particular bug appears fixed in Rawhide.  Anyone know when an updated xorg-x11-server will get into F13?  Koji shows a number of newer versions already built:

http://koji.fedoraproject.org/koji/packageinfo?packageID=63
Comment 26 Milan Kerslager 2010-03-22 01:45:32 EDT
From my point of view the file Fedora-rawhide-x86_64-netinst.iso is dated 24-Nov-2009, so seems to be way obsolete. But this could be caused by broken mirror set of servers (you may see up-to-date image from another server than me).
Comment 27 Andre Robatino 2010-03-22 01:52:43 EDT
No, I think you're right.  I didn't notice the 2009-11-24 date before and just assumed it would be recent.  Sorry.
Comment 28 Andre Robatino 2010-03-22 23:33:14 EDT
Beta.TC1 only has xorg-x11-server 1.7.99.901-8.20100223, and GUI install still fails with VirtualBox (tested with i386 DVD ISO).  However, 1.7.99.902-2.20100319 was just pushed to F13 today, so TC2 should be fixed.
Comment 29 Brian Dudek 2010-03-23 13:02:01 EDT
I can verify it does work!  I need to keep adding font packages until the "Welcome" run screen would show something other than squares.

I added three groups of fonts, this was the third group so it is one of these.

yum install xorg-x11-fonts-ISO8859-1-100dpi.noarch xorg-x11-fonts-Type1.noarch xorg-x11-fonts-ISO8859-1-75dpi.noarch xorg-x11-fonts-ISO8859-9-75dpi.noarch xorg-x11-fonts-misc.noarch
Comment 30 Milan Kerslager 2010-03-25 08:49:55 EDT
13-Beta.TC1 still has the problem.
Comment 31 Andre Robatino 2010-03-26 02:07:49 EDT
Fixed in 13-Beta.RC1 (tested i386 DVD).  Graphical installer starts normally, didn't attempt to complete install.
Comment 32 Matěj Cepl 2010-03-28 18:16:17 EDT
Thank you for letting us know.
Comment 33 Didier G 2010-03-28 21:34:52 EDT
I confirm this problem is fixed. I did a full Beta RC1 x64 installation in graphic mode in VirtualBox 3.1.6 with no problem.

Note You need to log in before you can comment on or make changes to this bug.