This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 575157 - cman cannot be rebuilt with latest nss libraries
cman cannot be rebuilt with latest nss libraries
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.5
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: ZStream
Depends On: 453577 587546 590145 590734
Blocks: 586034 586035 586036
  Show dependency treegraph
 
Reported: 2010-03-19 12:08 EDT by Jaroslav Kortus
Modified: 2016-04-26 11:00 EDT (History)
9 users (show)

See Also:
Fixed In Version: cman-2.0.115-37.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 17:32:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch fixing compile against nspr-4.8.2+ (678 bytes, patch)
2010-03-31 17:48 EDT, Tuomo Soini
no flags Details | Diff

  None (edit)
Description Jaroslav Kortus 2010-03-19 12:08:54 EDT
Description of problem:
cman srpm rebuild fails with:

/usr/include/nspr4/prlink.h:52: warning: function declaration isn't a prototype /usr/include/nspr4/prlink.h:211: warning: function declaration isn't a prototype 

Version-Release number of selected component (if applicable):
# rpm -q nss nspr cman
nss-3.12.6-1.el5_4
nspr-4.8.4-1.el5_4
cman-2.0.115-34.el5


How reproducible:
always

Steps to Reproduce:
1. rpmbuild -ba cman.spec
2.
3.
  
Actual results:
compilation fails

Expected results:
compilation succeeds

Additional info:
Comment 3 Lon Hohberger 2010-03-31 14:12:21 EDT
I don'
Comment 4 Lon Hohberger 2010-03-31 14:14:48 EDT
Oops.

I don't get the warm and fuzzies from the fact that use of nss makes me DISABLE compiler warnings.
Comment 6 Lon Hohberger 2010-03-31 15:01:21 EDT
It stems from a bad function prototype in prlink.h:

  void (*fp)();

For fence_xvm, the best option is to use:

#pragma GCC diagnostic ignored "-Wstrict-prototypes"

... at the beginning of the file(s) where nss or nspr includes are used.  This prevents the need to ignore strict-prototypes elsewhere in the code base during compilation.
Comment 7 Tuomo Soini 2010-03-31 16:11:13 EDT
Unfortunately this trick doesn't work with gcc version included in rhel5.

You need to use -Wno-strict-prototypes.
Comment 8 Tuomo Soini 2010-03-31 17:48:10 EDT
Created attachment 403833 [details]
Patch fixing compile against nspr-4.8.2+
Comment 9 Tru Huynh 2010-03-31 19:22:07 EDT
should be clone for RHEL4 too
cman-kernel-2.6.9-56.7.el4_8.12.can be built with nss-3.12.3.99.3-1.el4_8.2 but fails to build if 3.12.6-1.el4_8 is installed
Comment 10 Lon Hohberger 2010-04-01 10:46:46 EDT
cman-kernel does not use nss; I do not understand how building it could fail due to nss or nspr updates.
Comment 11 Lon Hohberger 2010-04-01 10:53:53 EDT
Furthermore, if there is an identifiable point at which an update of a library broke compilation of applications, it is a regression in the library.
Comment 12 Fabio Massimo Di Nitto 2010-04-08 06:36:53 EDT
This isn´t a new bug. nss maintainers have been aware of this issue for sometime (reported several months ago against Fedora).

And for sure not a cman issue.

Time nss people fix their stuff.
Comment 19 Lon Hohberger 2010-04-21 11:52:42 EDT
http://git.fedorahosted.org/git/?p=cluster.git;a=commit;h=d4ae5b0f197288fafe884046ba9d9cd1c9c556b0

I do not see value in sweeping the error under the rug by not compiling with -Wstrict-prototypes.  Consequently, I have removed -Werror.
Comment 21 Lon Hohberger 2010-04-22 13:04:14 EDT
See:

https://bugzilla.redhat.com/show_bug.cgi?id=453577#c3

A change to nss caused this (not nspr or gcc, as previously suspected)
Comment 29 Elio Maldonado Batiz 2010-04-27 10:26:18 EDT
Patch in https://bugzilla.redhat.com/attachment.cgi?id=409353
that patch should work for this bug as well.
Comment 32 errata-xmlrpc 2011-01-13 17:32:35 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0036.html

Note You need to log in before you can comment on or make changes to this bug.