Bug 577684 - same-gnome disappeared and didn't come back as swell-foop
Summary: same-gnome disappeared and didn't come back as swell-foop
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-games
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 600638
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-03-28 20:07 UTC by Tom Horsley
Modified: 2011-06-27 15:21 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-27 15:21:04 UTC
Type: ---


Attachments (Terms of Use)

Description Tom Horsley 2010-03-28 20:07:15 UTC
Description of problem:

The same-gnome game isn't part of the fedora 13 gnome-games package.
The web site at http://live.gnome.org/Same%20Gnome says the name changed
to swell foop. Did the fedora build get confused by the name change?

Version-Release number of selected component (if applicable):
gnome-games-2.29.92-1.fc13.x86_64


How reproducible:
100%

Steps to Reproduce:
1.try to find either same-gnome or swell-foop
2.
3.
  
Actual results:
not found

Expected results:
one or the other of them

Additional info:

Comment 1 Matthias Clasen 2010-03-28 22:49:16 UTC
swell-foop was rewritten to depend on seed.
So, if you want it back, you need to package seed, or convince somebody else to package it.

Comment 2 Michel Alexandre Salim 2010-06-05 10:53:26 UTC
I've updated this to point to the seed review request, which in turn blocks on the gnome-js-common review request.

Anyone interested in this bug report, please consider reviewing one of the two (or both).

Comment 3 Mamoru TASAKA 2010-06-23 05:03:10 UTC
Now thanks to Michel seed (and gnome-js-common) is imported
into rawhide. Matthias, would you enable swell-foop first on rawhide
so that we can check things go well or not?

seed will be imported also into F-13 once testing phase or so
ends (not submitted on bodhi yet).

Comment 4 Matthias Clasen 2010-06-23 17:11:06 UTC
I've done a gnome-games build. Maybe you want to try it ?

Comment 5 Tom Horsley 2010-06-23 17:29:09 UTC
I'd be willing to try it if I knew how to do it :-). Is it in rawhide?

I guess I need to install the rawhide repo definition, then enable
it and update gnome-games?

Comment 6 Mamoru TASAKA 2010-06-23 17:38:45 UTC
Hi, Matthias:

I just tried with
gnome-games-2.31.3-2.fc14.i686
seed-2.31.1-1.fc14.i686
gnome-js-common-0.1.2-3.fc14.noarch

however it failed like below:
-------------------------------------------------------
[tasaka1@localhost ~]$ swell-foop 

** (seed:16729): CRITICAL **: Line 8 in /usr/share/gnome-games/swell-foop/main.js: GIrepositoryError Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded
[tasaka1@localhost ~]$ 
-------------------------------------------------------
Looks like something wrong occurred with both gtk2 and gtk3
installed, however I don't know anything more.

Comment 7 Matthias Clasen 2010-06-23 18:03:58 UTC
ok, thanks for trying

Comment 8 Mamoru TASAKA 2010-06-24 17:16:54 UTC
A slight update:

(On i686) if I hide 4 files under /usr/lib/girepository-1.0/
in gtk3-2.90.3-1.fc14.i686, I see another message:
-----------------------------------------------
[tasaka1@localhost ~]$ swell-foop 

** (seed:19845): CRITICAL **: Line 11 in /usr/share/gnome-games/swell-foop/main.js: GIrepositoryError Typelib file for namespace 'GnomeGamesSupport' (any version) not found
[tasaka1@localhost ~]$ 
------------------------------------------------
So it seems that introspection files need to be compiled.
And it seems introspection files from GTK3 package need to be
"isolated"?

However if I remove "--disable-introspection" (in gnome-games-2.31.3-2.spec),
I see the following error:
-------------------------------------------------
/builddir/build/BUILD/gnome-games-2.31.3/libgames-support/.libs/libgames-support-gi.so: undefined reference to `g_settings_new_with_context_and_path'
/builddir/build/BUILD/gnome-games-2.31.3/libgames-support/.libs/libgames-support-gi.so: undefined reference to `g_settings_backend_setup_keyfile'
collect2: ld returned 1 exit status
-------------------------------------------------
This seems to be because of glib2 2.25.8 -> 2.25.9 change.

Comment 9 Michel Alexandre Salim 2010-07-12 08:06:57 UTC
How about getting it working for F-13 for now? It might take a while before auxiliary GNOME packages are updated for the 2.31 cycle.

Comment 10 Tom Horsley 2010-08-27 13:49:17 UTC
I notice there is a swell foop menu item in fedora 14 alpha, but no
program ever seems to start when I click it.

Comment 11 Mamoru TASAKA 2010-08-27 14:10:11 UTC
(In reply to comment #10)
> I notice there is a swell foop menu item in fedora 14 alpha, but no
> program ever seems to start when I click it.

Well, with
gnome-games-2.31.90-1.fc14.i686
seed-2.31.5-1.fc14.i686

when swell-foop is tried on terminal, I still see the following
messages.
--------------------------------------------------------------
$ swell-foop 

** (seed:18064): CRITICAL **: Line 8 in /usr/share/gnome-games/swell-foop/main.js: GIrepositoryError Requiring namespace 'Gtk' version '2.0', but '3.0' is already loaded
--------------------------------------------------------------
Matthias, any idea? Maybe seed must be downgraded to 2.30.0 for now?

Comment 12 Andre Robatino 2010-08-27 14:56:34 UTC
I have the swell-foop menu entry, but running "swell-foop" on the command line gave "/usr/bin/env: seed: No such file or directory", until I manually installed seed. Seed needs to be a dependency. After installing it, I get the error

** (seed:1985): CRITICAL **: Line 8 in /usr/share/gnome-games/swell-foop/main.js: GIrepositoryError Typelib file for namespace 'GtkClutter' (any version) not found

Comment 13 Valdis Kletnieks 2010-08-27 15:36:01 UTC
Comment 12: You need seed, and also clutter-gtk (which you're missing).

Comment 11: You've hit bug #626669

Comment 14 Andre Robatino 2010-08-27 15:49:50 UTC
Confirmed - when clutter-gtk is also installed, I get the same error as in comment 11. So clutter-gtk also needs to be a dependency, I guess.

Comment 15 Matthias Clasen 2010-08-27 22:50:46 UTC
The problem is that seed itself is linked against gtk3, while clutter-gtk is linked against gtk2.

Comment 16 Yanko Kaneti 2010-08-31 10:25:11 UTC
another thing, gnome-games should Requires: seed because rpm can't automatically figure that from the shell script contraption that is /usr/bin/swell-foop

Comment 17 Edward Sheldrake 2010-10-06 22:17:11 UTC
Even if the gtk2 vs gtk3 issue ever gets resolved for F-14, I found gnome-games 2.32.0 to be somewhat broken with glib2 2.26, gobject-introspection 0.9.10 etc. I eventually managed to fix it enough so that it runs and I can remind myself how much worse it is than same-gnome, I dumped the patches at bugzilla.gnome.org #631563.

Also - lightsoff needed less fixing, but the gnome-games.spec always deletes lightsoff (in %install) regardless of the build_seed_games setting.

Writing a same-gnome.spec plus gnome-games-2.28.2.tar.bz2 was, of course, much less trouble.

Comment 18 Michel Alexandre Salim 2010-11-16 17:05:05 UTC
(In reply to comment #17)

> Also - lightsoff needed less fixing, but the gnome-games.spec always deletes
> lightsoff (in %install) regardless of the build_seed_games setting.
> 
I patched this in Rawhide, but of course it does not build there for other reasons. You can use the Rawhide spec to try and reenable swell-foop and lightoff -- please provide patches if they work.

Comment 19 Edward Sheldrake 2010-11-16 20:28:55 UTC
The patches are filed upstream at https://bugzilla.gnome.org/show_bug.cgi?id=631563

Since then gobject-introspection has been fixed not to silently ignore comment blocks due to stray space characters.

Comment 20 Michel Alexandre Salim 2010-11-17 09:03:07 UTC
Might be worth turning this on in F-14 then -- though would it still make sense to have an "-unstable" subpackage, or incorporate the patchset but leave the seed games off by default?

ps Edward are you already a Fedora packager? We could use more folks who actually send patches!

Comment 21 Bug Zapper 2011-06-02 15:49:12 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 22 Edward Sheldrake 2011-06-23 13:06:27 UTC
swell-foop is present in gnome-games 3.0.1.1-1.fc15 on Fedora 15, and should be working and playable.

Comment 23 dcmores 2011-06-23 16:51:09 UTC
I can confirm that swell-foop does work and is playable as Ed claims.  However, this rebirth of the classic same-gnome is certainly less snazzy.  The rotating marbles are gone.  Remembering top scores is broken.

KDE games has a similar game called same-game that is spawned from an app called klickety.  It does keep score, uses marbles, but does not rotate them i.e. snazzless too.

Comment 24 Bug Zapper 2011-06-27 15:21:04 UTC
Fedora 13 changed to end-of-life (EOL) status on 2011-06-25. Fedora 13 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.