Bug 57945 - time-udp still does not work properly with xinetd
time-udp still does not work properly with xinetd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
: 60335 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-02 17:30 EST by Darren Gamble
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-03 18:21:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Gamble 2002-01-02 17:30:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
time-udp often does not respond, even when it is running and connections 
are logged.  

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start xinetd with time-udp enabled.
2. Use rdate -u from various other machines to try to connect.
	

Actual Results:  The service will sometimes repond, and sometimes not.  
time-udp appears to always serve connections originating from the same 
machine, and no others.  Sometimes (often after a restart), it may serve 
requests to other machines.  It is definately hit-and-miss, but with more 
misses than hits and is pretty easy to reproduce.

Expected Results:  The service should always respond.

Additional info:

Redhat 7.2 running xinetd-2.3.4-0.1 .

tcpdump and /var/log/secure reveal all requests arriving.  There are no 
filters in place.

"wait" has been tested as both "yes" and "no" with similar results.

xinetd-2.3.4-0.3 was tried but does not start (see bug #57944).

See also bug #56487.
Comment 1 Darren Gamble 2002-01-03 18:21:27 EST
I have some more information on this that might help track down this bug... 
after enabling some logging, I see that xinetd logs the message "Possible 
Denial of Service attack from X.X.X.X X", despite there only being one 
connection made.

I've also tried to install intimed, in an attempt to get a time server 
working.  xinetd instead logs the message "Deactivating service time due to 
excessive incoming connections.  Restarting in 30 seconds." after any 
connection attempt.  Again, this is after only a single connection.

Adding a (high) cps value to the service configuration does not change this.
Comment 2 Trond Eivind Glomsrxd 2002-01-06 07:41:18 EST
It should be fixed in xinetd-2.3.4-0.4 (the 2002-01-04 devel snapshot, available
from http://www.xinetd.org/devel/)
Comment 3 Trond Eivind Glomsrxd 2002-03-01 15:26:52 EST
*** Bug 60335 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.