Bug 582764 - k3b crashes during opening Settings - Configure k3b
Summary: k3b crashes during opening Settings - Configure k3b
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 623043 629362 632825 (view as bug list)
Depends On:
Blocks: kde-4.5
TreeView+ depends on / blocked
 
Reported: 2010-04-15 18:39 UTC by Karsten Roch
Modified: 2014-01-13 00:11 UTC (History)
17 users (show)

Fixed In Version: k3b-2.0.1-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 05:06:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 238819 None None None Never
Launchpad 594121 None None None Never

Description Karsten Roch 2010-04-15 18:39:44 UTC
Description of problem:

k3b crashes  during opening the Window for Settings - Configure k3b

Version-Release number of selected component (if applicable):

$ k3b -v
Qt: 4.7.0
KDE Development Platform: 4.4.2 (KDE 4.4.2)
K3b: 1.91.0

How reproducible:

Always

Steps to Reproduce:
1. Start k3b
2. go to Menue "Settings"
3. select "configure k3b"
  
Actual results:

Crash.

Expected results:

Window with settings will be opened. 

Additional info:
Starting k3b from a console:

$ k3b 
k3b(4661) K3b::PluginManager::loadAll:
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Ogg Vorbis Decoder" "k3boggvorbisdecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Ogg Vorbis Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Ogg Vorbis Encoder" "k3boggvorbisencoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Ogg Vorbis Encoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b FLAC Decoder" "k3bflacdecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b FLAC Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Audio Metainfo Renamer" "k3baudiometainforenamerplugin"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Audio Metainfo Renamer"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b SoX Audio Encoder" "k3bsoxencoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b SoX Audio Encoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b External Audio Encoder" "k3bexternalencoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b External Audio Encoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Musepack Decoder" "k3bmpcdecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Musepack Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b FFMpeg Decoder" "k3bffmpegdecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b FFMpeg Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Lame Mp3 Encoder" "k3blameencoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Lame Mp3 Encoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Cddb Audio Plugin" "k3baudioprojectcddbplugin"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Cddb Audio Plugin"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b MAD Decoder" "k3bmaddecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b MAD Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Libsndfile Decoder" "k3blibsndfiledecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Libsndfile Decoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: "K3b Wave Decoder" "k3bwavedecoder"
k3b(4661) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Wave Decoder"
k3b(4661) K3b::Device::Device::init: (K3b::Device::Device)  "/dev/sr0" : init()
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  CD Mastering
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  CD Track At Once
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD Read (MMC5)
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+R
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+RW                     
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+R Double Layer
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD-R/-RW Write
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  Rigid Restricted Overwrite
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  Layer Jump Recording
k3b(4661) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  unknown profile:  2
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : dataLen:  60
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for TAO
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO_R96P
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO_R96R
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R16
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R96P
k3b(4661) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R96R
k3b(4661) K3b::Device::Device::getPerformance: (K3b::Device::Device)  "/dev/sr0" : GET PERFORMANCE reports bogus dataLen:  8
k3b(4661) K3b::Device::Device::getSupportedWriteSpeedsVia2A: (K3b::Device::Device)  "/dev/sr0" :  Number of supported write speeds via 2A:  4
k3b(4661) K3b::Device::Device::getSupportedWriteSpeedsVia2A: (K3b::Device::Device)  "/dev/sr0"  :  8468  KB/s
k3b(4661) K3b::Device::Device::getSupportedWriteSpeedsVia2A: (K3b::Device::Device)  "/dev/sr0"  :  7056  KB/s
k3b(4661) K3b::Device::Device::getSupportedWriteSpeedsVia2A: (K3b::Device::Device)  "/dev/sr0"  :  4234  KB/s
k3b(4661) K3b::Device::Device::getSupportedWriteSpeedsVia2A: (K3b::Device::Device)  "/dev/sr0"  :  2822  KB/s
k3b(4661) K3b::Device::DeviceManager::addDevice: (K3b::Device::DeviceManager) setting current write speed of device  "/dev/sr0"  to  8468
k3b(4661) K3b::MediaCache::clearDeviceList:
k3b(4661) K3b::Medium::update: no medium found
k3b(4661) K3b::Device::DeviceManager::printDevices: Devices:
------------------------------
k3b(4661) K3b::Device::DeviceManager::printDevices: Blockdevice:     "/dev/sr0"
Vendor:          "HL-DT-ST"
Description:     "DVD-RAM GSA-H58N"
Version:         "1.03"
Write speed:     8468
Profiles:        "DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Read Cap:        "DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+RW Dual Layer, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Write Cap:       "DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW"
Writing modes:   "SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump"
------------------------------
k3b(4661) K3b::TitleLabel::updatePositioning: 21 21
k3b(4661) K3b::PlacesModel::slotDevicesChanged:
k3b(4661)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory! 
k3b(4661)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory! 
k3b(4661)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory! 
k3b(4661)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory! 
k3b(4661) K3b::FileTreeView::setSelectedUrl:
k3b(4661) K3b::PlacesModel::expandToUrl: KUrl("file:///home/karo/")
k3b(4661) K3b::PlacesModel::expandToUrl: KUrl("file:///home/karo")  will be expanded.
k3b(4661) K3b::FileTreeView::slotExpandUrl:
[karo@krakatoa ~]$ k3b(4661) K3b::kernelVersion: kernel version:  "2.6.34-0.28.rc3.git3.fc14.i686"
k3b(4661) K3b::SystemProblemDialog::checkSystem: (K3b::Core) System problems:
k3b(4661) K3b::SystemProblemDialog::checkSystem:           - none -
k3b(4661)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/usr/share/mime/magic"
k3b(4661)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/home/karo/.local/share/mime/magic"


--> k3b opens, works normally, only when select the Settings Menue, it crashes. See output here:


k3b(4661) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Ogg Vorbis Decoder"
k3b(4661)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "oggvorbisdecoder"
k3b(4661) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Ogg Vorbis Encoder"
k3b(4661)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  1  offers for  "k3boggvorbisencoder"
k3b(4661) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b FLAC Decoder"
k3b(4661) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Audio Metainfo Renamer"

<Crash>

Comment 1 Karsten Roch 2010-05-23 20:25:52 UTC
I updated today to 

Qt: 4.7.0
KDE Development Platform: 4.4.3 (KDE 4.4.3)
K3b: 1.92.0
 
with kernel 2.6.34-11.fc14.i686.


Unfortunately, the problem still exists.

Cordialement
Karsten

Comment 2 Radek Novacek 2010-05-25 06:29:59 UTC
Hello, can you report this bug to the upstream bugzilla and post the bug number here? Thank you

Comment 3 Karsten Roch 2010-05-25 18:50:15 UTC
As requested, Bug reported against KDE.org - K3B upstream:

 Bug 238819 -  k3b crashes during opening the Window for Settings - Configure k3b

Cordialement
Karsten

Comment 4 Rex Dieter 2010-06-14 13:40:12 UTC
Upstream triaged it as a kdeui issue.

Comment 5 Bug Zapper 2010-07-30 11:21:55 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Rex Dieter 2010-08-11 14:12:04 UTC
*** Bug 623043 has been marked as a duplicate of this bug. ***

Comment 7 Radek Novacek 2010-08-19 07:57:39 UTC
There is a patch in the upstream bugzilla that workarounds the issue. I tested it and it fixes the crash. Shouldn't we temporarily use the patch until that kdeui bug will be fixed? It can take long time (there is no reply from kdeui devs yet).

Comment 8 Kevin Kofler 2010-08-19 09:43:13 UTC
Since this is a 4.5 blocker, we can use the workaround, but it means we need a new K3b pushed either together with or before 4.5. I don't like the workaround at all (it's clearly just a hack to hide the real issue), but we can't wait forever for a real fix for this blocker regression.

Comment 9 Rex Dieter 2010-08-29 21:34:58 UTC
agreed, please include the workaround asap, while waiting for something better.

Comment 10 Kevin Kofler 2010-08-30 10:06:53 UTC
Does this actually happen with KDE 4.5 + Qt 4.6 or is this actually a Qt 4.7 issue?

Comment 11 Fedora Update System 2010-08-31 12:51:02 UTC
k3b-2.0.0-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/k3b-2.0.0-3.fc14

Comment 12 Fedora Update System 2010-08-31 13:07:39 UTC
k3b-2.0.0-3.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/k3b-2.0.0-3.fc13

Comment 13 Fedora Update System 2010-08-31 20:18:48 UTC
k3b-2.0.0-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update k3b'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/k3b-2.0.0-3.fc14

Comment 14 Martin Naď 2010-09-01 18:59:44 UTC
*** Bug 629362 has been marked as a duplicate of this bug. ***

Comment 15 Sven Lankes 2010-09-06 11:51:54 UTC
I can not reproduce this using k3b-2.0.1-1.fc13.x86_64 (from updates-testing).

Comment 16 Rex Dieter 2010-09-11 20:06:17 UTC
*** Bug 632825 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-09-14 05:06:00 UTC
k3b-2.0.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2010-09-15 05:45:52 UTC
k3b-2.0.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.