Bug 583197 - [abrt] crash in pino-0.2.6-1.fc13: Process /usr/bin/pino was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in pino-0.2.6-1.fc13: Process /usr/bin/pino was killed by signal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pino
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Filipe Rosset
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6908adf5411311ab73a01b6f9bc...
: 583969 596077 597844 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-17 01:02 UTC by Bruce Cowan
Modified: 2010-06-22 09:31 UTC (History)
8 users (show)

Fixed In Version: pino-0.2.10-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 09:30:05 UTC


Attachments (Terms of Use)
File: backtrace (5.15 KB, text/plain)
2010-04-17 01:02 UTC, Bruce Cowan
no flags Details
Stack trace (14.23 KB, text/plain)
2010-05-14 01:22 UTC, Bruce Cowan
no flags Details

Description Bruce Cowan 2010-04-17 01:02:05 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: pino
comment: Pino crashes when I click on buttons in it. Each time it is started, something different triggers the crash.
component: pino
executable: /usr/bin/pino
global_uuid: 6908adf5411311ab73a01b6f9bcb26e1b649ab51
kernel: 2.6.33.2-41.fc13.i686
package: pino-0.2.6-1.fc13
rating: 4
reason: Process /usr/bin/pino was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Open Pino
2. Click on any of the toolbar buttons until it crashes

Comment 1 Bruce Cowan 2010-04-17 01:02:07 UTC
Created attachment 407214 [details]
File: backtrace

Comment 2 Bruce Cowan 2010-04-21 17:37:17 UTC
Uninstalling and reinstalling pino fixes this it would appear.

Comment 3 Fedora Update System 2010-04-30 17:55:28 UTC
pino-0.2.7-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/pino-0.2.7-1.fc13

Comment 4 Carl G. 2010-05-01 17:31:25 UTC
---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Fedora Update System 2010-05-06 06:58:12 UTC
pino-0.2.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Bruce Cowan 2010-05-13 20:11:17 UTC
This still occurs as of 0.2.8. However, switching off "Enable window and button sounds" in the sound preferences capplet makes this not occur.

Comment 7 Rahul Sundaram 2010-05-13 22:41:06 UTC
Would you get me a stack trace?

http://fedoraproject.org/wiki/StackTraces

It appears Pino is just triggering a bug elsewhere in the stack but a stack trace would be very useful to drill down on the details.

Comment 8 Bruce Cowan 2010-05-14 01:22:13 UTC
Created attachment 413929 [details]
Stack trace

I had to run this in gdb because abrtd doesn't seem to work for some reason.

Comment 9 Bruce Cowan 2010-06-04 16:24:32 UTC
This appears to not occur with Pino 0.2.10.

Comment 10 Chen Lei 2010-06-04 16:51:27 UTC
*** Bug 583969 has been marked as a duplicate of this bug. ***

Comment 11 Michal Schmidt 2010-06-22 09:29:45 UTC
The assert failure in pa_tls_set must have been fixed upstream by http://code.google.com/p/pino-twitter/source/detail?r=7774350dc5badd40807cf8d9d46f29b879f3f5c7 which removed the repeated calls to xmlCleanupParser(). This commit is present in 0.2.10.
See http://lists.fedoraproject.org/pipermail/devel/2010-January/129117.html for explanation what's wrong with xmlCleanupParser().

Comment 12 Michal Schmidt 2010-06-22 09:31:15 UTC
*** Bug 596077 has been marked as a duplicate of this bug. ***

Comment 13 Michal Schmidt 2010-06-22 09:31:55 UTC
*** Bug 597844 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.