Bug 585405 - [abrt] crash in NetworkManager-gnome-1:0.8.0-6.git20100408.fc13: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
[abrt] crash in NetworkManager-gnome-1:0.8.0-6.git20100408.fc13: Process /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:e79d0136baae1111fa89001441b...
:
: 575450 582483 585557 587067 593320 593719 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-23 17:31 EDT by Bill Nottingham
Modified: 2014-03-16 23:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 19:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.24 KB, text/plain)
2010-04-23 17:31 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2010-04-23 17:31:01 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: nm-connection-editor
component: NetworkManager
executable: /usr/bin/nm-connection-editor
global_uuid: e79d0136baae1111fa89001441b8c7b752e8c82a
kernel: 2.6.33.2-41.fc13.x86_64
package: NetworkManager-gnome-1:0.8.0-6.git20100408.fc13
rating: 4
reason: Process /usr/bin/nm-connection-editor was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Start nm-connection editor
2. Mistype the polkit password
Comment 1 Bill Nottingham 2010-04-23 17:31:02 EDT
Created attachment 408743 [details]
File: backtrace
Comment 2 Bill Nottingham 2010-04-23 17:32:05 EDT
Not 100% reproducible, alas.
Comment 3 Bill Nottingham 2010-04-23 17:35:33 EDT
Aha. Better instructions:

1. Start nm-connection editor
2. Select a config
3. Mistype password
4. Close the selected config (leaving polkit dialog open)
5. Reopen the config
6. Enter password correctly
7. You get asked for the password again (!?!)
8. Crash
Comment 4 Dan Williams 2010-04-25 13:41:50 EDT
For my future reference, Valgrind trace from F12:

==30617== Invalid free() / delete / delete[]
==30617==    at 0x4A04D72: free (vg_replace_malloc.c:325)
==30617==    by 0x3581650335: g_free (gmem.c:190)
==30617==    by 0x41969E: connection_updated_cb (nm-connection-list.c:713)
==30617==    by 0x4171D4: update_complete (nm-connection-list.c:462)
==30617==    by 0x417FB6: add_cb (nm-connection-list.c:409)
==30617==    by 0x4C3FCBD: add_connection_done (nm-remote-settings.c:235)
==30617==    by 0x4C3FC98: org_freedesktop_NetworkManagerSettings_add_connection_async_callback (nm-settings-bindings.h:81)
==30617==    by 0x32BE40E509: complete_pending_call_and_unlock (dbus-connection.c:2227)
==30617==    by 0x32BE41073E: dbus_connection_dispatch (dbus-connection.c:4390)
==30617==    by 0x3584A098E4: message_queue_dispatch (dbus-gmain.c:101)
==30617==    by 0x3581646F8C: g_main_dispatch (gmain.c:1960)
==30617==    by 0x358164840C: g_main_context_dispatch (gmain.c:2513)
==30617==  Address 0xf19e210 is 0 bytes inside a block of size 24 free'd
==30617==    at 0x4A04D72: free (vg_replace_malloc.c:325)
==30617==    by 0x3581650335: g_free (gmem.c:190)
==30617==    by 0x41A295: edit_done_cb (nm-connection-list.c:760)
==30617==    by 0x3581A0DB13: g_closure_invoke (gclosure.c:767)
==30617==    by 0x3581A2669A: signal_emit_unlocked_R (gsignal.c:3247)
==30617==    by 0x3581A255BF: g_signal_emit_valist (gsignal.c:2980)
==30617==    by 0x3581A25B5B: g_signal_emit (gsignal.c:3037)
==30617==    by 0x3583F53AE2: _gtk_marshal_BOOLEAN__BOXED (gtkmarshalers.c:84)
==30617==    by 0x3581A0DB13: g_closure_invoke (gclosure.c:767)
==30617==    by 0x3581A2669A: signal_emit_unlocked_R (gsignal.c:3247)
==30617==    by 0x3581A2564B: g_signal_emit_valist (gsignal.c:2990)
==30617==    by 0x3581A25B5B: g_signal_emit (gsignal.c:3037)
==30617== 

(nm-connection-editor:30617): GLib-GObject-WARNING **: invalid unclassed pointer in cast to `NMConnectionEditor'

** (nm-connection-editor:30617): CRITICAL **: nm_connection_get_setting: assertion `NM_IS_CONNECTION (connection)' failed
**
ERROR:nm-connection-editor.c:214:connection_editor_validate: assertion failed: (s_con)
==30617==
Comment 5 Dan Williams 2010-04-26 02:01:55 EDT
Should be fixed by:

commit 0ad8fc1adc6ee3e59ab8963f94c106cb71af3345
Author: Dan Williams <dcbw@redhat.com>
Date:   Sun Apr 25 22:48:10 2010 -0700

    libnm-glib: use max timeout for settings dbus calls

commit 64ff90de5a989fcd7dc1c1b00fe8bc7bf4182f66
Author: Dan Williams <dcbw@redhat.com>
Date:   Sun Apr 25 22:59:26 2010 -0700

    editor: fix issues with multiple concurrent operations (rh #585405)
Comment 6 Dan Williams 2010-04-26 03:03:11 EDT
*** Bug 575450 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2010-04-27 03:56:46 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 8 Fedora Update System 2010-04-27 03:57:29 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 9 Fedora Update System 2010-04-27 21:15:50 EDT
NetworkManager-0.8.0-8.git20100426.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc13
Comment 10 Fedora Update System 2010-04-27 21:20:33 EDT
NetworkManager-0.8.0-8.git20100426.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-8.git20100426.fc12
Comment 11 Dan Williams 2010-04-29 20:30:32 EDT
*** Bug 587067 has been marked as a duplicate of this bug. ***
Comment 12 Dan Williams 2010-04-29 20:31:24 EDT
*** Bug 585557 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2010-04-29 20:31:52 EDT
*** Bug 582483 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2010-04-29 20:33:26 EDT
For everyone's benefit, I'm duping a bunch of bugs that look to be memory-corruption related to this one because the commit for this bug cleans up the only source of memory corruption in nm-connection-editor that we currently know of.  Most of the other stack traces aren't very descriptive.
Comment 15 Fedora Update System 2010-04-30 19:49:55 EDT
NetworkManager-0.8.0-9.git20100429.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-9.git20100429.fc13
Comment 16 Fedora Update System 2010-05-04 02:12:56 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc13
Comment 17 Fedora Update System 2010-05-04 02:14:50 EDT
NetworkManager-0.8.0-11.git20100503.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-11.git20100503.fc12
Comment 18 Fedora Update System 2010-05-04 19:50:28 EDT
NetworkManager-0.8.0-11.git20100503.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2010-05-05 05:16:01 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc13
Comment 20 Fedora Update System 2010-05-05 05:18:42 EDT
NetworkManager-0.8.0-12.git20100504.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.0-12.git20100504.fc12
Comment 21 Fedora Update System 2010-05-06 03:02:02 EDT
NetworkManager-0.8.0-12.git20100504.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2010-05-11 02:54:44 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 23 Dan Williams 2010-05-20 16:32:36 EDT
*** Bug 593719 has been marked as a duplicate of this bug. ***
Comment 24 Dan Williams 2010-05-20 16:39:07 EDT
*** Bug 593320 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2010-06-10 15:06:20 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.