This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 586511 - [abrt] crash in samba-client-0:3.5.2-59.fc13: Process /usr/bin/smbclient was killed by signal 11 (SIGSEGV)
[abrt] crash in samba-client-0:3.5.2-59.fc13: Process /usr/bin/smbclient was ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
abrt_hash:23395f82c1b6ad8928eddd4863f...
:
: 573438 581954 583516 (view as bug list)
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-04-27 14:57 EDT by Mihai Limbășan
Modified: 2010-05-21 05:55 EDT (History)
9 users (show)

See Also:
Fixed In Version: samba-3.5.2-60.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-04 02:06:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (12.38 KB, text/plain)
2010-04-27 14:57 EDT, Mihai Limbășan
no flags Details
Patch to fix the SIGSEGV issue. (1.14 KB, patch)
2010-04-30 09:21 EDT, Mihai Limbășan
no flags Details | Diff
Specfile changes (695 bytes, patch)
2010-04-30 09:22 EDT, Mihai Limbășan
no flags Details | Diff

  None (edit)
Description Mihai Limbășan 2010-04-27 14:57:19 EDT
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: smbclient //172.22.22.2/pub
component: samba
executable: /usr/bin/smbclient
global_uuid: 23395f82c1b6ad8928eddd4863f5c45d36782de6
kernel: 2.6.33.2-57.fc13.i686.PAE
package: samba-client-0:3.5.2-59.fc13
rating: 4
reason: Process /usr/bin/smbclient was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
The crash is reliably triggered when trying (by any means and/or abstraction levels, thus indicating a libsmbclient bug) to access a SMB share on a server that has share-level security enabled, i.e. security=share in the [global] section of smb.conf.

172.22.22.2 is the local machine, incidentally, but the crash occurs when trying to access any other machine that is similarly configured. Accessing this or other machines using share-level security works flawlessly from Fedora 11, Fedora 12, CentOS 5.x, RHEL 5.x, and Microsoft OSes.

From what I can see, bugs 573438, 581954, 583516 describe the same situation. Opening a new bug since all the others were on the x86_64 arch, and this one has a complete debuginfo backtrace.

How to reproduce
-----
1. smbclient //172.22.22.2/pub
2. Crash.
Comment 1 Mihai Limbășan 2010-04-27 14:57:21 EDT
Created attachment 409552 [details]
File: backtrace
Comment 2 Mihai Limbășan 2010-04-27 15:08:52 EDT
As far as I can tell, this looks like Samba bug #7250 (see https://bugzilla.samba.org/show_bug.cgi?id=7250 ). That bug suggests that the patch at

http://gitweb.samba.org/?p=samba.git;a=commitdiff;h=34f0cff0664f1c160ee7442461e9f875e8d8f4dc;hp=dc689827114c46b3ca2a75082421dc2d98001ce7 

fixes the issue.
Comment 3 Mihai Limbășan 2010-04-30 09:20:13 EDT
I can confirm that the upstream patch fixes the issue. I've rebuilt the samba packages locally including that patch and smbclient, as well as everything else linking against the SMB client libraries, works fine.

I've attached the upstream patch and the diff for the specfile I used below.
Comment 4 Mihai Limbășan 2010-04-30 09:21:33 EDT
Created attachment 410413 [details]
Patch to fix the SIGSEGV issue.
Comment 5 Mihai Limbășan 2010-04-30 09:22:01 EDT
Created attachment 410414 [details]
Specfile changes
Comment 6 Mihai Limbășan 2010-04-30 09:29:55 EDT
Erroneously saved the upstream patch as samba-3.2.5* instead of samba-3.5.2*. Oops. Obviously, it should be named according to the 3.5.2 release.
Comment 7 Adam Williamson 2010-04-30 15:22:47 EDT
*** Bug 573438 has been marked as a duplicate of this bug. ***
Comment 8 Adam Williamson 2010-04-30 15:23:13 EDT
*** Bug 581954 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2010-04-30 15:23:37 EDT
*** Bug 583516 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2010-04-30 15:29:38 EDT
This bug was discussed at the 2010/04/30 blocker review meeting.

Although it's a serious issue, we agreed it's not a blocker as it can be properly fixed by an update. However, it seems the fix is already known, and we would happily take the fix into the final release if it is ready in time.

Can Simo, jlayton or gdeschner please apply the fix and submit a new build as an update ASAP? We're working to a target date of 2010/05/04 to start building the RCs, so we really need the package to be available by then to get it in for final release. Thanks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Mihai Limbășan 2010-04-30 16:34:01 EDT
Thanks, Adam. I did a bit of soul-searching on whether to add it to F13Blocker or F13Target and finally decided on F13Blocker mostly due to potential PR issues for new users. Obviously it's no longer an issue at this end once a fix was found (I can live with local packages just fine) and I'd rather not see the likelihood of a release slip increased. I'll see it in an update then :)
Comment 12 Fedora Update System 2010-05-01 15:41:38 EDT
samba-3.5.2-60.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/samba-3.5.2-60.fc13
Comment 13 Simo Sorce 2010-05-01 15:45:43 EDT
I built a package with the patch. And I pushed it directly to stable in bodhi.
Adam can you check it gets included in F13 ?
Comment 14 Mihai Limbășan 2010-05-02 03:50:00 EDT
Thanks, Simo, reconfirmed it fixes the issue and doesn't wreak any havoc. will you or Adam be closing the bug as fixed, or should I?
Comment 15 Fedora Update System 2010-05-04 02:06:50 EDT
samba-3.5.2-60.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Pavel Alexeev 2010-05-04 03:50:04 EDT
I also affected by this problem. And I do not see such update in Fedora 13 updates (nor in testing http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/13/i386/ nor in stable http://download.fedora.redhat.com/pub/fedora/linux/updates/13/i386/). Have it pushed? Or I search in wrong place (yum also do not found it automatically)?
Comment 18 Mihai Limbășan 2010-05-04 05:49:58 EDT
Pavel, it takes time for the mirrors to sync. A bit of patience would be in order. If you really, really, really must have the new packages *right now*, you can always click on Simo's Koji link, https://admin.fedoraproject.org/updates/samba-3.5.2-60.fc13 , and install the packages manually. but I recommend a bit of patience.
Comment 19 Pavel Alexeev 2010-05-04 06:58:00 EDT
Thank you. I test it and it seams fix it bug.
Comment 20 Mihai Limbășan 2010-05-21 05:55:50 EDT
The patch is already provided by upstream (Samba 3.5.3). Updating to the -61 packages (currently in updates-testing) should also do the trick.

Note You need to log in before you can comment on or make changes to this bug.