Bug 590666 - [abrt] crash in gnome-bluetooth-2.30.0-1.fc13: raise: Process /usr/bin/bluetooth-wizard was killed by signal 6 (SIGABRT)
[abrt] crash in gnome-bluetooth-2.30.0-1.fc13: raise: Process /usr/bin/blueto...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:7062785b4e59384833297bc0e27...
: Regression
: 590550 591358 591373 591477 (view as bug list)
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-05-10 08:57 EDT by Richard Chan
Modified: 2013-01-10 00:57 EST (History)
9 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-10 15:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (13.82 KB, text/plain)
2010-05-10 08:57 EDT, Richard Chan
no flags Details

  None (edit)
Description Richard Chan 2010-05-10 08:57:38 EDT
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: bluetooth-wizard
component: gnome-bluetooth
crash_function: raise
executable: /usr/bin/bluetooth-wizard
global_uuid: 7062785b4e59384833297bc0e27e7280674dce67
kernel: 2.6.33.3-85.fc13.x86_64
package: gnome-bluetooth-2.30.0-1.fc13
rating: 4
reason: Process /usr/bin/bluetooth-wizard was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

comment
-----
Use gnome-bluetooth and wizard to pair Nokia E51 for Internet DUN.
Crashes just after 3G modem is detected and exported to NetworkManager.
Modem is immediately removed by modem-manager.

How to reproduce
-----
1. use gnome-bluetooth to setup new device
2. configure internet DUN connection
3. gnome-bluetooth wizard crashes just after 3G modem (Nokia E51) is detected
Comment 1 Richard Chan 2010-05-10 08:57:40 EDT
Created attachment 412824 [details]
File: backtrace
Comment 2 Bastien Nocera 2010-05-10 09:41:15 EDT
Crashes in the NM plugin, modem_get_all_cb()
Comment 3 Bastien Nocera 2010-05-10 09:45:01 EDT
*** Bug 590550 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2010-05-10 10:41:22 EDT
blocker rationale: Bastien notes that this is a recent regression (I'm guessing connected to the faffing about in NM last week), and Bluetooth DUN support is a Fedora 13 Feature - http://fedoraproject.org/wiki/Features/NetworkManagerBluetoothDUN
Comment 5 Adam Williamson 2010-05-10 11:59:20 EDT
it'd be nice to know the exact impact of this - does it affect PAN, and does it affect _all_ BT DUN hardware - but broadly we agreed at the QA meeting today we don't consider this blocker-worthy enough to slip release a week, it can be efficiently fixed via an update, though obviously it's unfortunate to ship with breakage in an official feature.
Comment 6 Bastien Nocera 2010-05-10 15:01:15 EDT
Apparently all DUN devices, not PAN.
Comment 7 Dan Williams 2010-05-10 17:54:43 EDT
upstream fix is 4b7ed9ee91611bb7aad2a672d53cee77e5037dab
Comment 8 Fedora Update System 2010-05-11 02:49:19 EDT
NetworkManager-0.8.1-0.1.git20100510.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc13
Comment 9 Fedora Update System 2010-05-11 02:55:22 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 10 Richard Chan 2010-05-11 04:57:53 EDT
I can confirm that the the koji update fixes it for me.

Fedora 13 Beta with all updates, Nokia E51 DUN.
Comment 11 Fedora Update System 2010-05-11 15:42:23 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc12
Comment 12 François Kooman 2010-05-11 16:07:49 EDT
Works for me now.

NetworkManager-0.8.1-0.1.git20100510.fc13.x86_64
Comment 13 Adam Williamson 2010-05-12 05:09:42 EDT
Adding this to F13Target. James, Jesse, do you think we should take this fix for RC3 now we've slipped? It seems a reasonable candidate to me.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Bastien Nocera 2010-05-12 06:11:23 EDT
*** Bug 591358 has been marked as a duplicate of this bug. ***
Comment 15 Bastien Nocera 2010-05-12 06:11:53 EDT
*** Bug 591373 has been marked as a duplicate of this bug. ***
Comment 16 Fedora Update System 2010-05-12 08:22:12 EDT
NetworkManager-0.8.1-0.1.git20100510.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/NetworkManager-0.8.1-0.1.git20100510.fc13
Comment 17 Bastien Nocera 2010-05-12 08:51:41 EDT
*** Bug 591477 has been marked as a duplicate of this bug. ***
Comment 18 James Laska 2010-05-12 10:05:00 EDT
* Mon May 10 2010 Dan Williams <dcbw@redhat.com> - 0.8.1-0.1.git20100510 
 - core: fix handling of IPv6 RA flags when router goes away (rh #588560)
 - bluetooth: fix crash configuring DUN connections from the wizard (rh #590666) 

* Sun May 09 2010 Dan Williams <dcbw@redhat.com> - 0.8-13.git20100509
 - core: restore initial accept_ra value for IPv6 ignored connections (rh #588619)
 - bluetooth: fix bad timeout on PAN connections (rh #586961) - applet: updated translations 

(In reply to comment #13)
> Adding this to F13Target. James, Jesse, do you think we should take this fix
> for RC3 now we've slipped? It seems a reasonable candidate to me.

I'm hesitant to pull in anything into a future release candidate, but we do have a karma system for confirming the update solves the reported issues and does not introduce regressions.  I don't object if this update receives the required karma.
Comment 19 Fedora Update System 2010-06-10 15:07:03 EDT
NetworkManager-0.8.1-0.1.git20100510.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.