Bug 600472 - crash in mutter when plugging a second monitor into an intel GPU
crash in mutter when plugging a second monitor into an intel GPU
Status: CLOSED DUPLICATE of bug 576883
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
abrt_hash:fedb4b0cad6b4b7853b40ae7ea6...
: Triaged
: 608213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-04 15:19 EDT by Andrea Dell'Amico
Modified: 2018-04-11 13:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 16:37:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (42.91 KB, text/plain)
2010-06-04 15:19 EDT, Andrea Dell'Amico
no flags Details
dmesg output (122.24 KB, text/plain)
2010-06-30 05:44 EDT, Andrea Dell'Amico
no flags Details
Contents of /var/log/messages (90.67 KB, text/plain)
2010-06-30 05:45 EDT, Andrea Dell'Amico
no flags Details
xorg.conf. (234 bytes, text/plain)
2010-06-30 05:46 EDT, Andrea Dell'Amico
no flags Details
Xorg log file for the session. (412.88 KB, text/plain)
2010-06-30 05:47 EDT, Andrea Dell'Amico
no flags Details

  None (edit)
Description Andrea Dell'Amico 2010-06-04 15:19:01 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: mutter
component: mutter
executable: /usr/bin/mutter
global_uuid: fedb4b0cad6b4b7853b40ae7ea6f04e93398d581
kernel: 2.6.33.5-112.fc13.i686.PAE
package: mutter-2.29.1-1.fc13
rating: 4
reason: Process /usr/bin/mutter was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Activate Gnome Shell
2. Use it for a while. On a system with an intel 945GM graphic card, don't know if it matters
3. Connect an external monitor ==> instant crash
Comment 1 Andrea Dell'Amico 2010-06-04 15:19:06 EDT
Created attachment 421331 [details]
File: backtrace
Comment 2 Max Whittingham 2010-06-26 00:06:33 EDT
Package: mutter-2.29.1-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1.Plugged VGA Cable in
2.Error
3.Error
Comment 3 Peter Robinson 2010-06-26 08:03:48 EDT
Max. Can you confirm what sort of video card you have please. A 'lspci | grep VGA' would be enough.
Comment 4 Peter Robinson 2010-06-26 08:23:52 EDT
*** Bug 608213 has been marked as a duplicate of this bug. ***
Comment 5 Peter Robinson 2010-06-26 08:27:04 EDT
I'm not sure if this is mesa or the intel driver but it seems like its intel based.
Comment 6 Matěj Cepl 2010-06-29 11:11:56 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 7 Andrea Dell'Amico 2010-06-30 05:44:24 EDT
Created attachment 427927 [details]
dmesg output

dmesg output for the session, the system booted with the kernel option drm.debug=0x04
Comment 8 Andrea Dell'Amico 2010-06-30 05:45:58 EDT
Created attachment 427928 [details]
Contents of /var/log/messages

This is the /var/log/messages file, from boot to shutdown. I purged the NetworkManager and named logs.
Comment 9 Andrea Dell'Amico 2010-06-30 05:46:59 EDT
Created attachment 427931 [details]
xorg.conf.
Comment 10 Andrea Dell'Amico 2010-06-30 05:47:31 EDT
Created attachment 427932 [details]
Xorg log file for the session.
Comment 11 Andrea Dell'Amico 2010-06-30 05:53:54 EDT
I attached the requested files.
mutter didn't crash this time, but I changed kernel in the meantime: I had a PAE kernel, now I'm using a 'normal' one to see if it mitigates frequency of bug #573177

My smolt profile, if it can be of any use: http://www.smolts.org/client/show/pub_3a4bcaeb-fcda-423a-9f49-dbca00f26f18
Comment 12 Matěj Cepl 2010-06-30 12:03:56 EDT
(In reply to comment #9)
> Created an attachment (id=427931) [details]
> xorg.conf.    

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"

		#Virtual 2560 1200
		Viewport   0 0
		Virtual   1700 2000
		Depth     24
	EndSubSection
EndSection

---------------------------

What's wrong with the default? Does it help when you remove this xorg.conf?
Comment 13 Andrea Dell'Amico 2010-06-30 12:19:42 EDT
In the past, without the "Virtual 1700 2000", it was impossible to add a second display for a xinerama configuration.
If it isn't needed anymore, I can remove it. Check in 10 minutes.
Comment 14 Andrea Dell'Amico 2010-06-30 12:37:27 EDT
My /etc/X11/xorg.conf is not needed anymore, the dual monitor configuration works without it.
But gnome-shell still doesn't work.
Comment 15 Hamidou Dia 2010-09-13 16:37:29 EDT
Hi Andrea,

Thanks for reporting the issue (and sorry to update you late).

This issue has been reported in Fedora 12 (Master ticket BZ#557027) and in Fedora 13 (Master ticket BZ#576883).

This a Desktop Effect triggered issue (Compiz + dual with your HW will trigger the same crasher.

I am closing this ticket, so please feel free to make any comment regarding this issue in the Master ticket corresponding to the version of Fedora that you are running now, and report whether or not, you can still reproduce the same issue (with the same backtrace showing crash around the sample_2d_linear function). If you try it reproduce it, please ensure that you are running a fully upgraded system (specially the intel video drivers).

Not sure it works, but feel free to report anyway.

PS: @ At Peter, Both BZ#557027 for F12 and F13 are assigned to xorg-x11-drv-intel so far.

As well Peter, with your permission, I will close 607564, 607559 and 603648 from the mutter component queue as dup of the BZ#576883 (F13)

Regards.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 576883 ***

Note You need to log in before you can comment on or make changes to this bug.