Bug 713109 - wicd crashes when daemon is not running
Summary: wicd crashes when daemon is not running
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: wicd
Version: 14
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:7cc26af9
Keywords:
: 715182 716691 718401 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-14 10:23 UTC by Raphael Groner
Modified: 2011-08-23 04:25 UTC (History)
10 users (show)

(edit)
Clone Of: 611104
(edit)
Last Closed: 2011-08-23 04:25:53 UTC


Attachments (Terms of Use)

Description Raphael Groner 2011-06-14 10:23:51 UTC
+++ This bug was initially created as a clone of Bug #611104 +++

abrt 1.1.1 detected a crash.

architecture: i686
cmdline: /usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --no-tray
component: wicd
executable: /usr/share/wicd/gtk/wicd-client.py
kernel: 2.6.33.5-124.fc13.i686
package: wicd-gtk-1.7.0-1.fc13
reason: gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'
release: Fedora release 13 (Goddard)

backtrace
-----
gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'

Traceback (most recent call last):
  File "/usr/share/wicd/gtk/wicd-client.py", line 1032, in <module>
    main(sys.argv)
  File "/usr/share/wicd/gtk/wicd-client.py", line 90, in wrapper
    return func(*args, **kwargs)
  File "/usr/share/wicd/gtk/wicd-client.py", line 998, in main
    the_gui = gui.appGui(standalone=True)
  File "/usr/share/wicd/gtk/gui.py", line 154, in __init__
    size = daemon.ReadWindowSize("main")
AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'

Local variables in innermost frame:
tray: None
self: <gui.appGui object at 0x8b37fec>
gladefile: '/usr/share/wicd/gtk/wicd.glade'
standalone: True

--- Additional comment from kvinayaks@yahoo.com on 2010-07-03 19:30:45 CEST ---

Created attachment 429279 [details]
File: backtrace

--- Additional comment from artix@hurr.ca on 2010-07-09 21:48:16 CEST ---

Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. installed wicd
2. installed wicd-gtk
3. started wicd

--- Additional comment from duck@duckland.org on 2010-07-15 05:02:15 CEST ---

Package: wicd-gtk-1.7.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. Install Fedora13 from Summit 2010 live USB
2. yum upgrade -y
3. reboot
4. yum install wicd\* -y
5. run wicd-gtk

--- Additional comment from dcantrell@redhat.com on 2010-07-15 15:50:20 CEST ---

To use wicd, you need to uninstall or disable NetworkManager.  After installing wicd packages, make sure you do:

    service NetworkManager stop
    chkconfig NetworkManager off
    chkconfig wicd on
    service wicd start

--- Additional comment from duck@duckland.org on 2010-07-16 04:01:40 CEST ---

If this is a know issue, why does wicd and NetworkManager have a Conflict line in the SPEC file?

--- Additional comment from dcantrell@redhat.com on 2010-07-16 20:46:12 CEST ---

I wanted to add a Conflict line, but the package reviewers disagreed.  Technically, the packages can be installed at the same time, so there's not really a conflict.  You can only run one or the other.

--- Additional comment from dcantrell@redhat.com on 2010-08-20 03:36:57 CEST ---

*** Bug 607702 has been marked as a duplicate of this bug. ***

--- Additional comment from dcantrell@redhat.com on 2010-08-20 03:37:35 CEST ---

*** Bug 607865 has been marked as a duplicate of this bug. ***

Comment 1 Raphael Groner 2011-06-14 10:25:24 UTC
Sorry, but please fix the crash. It's okay to show a message box about the failed connection to DBus. But the crash will cause a report to Abrt and that's not user-friendly.
-

Package:    	wicd-gtk-1.7.0-4.fc14
Latest Crash:	Di 14 Jun 2011 12:01:04 
Command:    	/usr/bin/python -O /usr/share/wicd/gtk/wicd-client.py --no-tray
Reason:     	gui.py:154:__init__:AttributeError: 'NoneType' object has no attribute 'ReadWindowSize'
Comment:    	Daemon wicd wasn't running and there's a message box not being able to connect to dbus then. After started the daemon, there's no crash any more.
Bug Reports:	Status: CLOSED NOTABUG
		https://bugzilla.redhat.com/show_bug.cgi?id=611104

Comment 2 piyush_harsh 2011-07-11 13:05:40 UTC
Package: wicd-gtk-1.7.0-4.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. installed WICD from System -> Administration -> Add/Remove Software
2. installed wicd-gtk package from System -> Administration -> Add/Remove Software
3. clicken on Application -> Internet -> Wicd Network Manager


Comment
-----
Launching the Wicd Network Manager causes this crash, NetworkManager was running already while this happened

Comment 3 Fedora Update System 2011-08-05 15:28:45 UTC
wicd-1.7.0-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/wicd-1.7.0-5.fc14

Comment 4 Fedora Update System 2011-08-05 23:59:03 UTC
Package wicd-1.7.0-5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wicd-1.7.0-5.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/wicd-1.7.0-5.fc14
then log in and leave karma (feedback).

Comment 5 Raphael Groner 2011-08-06 17:59:50 UTC
Package: wicd-gtk-1.7.0-4.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. wicd daemon wasn't running
2.
3.


Comment
-----
This is a test to reproduce the bug and verify the fix in updates-testing.

Comment 6 Raphael Groner 2011-08-06 18:06:05 UTC
Package: wicd-gtk-1.7.0-5.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. select Quit from context menu of wicd systray icon -> icon disappears
2. stop wicd daemon with system-config-services
3. try to start wicd-gtk -> message box and crash reported to abrt


Comment
-----
Sorry, but the -5 patch does not seem to fix this issue.

Comment 7 Raphael Groner 2011-08-06 19:25:38 UTC
You would need to add the patch also to the %prep section in the spec file as "%patch3 -p1" for instance, if you list it in the header as "Patch3: wicd-1.7.0-dbus-failure.patch".

Notice that there are even more patches for fc15 and fc16 applied already[1], so you maybe should first try to build against rawhide before fiddling with fc14 only. Further, you should sync the source to the very outdated looking git[2].

A good idea would also be to disable the Search and Connection info entries in the context menu of the systray icon if the daemon is not running. Both will lead to a crash due to a null pointer dereference, too. It happens when wicd-gtk was called from within a terminal.

[1] https://admin.fedoraproject.org/updates/wicd
[2] http://pkgs.fedoraproject.org/gitweb/?p=wicd.git

Comment 8 David Cantrell 2011-08-10 01:07:30 UTC
(In reply to comment #7)
> You would need to add the patch also to the %prep section in the spec file as
> "%patch3 -p1" for instance, if you list it in the header as "Patch3:
> wicd-1.7.0-dbus-failure.patch".

Yeah, that would help.  Stupid mistake.

> Notice that there are even more patches for fc15 and fc16 applied already[1],
> so you maybe should first try to build against rawhide before fiddling with
> fc14 only.

No, I'm working the stack of wicd bugs backwards right now, mainly due to the major changes from F-14 to F-15 to rawhide.  As the person who got wicd in to Fedora and the maintainer of the package, I'm aware of the patches on the other branches.

> Further, you should sync the source to the very outdated looking git[2].

What?

> A good idea would also be to disable the Search and Connection info entries in
> the context menu of the systray icon if the daemon is not running. Both will
> lead to a crash due to a null pointer dereference, too. It happens when
> wicd-gtk was called from within a terminal.

I don't want this bug to become a 100+ comment "hey, and fix this too!" bug chase.  I'm just trying to fix the issue originally reported.

Another test update coming up shortly.

Thanks for the feedback.

Comment 9 Fedora Update System 2011-08-11 23:31:22 UTC
Package wicd-1.7.0-6.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wicd-1.7.0-6.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/wicd-1.7.0-6.fc14
then log in and leave karma (feedback).

Comment 10 David Cantrell 2011-08-19 19:23:03 UTC
*** Bug 718401 has been marked as a duplicate of this bug. ***

Comment 11 David Cantrell 2011-08-19 20:09:15 UTC
*** Bug 715182 has been marked as a duplicate of this bug. ***

Comment 12 David Cantrell 2011-08-19 20:13:20 UTC
*** Bug 716691 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2011-08-23 04:25:48 UTC
wicd-1.7.0-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.