Bug 616730 - [abrt] crash in lxpolkit-0.1.0-0.1.20100402git5087383.fc13: vfprintf: Process /usr/libexec/lxpolkit was killed by signal 11 (SIGSEGV)
[abrt] crash in lxpolkit-0.1.0-0.1.20100402git5087383.fc13: vfprintf: Process...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: lxpolkit (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
https://sourceforge.net/tracker/?func...
abrt_hash:82e5efed759556900efbd6d2284...
:
: 617781 617883 619164 622205 626059 632981 650524 672522 (view as bug list)
Depends On: 622580
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-21 05:49 EDT by Sandro Janke
Modified: 2011-01-25 07:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 09:08:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (255.39 KB, text/plain)
2010-07-21 05:50 EDT, Sandro Janke
no flags Details

  None (edit)
Description Sandro Janke 2010-07-21 05:49:03 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/lxpolkit
comment: Crash happens everytime I login using LXDE desktop environment
component: lxpolkit
crash_function: vfprintf
executable: /usr/libexec/lxpolkit
global_uuid: 82e5efed759556900efbd6d22848201234e60317
kernel: 2.6.33.6-147.fc13.x86_64
package: lxpolkit-0.1.0-0.1.20100402git5087383.fc13
rating: 4
reason: Process /usr/libexec/lxpolkit was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)
Comment 1 Sandro Janke 2010-07-21 05:50:03 EDT
Created attachment 433363 [details]
File: backtrace
Comment 2 Christoph Wickert 2010-07-21 06:32:23 EDT
Did you disable polkit-gnome-authentication-agent?
Comment 3 Sandro Janke 2010-07-21 07:08:55 EDT
How/where would/could I do/verify that?
Comment 4 Christoph Wickert 2010-07-21 07:38:34 EDT
$ ps -A | grep policy

You will most likely see something like

 5768 ?        00:00:00 polkitd
 6126 ?        00:00:00 polkit-gnome-au

This means that polkit-gnome-authentication-agent-1 is running. To disable it start lxsession-edit and disable "PolicyKit Authentication Agent" there.
Comment 5 Sandro Janke 2010-07-21 08:32:58 EDT
polkit-gnome-authentication-agent was indeed enabled. After disabling it abrt no longer reports any crashes.

Thanks.
Comment 6 Christoph Wickert 2010-07-21 09:08:04 EDT
Well, even is there is another authentfication agent already claiming the service, lxpolkit shouldn't crash but silently exit, perhaps with a warning in ~/.xsession-errors but definitely not with a crash.

I forwarded your bug to https://sourceforge.net/tracker/?func=detail&aid=3032602&group_id=180858&atid=894869 for further investigation. Thanks for your report.
Comment 7 Christoph Wickert 2010-07-23 19:38:58 EDT
*** Bug 617781 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2010-07-24 13:46:03 EDT
*** Bug 617883 has been marked as a duplicate of this bug. ***
Comment 9 Jérémy Libion 2010-07-24 20:45:00 EDT
(In reply to comment #4)
> $ ps -A | grep policy
> 
> You will most likely see something like
> 
>  5768 ?        00:00:00 polkitd
>  6126 ?        00:00:00 polkit-gnome-au
> 
> This means that polkit-gnome-authentication-agent-1 is running. To disable it
> start lxsession-edit and disable "PolicyKit Authentication Agent" there.    

the command '$ ps -A | grep policy' do nothing for me

but in 'lxsession-edit' I see the "PolicyKit Authentication Agent" and I disable it, but I don't know if it work.

Sorry for my double or trouble post and sorry for my not perfect english
Comment 10 Christoph Wickert 2010-07-24 21:13:52 EDT
(In reply to comment #9)
> the command '$ ps -A | grep policy' do nothing for me

Sorry Jérémy, this was my fault, it should be

  $ ps -A | grep polkit

> Sorry for my double or trouble post and sorry for my not perfect english

No need to apologize. Your English is fine and the duplicate report is not your fault. The bug reporting tool should cover these duplicates automatically. Unfortunately this doesn't work and causes a lot of work for us maintainers. :(

Thanks for your feedback, it is highly appreciated.
Comment 11 Jérémy Libion 2010-07-25 09:55:39 EDT
This don't work, I do that and the terminal say:
[root@JRLaptop ~]# lxsession-edit

(lxsession-edit:2321): GLib-CRITICAL **: g_key_file_free: assertion `key_file != NULL' failed
Comment 12 Christoph Wickert 2010-07-25 10:40:52 EDT
This warning can be ignored, it doesn't impact the functionality of lxsession-edit.

What exactly does not work? Do you still have another PolicyKit authentication agent running?
Comment 13 Jérémy Libion 2010-07-25 11:02:20 EDT
I have 2 PolicyKit authentication, but every restart of the computer, one PolicyKit authentication enable hitself, I have a native kde with gnome et lxde, everytime I go to lxde, I see that error/bug
Comment 14 Christoph Wickert 2010-07-28 15:39:16 EDT
So you have 3 different desktops installed, KDE, GNOME and LXDE? Which agent is active after lxpolkit is crashing?

Please only use one authentification agent and make sure the others are disabled. You can disable polkit-gnome-authentication-agent-1 in LXDE by editing 
/etc/xdg/autostart/polkit-gnome-authentication-agent-1.desktop and adding 
"LXDE;" to the last line. It should look like this:

NotShowIn=KDE;LXDE;

Make sure you don't have a private copy of that file in ~/.config/autostart, remove it with

rm ~/.config/autostart/polkit-gnome-authentication-agent-1.desktop
Comment 15 Christoph Wickert 2010-07-28 15:39:33 EDT
*** Bug 619164 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Wickert 2010-08-08 06:35:56 EDT
*** Bug 622205 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Wickert 2010-08-21 21:07:30 EDT
*** Bug 626059 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Wickert 2010-09-12 07:36:43 EDT
*** Bug 632981 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Wickert 2010-11-06 17:30:22 EDT
*** Bug 650524 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Wickert 2011-01-25 07:45:28 EST
*** Bug 672522 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.