Bug 61851 - Anaconda crashes during firewall configuration.
Anaconda crashes during firewall configuration.
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 59668 62212 62768 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 04:50 EST by Alex Lancaster
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 13:58:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump, when I selecte no-firewall (30.73 KB, text/plain)
2002-03-27 05:38 EST, David Balažic
no flags Details

  None (edit)
Description Alex Lancaster 2002-03-25 04:50:40 EST
Description of Problem:

I am doing a "laptop" installation in "text" mode, when attempting to do the
firewall configuration section, upon pressing "OK" I get "An unhandled exception
has occured [sic]".  This happens I even when I reboot and choose different
options before pressing "OK".  Also happens when I attempt a "Custom"
installation.  I'm running an IBM ThinkPad 365XD (Pentium II, 133 MHz) with 24MB
of RAM.

Version-Release number of selected component (if applicable): N/A

How Reproducible:

Steps to Reproduce:

1. Boot from a floppy using the "boot.img" image. Select "English" and "US
keyboard".
2. Choose "Laptop" installation.
3. Select "Automatic" partitioning.
4. Choose "GRUB" boot-loader.
5. In firewall configuration leave defaults (i.e. "Medium" security) and simply
press "OK". 

Actual Results:

Get "Unhandled exception" and installation stops. 

Expected Results:

Firewall configuration should have worked and install should have proceeded.

Additional Information:

Traceback (transcribed manually as carefully as possible) follows:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 627 in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 406 in
run
    rc = apply(win, (self.screen, ) + args)
  File "/usr/lib/anaconda/textw/firewall_text.py", line 208, in __call__
    for dev in devicelist.getSelection():
NameError: devicelist


Looking at the Python code, I notice that "devicelist" is only set if the "if"
statement ("if devices != []:") on line 71 is called.  However in the "Pdb"
debugger, if attempt to print this variable I get:

(Pdb) print devices
[]

which leads me to suspect that if statement is not entered and hence
"devicelist" is not set... and the NameError.
Comment 1 Jay Turner 2002-03-25 09:04:46 EST
*** Bug 59668 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-03-25 19:17:34 EST
Fixed in CVS
Comment 3 Alex Lancaster 2002-03-26 01:27:57 EST
Great to hear that it's fixed in CVS, however, where is the CVS repository for
anaconda so I can test the fix?  I figured it should probably be at:

http://sources.redhat.com/cgi-bin/cvsweb.cgi/anaconda/?cvsroot=rhl

However, only the bootdisk, help text and po modules are listed there, not the
Python code.  Is this a  "private" Red Hat CVS module, if so could you send me
the fix by private e-mail.  I'm happy to help out and test the fix for your QA
people, but I need to be able to get it... ;-)

If I could successfully get the fix, is there way I could apply the fix against
a running anaconda (i.e. make the firewall configuration "work" on the fly, by
manually applying the change in the .py/.pyc module) without having to rebuild
the image, making a new ISO disk and re-burn?
Comment 4 David Balažic 2002-03-27 05:32:01 EST
I had a similar experiance.
Install from the Skipjack CD, text mode, Custom , use Disk Druid for 
partitioning hdb, select no boot loader,on the "Firewall Configuration" screen 
after I press OK it crashes, regardless of which FW config I select.

I have no ethernet card, maybe that is important ?

I attach one anaconda dump
Comment 5 David Balažic 2002-03-27 05:38:08 EST
Created attachment 50824 [details]
anaconda dump, when I selecte no-firewall
Comment 6 Jay Turner 2002-04-02 13:58:00 EST
*** Bug 62212 has been marked as a duplicate of this bug. ***
Comment 7 Jay Turner 2002-04-02 15:19:18 EST
Not able to replicate with the latest install trees.
Comment 8 Jeremy Katz 2002-04-05 09:06:48 EST
*** Bug 62768 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.