Bug 620823 - Ifcfg-rh plugin is not loaded when NM is run in anaconda's loader
Ifcfg-rh plugin is not loaded when NM is run in anaconda's loader
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
: 624939 625385 627897 631557 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 11:07 EDT by Radek Vykydal
Modified: 2010-09-29 10:26 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-14.17-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-29 10:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Syslog (52.81 KB, text/plain)
2010-08-03 11:07 EDT, Radek Vykydal
no flags Details

  None (edit)
Description Radek Vykydal 2010-08-03 11:07:31 EDT
Created attachment 436293 [details]
Syslog

Description of problem:

Ifcfg-rh plugin is not loaded when NM is run in anaconda's loader. Or is it something that should be configured on anaconda side?

Version-Release number of selected component (if applicable):

Fedora 14 TC1
NetworkManager 0.8.1-1.fc14

How reproducible:

Always

Steps to Reproduce:
1. Install F14 TC1 using network repo or stage2
  
Actual results:

Network enablement dialog in anaconda loader is skipped because network had already been brought up automatically when NM was started.

Expected results:

ifcfg config files written by anaconda prevent automatic network activation.

Additional info:

Attaching syslog
Comment 1 Dan Williams 2010-08-17 12:54:20 EDT
We tracked this down to a change NM made for config files; we deprecated nm-system-settings long ago (F13 timeframe) but only now is the NM tarball actually shipping NetworkManager.conf.  So the anaconda image creation scripts should get updated to:

s/nm-system-settings.conf/NetworkManager.conf

everywhere; there are two places to fix for that.
Comment 2 Chris Lumens 2010-08-17 13:02:18 EDT

*** This bug has been marked as a duplicate of bug 623937 ***
Comment 3 Radek Vykydal 2010-08-18 08:05:47 EDT
*** Bug 624939 has been marked as a duplicate of this bug. ***
Comment 4 Radek Vykydal 2010-08-18 09:28:51 EDT
Moving back to assigned as the fix is not in f14-branch yet.
Comment 5 Radek Vykydal 2010-08-18 09:38:15 EDT
Should be fixed in anaconda-14.17-1.
Comment 6 Radek Vykydal 2010-08-19 06:17:16 EDT
*** Bug 625385 has been marked as a duplicate of this bug. ***
Comment 7 Radek Vykydal 2010-08-19 06:33:31 EDT
*** Bug 624992 has been marked as a duplicate of this bug. ***
Comment 8 Radek Vykydal 2010-08-27 06:55:59 EDT
*** Bug 627897 has been marked as a duplicate of this bug. ***
Comment 9 Radek Vykydal 2010-09-13 12:52:21 EDT
*** Bug 631557 has been marked as a duplicate of this bug. ***
Comment 10 Adam Williamson 2010-09-27 20:27:39 EDT
this should be fixed in Beta, can anyone confirm with testing?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Kamil Páral 2010-09-29 07:06:31 EDT
I can confirm that 624939 and 625385 (duplicates of this bug) are fixed in F14 Beta.
Comment 12 Adam Williamson 2010-09-29 10:26:25 EDT
Then let's closerificate it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.