Bug 6270 - Operations, Preferences dumps core.
Operations, Preferences dumps core.
Status: CLOSED DUPLICATE of bug 6534
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-22 17:10 EDT by Sam Varshavchik
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-05 14:37:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 1999-10-22 17:10:26 EDT
gnorpm-0.9-10

Menu "Operations", option "Preferences" dumps core
immediately if the machine is off the network.

Script started on Fri Oct 22 16:57:11 1999
[root@gwl root]# gnorpm
Can't resolve host name "unix"!

[ select "Operations", "Preferences", the following output
immediately comes up ]

LibFind-Message: downloading
http://www.redhat.com/RDF/resources/distribs/metadata.rdf

LibFind-WARNING **: processing request failed

LibFind-WARNING **: Couldn't get data at
http://www.redhat.com/RDF/resources/distribs/metadata.rdf

LibFind-WARNING **: couldn't grab metadata server list

Gtk-CRITICAL **: file gtkcombo.c: line 817
(gtk_combo_set_popdown_strings): assertion `strings != NULL'
failed.
LibFind-Message: downloading
http://www.redhat.com/RDF/resources/distribs/list.rdf

LibFind-WARNING **: processing request failed

LibFind-WARNING **: Couldn't get data at
<90><83>^p^BT@ww.redhat.com/RDF/resources/distribs/list.rdf
Can't resolve host name "unix"!
Aborted (core dumped)
[root@gwl root]# gdb /usr/bin/gnorpm core
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public
License, and you are
welcome to change it and/or distribute copies of it under
certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show
warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `gnorpm'.
Program terminated with signal 6, Aborted.
Reading symbols from /usr/lib/libgnomeui.so.32...
(no debugging symbols found)...done.
Reading symbols from /usr/lib/libart_lgpl.so.2...
(no debugging symbols found)...done.
Reading symbols from /usr/lib/libgdk_imlib.so.1...
(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6...
(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6...
(no debugging symbols found)...done.
Reading symbols from /usr/lib/libgtk-1.2.so.0...(no
debugging symbols found)...
done.
Reading symbols from /usr/lib/libgdk-1.2.so.0...(no
debugging symbols found)...
---Type <return> to continue, or q <return> to quit---
done.
Reading symbols from /usr/lib/libgmodule-1.2.so.0...
(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6...
(no debugging symbols found)...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6...
(no debugging symbols found)...done.
Reading symbols from /usr/lib/libgnome.so.32...(no debugging
symbols found)...
done.
Reading symbols from /usr/lib/libgnomesupport.so.0...
(no debugging symbols found)...done.
Reading symbols from /usr/lib/libesd.so.0...(no debugging
symbols found)...
done.
Reading symbols from /usr/lib/libaudiofile.so.0...done.
Reading symbols from /lib/libm.so.6...done.
Reading symbols from /lib/libdb.so.2...done.
Reading symbols from /usr/lib/libglib-1.2.so.0...done.
Reading symbols from /lib/libdl.so.2...done.
Reading symbols from /usr/lib/libxml.so.1...done.
Reading symbols from /usr/lib/libz.so.1...done.
Reading symbols from /usr/lib/libghttp.so.1...done.
Reading symbols from /usr/lib/librpm.so.0...done.
Reading symbols from /usr/lib/libbz2.so.0...done.
---Type <return> to continue, or q <return> to quit---
Reading symbols from /lib/libc.so.6...
done.
Reading symbols from /lib/ld-linux.so.2...done.
Reading symbols from /lib/libnss_files.so.2...done.
Reading symbols from /lib/libnss_nisplus.so.2...done.
Reading symbols from /lib/libnsl.so.1...done.
Reading symbols from /lib/libnss_nis.so.2...done.
Reading symbols from /lib/libnss_dns.so.2...done.
Reading symbols from /lib/libresolv.so.2...done.
Reading symbols from /usr/lib/gconv/ISO8859-1.so...done.
Reading symbols from
/usr/lib/gtk/themes/engines/libpixmap.so...done.
Reading symbols from /usr/lib/libimlib-png.so...done.
Reading symbols from /usr/lib/libpng.so.2...done.
#0  0x404714e1 in __kill () from /lib/libc.so.6
(gdb)
(gdb) where
#0  0x404714e1 in __kill () from /lib/libc.so.6
#1  0x40471156 in raise (sig=6) at
../sysdeps/posix/raise.c:27
#2  0x40472868 in abort () at ../sysdeps/generic/abort.c:88
#3  0x40080df6 in gnome_segv_handle () from
/usr/lib/libgnomeui.so.32
#4  0x40471408 in __restore ()
    at ../sysdeps/unix/sysv/linux/i386/sigaction.c:127
#5  0x403d0d0b in xmlSAXParseFile () from
/usr/lib/libxml.so.1
#6  0x403d0d9d in xmlParseFile () from /usr/lib/libxml.so.1
#7  0x806e9de in rdfRead ()
#8  0x806c3bc in ftpStrerror ()
#9  0x806c579 in distribGetList ()
#10 0x8066931 in rpm_props_box_get_type ()
#11 0x402136d1 in gtk_type_new () from
/usr/lib/libgtk-1.2.so.0
#12 0x806724b in rpm_props_box_new ()
#13 0x8055afb in create_main ()
#14 0x401c0b4d in gtk_marshal_NONE__NONE () from
/usr/lib/libgtk-1.2.so.0
#15 0x401edfdd in gtk_handlers_run () from
/usr/lib/libgtk-1.2.so.0
#16 0x401ed422 in gtk_signal_real_emit () from
/usr/lib/libgtk-1.2.so.0
#17 0x401eb575 in gtk_signal_emit () from
/usr/lib/libgtk-1.2.so.0
#18 0x402208c8 in gtk_widget_activate () from
/usr/lib/libgtk-1.2.so.0
#19 0x401c813b in gtk_menu_shell_activate_item () from
/usr/lib/libgtk-1.2.so.0
#20 0x401c74bb in gtk_menu_shell_button_release ()
   from /usr/lib/libgtk-1.2.so.0
---Type <return> to continue, or q <return> to quit---
#21 0x401c0719 in gtk_marshal_BOOL__POINTER () from
/usr/lib/libgtk-1.2.so.0
#22 0x401ed45b in gtk_signal_real_emit () from
/usr/lib/libgtk-1.2.so.0
#23 0x401eb575 in gtk_signal_emit () from
/usr/lib/libgtk-1.2.so.0
#24 0x4022077c in gtk_widget_event () from
/usr/lib/libgtk-1.2.so.0
#25 0x401c0672 in gtk_propagate_event () from
/usr/lib/libgtk-1.2.so.0
#26 0x401bf8ca in gtk_main_do_event () from
/usr/lib/libgtk-1.2.so.0
#27 0x4026a00b in gdk_event_dispatch () from
/usr/lib/libgdk-1.2.so.0
#28 0x403a7be6 in g_main_dispatch () from
/usr/lib/libglib-1.2.so.0
#29 0x403a81a1 in g_main_iterate () from
/usr/lib/libglib-1.2.so.0
#30 0x403a8341 in g_main_run () from
/usr/lib/libglib-1.2.so.0
#31 0x401bf209 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#32 0x8053384 in main ()
#33 0x4046b1eb in __libc_start_main (main=0x805315c <main>,
argc=1,
    argv=0xbffffb44, init=0x8050bf8 <_init>, fini=0x806f2dc
<_fini>,
    rtld_fini=0x4000a610 <_dl_fini>, stack_end=0xbffffb3c)
    at ../sysdeps/generic/libc-start.c:90
(gdb) quit
[root@gwl root]# exit
Comment 1 culliton 1999-10-30 17:29:59 EDT
Duplicate of bugzilla #5523.
Comment 2 zmt 1999-12-07 04:23:59 EST
What more info. do you need to fix this problem? Where can I edit the
configuration to rid myself of this? With duplicate or nearly duplicate bugs
#5721, #6335, #6611, #6612, #6657, #6659, #6888, #7107, & #6759, I would think
that someone would at least post some further info. or a work-around if it's
really that difficult a fix. Then again, I notice that these bugs are all owned
by msw@redhat.com - MS???!!! It looks like it to me now.
Comment 3 Bill Nottingham 2000-02-05 14:37:59 EST
*** This bug has been marked as a duplicate of 6534 ***

Note You need to log in before you can comment on or make changes to this bug.