This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 642248 - avogadro SIGABRT from __cxa_rethrow of boost::python::error_already_set - The _C_API object in the sip python module is invalid
avogadro SIGABRT from __cxa_rethrow of boost::python::error_already_set - The...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avogadro (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
abrt_hash:5d412730fcf4c3f88a4e8388937...
: Patch
: 649236 650943 653547 655079 655848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-12 09:00 EDT by Vytas
Modified: 2010-11-24 17:39 EST (History)
9 users (show)

See Also:
Fixed In Version: avogadro-1.0.1-10.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-24 17:39:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (34.23 KB, text/plain)
2010-10-12 09:00 EDT, Vytas
no flags Details
possible fix (768 bytes, patch)
2010-11-23 15:04 EST, Edward Sheldrake
no flags Details | Diff

  None (edit)
Description Vytas 2010-10-12 09:00:42 EDT
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/avogadro
component: avogadro
crash_function: __gnu_cxx::__verbose_terminate_handler()
executable: /usr/bin/avogadro
kernel: 2.6.34.7-56.fc13.x86_64
package: avogadro-1.0.1-6.fc14
rating: 3
reason: Process /usr/bin/avogadro was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1286888373
uid: 500

How to reproduce
-----
1. Just run it.
Comment 1 Vytas 2010-10-12 09:00:45 EDT
Created attachment 452958 [details]
File: backtrace
Comment 2 Kevin Kofler 2010-11-15 12:14:18 EST
*** Bug 646375 has been marked as a duplicate of this bug. ***
Comment 3 Kevin Kofler 2010-11-15 12:14:32 EST
*** Bug 649236 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Kofler 2010-11-15 12:18:06 EST
Bug 649236 has more information about what exactly is being rethrown:

comment
-----
Eventually this is not an avogadro bug. here is the console output

The _C_API object in the sip python module is invalid.
Could not initialize SIP API !
terminate called after throwing an instance of
'boost::python::error_already_set'
Aborted (core dumped)
Comment 5 Kevin Kofler 2010-11-15 12:19:31 EST
*** Bug 650943 has been marked as a duplicate of this bug. ***
Comment 6 Kevin Kofler 2010-11-15 12:19:51 EST
*** Bug 653547 has been marked as a duplicate of this bug. ***
Comment 7 Pietro Amodeo 2010-11-18 12:00:44 EST
Package: avogadro-1.0.1-6.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Just started the program
2.
3.
Comment 8 Kevin Kofler 2010-11-19 10:37:08 EST
*** Bug 655079 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Kofler 2010-11-22 09:32:40 EST
*** Bug 655848 has been marked as a duplicate of this bug. ***
Comment 10 Edward Sheldrake 2010-11-23 15:04:50 EST
Created attachment 462431 [details]
possible fix

The problem appears to be avogadro being incompatible with sip + python 2.7, because sip started using PyCapsule (sip 4.10.4 NEWS).

I don't know python, the patch is entirely based on http://docs.python.org/whatsnew/2.7.html#capsules
Comment 11 Kevin Kofler 2010-11-23 15:15:02 EST
Hmmm, I wonder if bug 646375 is actually a different issue, because that one is on F13, which doesn't have Python 2.7. All the others are on F14, which makes sense.
Comment 12 Kevin Kofler 2010-11-23 15:19:23 EST
Have you tested this patch?
Comment 13 Edward Sheldrake 2010-11-23 15:27:30 EST
Yes, it appears to work - open a sample file, then in the python console:

import Avogadro
Avogadro.molecule.clear()

And, avogadro also starts up.
Comment 14 Fedora Update System 2010-11-23 16:13:32 EST
avogadro-1.0.1-10.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/avogadro-1.0.1-10.fc14
Comment 15 Fedora Update System 2010-11-24 17:39:35 EST
avogadro-1.0.1-10.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.