Bug 646041 - Missing "OK" button
Summary: Missing "OK" button
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-keyboard
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 650613 676388 678162 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-24 00:17 UTC by Masami Ichikawa
Modified: 2011-08-23 04:38 UTC (History)
11 users (show)

Fixed In Version: system-config-keyboard-1.3.1-5.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 03:32:30 UTC
Type: ---


Attachments (Terms of Use)
GUI screeen (17.70 KB, image/png)
2010-10-24 00:18 UTC, Masami Ichikawa
no flags Details
do not remove the OK button (765 bytes, patch)
2010-11-08 15:12 UTC, Michal Schmidt
no flags Details | Diff

Description Masami Ichikawa 2010-10-24 00:17:23 UTC
Description of problem:
system-config-keyboard gui screen doesn't have "OK" button. F13's s-c-k has it.

Version-Release number of selected component (if applicable):
system-config-keyboard-1.3.1-2.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1.run system-config-keyboard from terminal or menu.
  
Actual results:
There is no "OK" button.

Expected results:
GUI has "OK" button.

Comment 1 Masami Ichikawa 2010-10-24 00:18:41 UTC
Created attachment 455297 [details]
GUI screeen

I added a screenshot.

Comment 2 Masami Ichikawa 2010-10-24 00:48:45 UTC
I checked Gnome desktop(x86_64) and LXDE spin(i686) both has the issue.

Comment 3 Michal Schmidt 2010-11-08 15:12:42 UTC
Created attachment 458769 [details]
do not remove the OK button

Comment 4 Michal Schmidt 2010-11-08 15:14:47 UTC
*** Bug 650613 has been marked as a duplicate of this bug. ***

Comment 5 Till Maas 2010-11-22 18:09:39 UTC
Just wondering, since this bug is still open. How is one supposed to select a different keyboard layout? For me it did not work clicking as fast as I could or pressing enter or anything else on the F14 live medium.

Comment 6 Till Maas 2010-11-22 19:03:20 UTC
In case someone else gets hit by this bug:
A workaround for the F14 Live iso is to use gnome-keyboard-properties, with some excessive clicking it is possible to change the layout. One needs to add a different layout and select it.

Comment 7 Masami Ichikawa 2010-11-23 01:00:56 UTC
you can run s-c-k by text mode.
#system-config-keyboard --text

Comment 8 Michal Pomorski 2010-12-06 16:33:46 UTC
I confirm this bug, there is no way to confirm selection in gui mode.
--text mode works in the mean time.

Comment 9 Jeff Moe (jebba) 2010-12-12 20:15:57 UTC
I can confirm the bug and that `system-config-keyboard --text` worked around the problem for me.

Comment 10 Till Maas 2011-02-27 22:00:06 UTC
*** Bug 678162 has been marked as a duplicate of this bug. ***

Comment 11 Till Maas 2011-02-27 22:00:18 UTC
*** Bug 676388 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2011-06-17 15:10:01 UTC
system-config-keyboard-1.3.1-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-5.fc15

Comment 13 Fedora Update System 2011-06-17 15:10:15 UTC
system-config-keyboard-1.3.1-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-5.fc14

Comment 14 Fedora Update System 2011-06-17 15:10:28 UTC
system-config-keyboard-1.3.1-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-5.fc13

Comment 15 Toshio Ernie Kuratomi 2011-06-17 15:14:03 UTC
Thanks to Itamar for pointing this out.  I've built a package with this patch, please test it and leave bodhi comments if it's good to push to stable.

Comment 16 Fedora Update System 2011-06-21 17:09:21 UTC
Package system-config-keyboard-1.3.1-5.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-keyboard-1.3.1-5.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-keyboard-1.3.1-5.fc15
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-06-24 03:32:19 UTC
system-config-keyboard-1.3.1-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-08-23 04:38:30 UTC
system-config-keyboard-1.3.1-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.