Bug 64711 - Exception Occured while checking hard disk for bad blocks
Exception Occured while checking hard disk for bad blocks
Status: CLOSED DUPLICATE of bug 66181
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: 64992 65013 65151 65162 65169 67478 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-05-09 16:36 EDT by Heikki Kiviranta
Modified: 2007-04-18 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-17 17:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda crashed on the checking for bad sectors (73.62 KB, text/plain)
2002-05-10 02:41 EDT, dan
no flags Details

  None (edit)
Description Heikki Kiviranta 2002-05-09 16:36:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
File "/usr/bin/anaconda", line 633m in ? intf.run (id, dispatch, configFileData)
File "/usr/lib/anaconda/text.py", line 427, in run dispatch,gotoNext()
File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
val = (long(l[0]) * 100) / long(l[1])
Value Error: invalid literal for long(): 267840 267841

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Nothing special, just selecting scan for bad blocks at partitioning. Hard disk 
does have bad sectors, and check couldn't get pass them.


Actual Results:  Unhandled exception.

Expected Results:  It should have scanned bad blocks, and marked them. Nothing 

Additional info:

harddisk: Old seagate ~500mb with few bad sectors.
Comment 1 dan 2002-05-10 02:41:03 EDT
Created attachment 56905 [details]
anaconda crashed on the checking for bad sectors
Comment 2 James Johnson 2002-05-10 02:52:35 EDT
I have had the exact same problem. Installed RHL 7.3 on a brand new system
including out of the box HDD. Once I removed the "check for bad blocks",
installed as before it worked fine.

After install i used: badblocks /dev/hda6 and it found three bad blocks.

Here is the anacron output:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 375, in turnOnFilesystems
  File "/usr/lib/anaconda/fsset.py", line 1007, in checkBadblocks
    self.badblocksEntry(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
    entry.fsystem.badblocksDevice(entry, self.progressWindow, chroot)
  File "/usr/lib/anaconda/fsset.py", line 210, in badblocksDevice
    l = string.split(num, '/')
TypeError: argument 1: expected read-only character buffer, int found
Comment 3 Jeremy Katz 2002-05-20 15:08:25 EDT
*** Bug 65169 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2002-05-20 15:09:49 EDT
*** Bug 65162 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2002-05-20 15:10:27 EDT
*** Bug 65151 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2002-05-20 15:16:01 EDT
*** Bug 65013 has been marked as a duplicate of this bug. ***
Comment 7 Michael Fulbright 2002-05-20 15:19:57 EDT
*** Bug 64992 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2002-06-17 17:27:55 EDT
This error occurs when the badblocks command detects bad blocks on the system. 
The traceback occurred because the output from the badblocks command has
changed, fooling our parser.

If you get this traceback it means you have bad blocks on the drive it was testing.

In the future an error dialog will be presented saying bad blocks have been
Comment 9 Michael Fulbright 2002-06-17 17:31:14 EDT

*** This bug has been marked as a duplicate of 66181 ***
Comment 10 Tom McQueeney 2002-06-19 15:45:33 EDT
Wait a minute.

Does the fact that this bug is closed mean nothing is going to be fixed? I can't
install RedHat 7.3 because of this bug. I have several bad blocks in my hard
disk, but that shouldn't mean the hard disk is unusable. That's the whole point
of scanning for bad blocks -- so they can be marked as "do not use." Heck, DOS
was able to handle the bad blocks. Are you saying this is too complicated for

I would very much appreciate this bug being fixed. I'd like to install 7.3. But
till this bug is fixed, I can't.
Comment 11 Michael Fulbright 2002-06-26 00:59:32 EDT
*** Bug 67478 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.