Bug 652604 - [abrt] terminate in framework::AutoRecovery::implts_dispatch
[abrt] terminate in framework::AutoRecovery::implts_dispatch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
14
i686 Unspecified
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:f2bf4effa26242b3e83e27af2a3...
:
: 655429 655784 656184 658484 661175 661289 662044 662053 663555 666671 669261 669400 669691 670099 671604 671605 673523 674368 674604 676001 676087 676433 677690 684306 684435 684436 689587 697337 701792 705197 711271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-12 05:23 EST by adriano
Modified: 2011-06-21 13:14 EDT (History)
34 users (show)

See Also:
Fixed In Version: openoffice.org-3.3.0-20.6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 13:14:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (45.40 KB, text/plain)
2010-11-12 05:23 EST, adriano
no flags Details

  None (edit)
Description adriano 2010-11-12 05:23:19 EST
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/soffice.bin -quickstart -nologo -nodefault
comment: Happens on session start
component: openoffice.org
crash_function: raise
executable: /usr/lib/openoffice.org3/program/soffice.bin
kernel: 2.6.35.6-48.fc14.i686.PAE
package: openoffice.org-brand-1:3.3.0-13.3.fc14
rating: 4
reason: Process /usr/lib/openoffice.org3/program/soffice.bin was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1289502689
uid: 500
Comment 1 adriano 2010-11-12 05:23:22 EST
Created attachment 460006 [details]
File: backtrace
Comment 2 David Tardon 2010-11-22 04:44:20 EST
*** Bug 655429 has been marked as a duplicate of this bug. ***
Comment 3 David Tardon 2010-11-22 04:45:27 EST
Is there a way to reproduce that, e.g., with a concrete document opened?
Comment 4 adriano 2010-11-22 05:47:21 EST
I use Avant window navigator, and at session start I have always ABRT crash reports. I noticed that awn is buggy in fedora 14... 
Only at session start I have also this openoffice crash report (quick starter crash?) and not in open documents.
I hope this can help you.
Thanks
Adriano
Comment 5 David Tardon 2010-11-22 08:29:29 EST
*** Bug 655784 has been marked as a duplicate of this bug. ***
Comment 6 David Tardon 2010-11-23 02:44:11 EST
*** Bug 656184 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2010-11-30 09:43:12 EST
*** Bug 658484 has been marked as a duplicate of this bug. ***
Comment 8 David Tardon 2010-12-08 02:09:26 EST
*** Bug 661175 has been marked as a duplicate of this bug. ***
Comment 9 David Tardon 2010-12-08 08:19:05 EST
*** Bug 661289 has been marked as a duplicate of this bug. ***
Comment 10 Caolan McNamara 2010-12-10 07:33:43 EST
*** Bug 662044 has been marked as a duplicate of this bug. ***
Comment 11 Rado 2010-12-13 06:03:31 EST
Package: openoffice.org-brand-1:3.3.0-17.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.You work with OO
2.You perform shutdown
3.


Comment
-----
If you leave OO windows open when you perform shutdown OO crashes everytime
Comment 12 Pavel Alexeev 2010-12-13 10:16:45 EST
Package: openoffice.org-brand-1:3.3.0-17.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
reboot computer
Comment 13 Pavel Alexeev 2010-12-13 10:18:57 EST
Package: openoffice.org-brand-1:3.3.0-17.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
reboot computer
Comment 14 David Tardon 2010-12-16 02:43:24 EST
*** Bug 663555 has been marked as a duplicate of this bug. ***
Comment 15 David Tardon 2011-01-02 02:24:30 EST
*** Bug 666671 has been marked as a duplicate of this bug. ***
Comment 16 David Tardon 2011-01-13 01:29:52 EST
*** Bug 669261 has been marked as a duplicate of this bug. ***
Comment 17 David Tardon 2011-01-13 11:01:09 EST
*** Bug 669400 has been marked as a duplicate of this bug. ***
Comment 18 David Tardon 2011-01-14 08:58:45 EST
*** Bug 669691 has been marked as a duplicate of this bug. ***
Comment 19 Jeffrey S Austin 2011-01-16 14:06:31 EST
Package: openoffice.org-brand-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Went to open LightSpark while at http://www.ford.com/2011Superduty/?p=field&intcmp=fv-fv-a1b07c02d000656e17f11g05h17j11k09m5n0p20110111 and it crashed.
Comment 20 Jeffrey S Austin 2011-01-16 22:29:44 EST
Package: openoffice.org-brand-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Don't know how it happened.
Comment 21 David Tardon 2011-01-17 04:04:09 EST
*** Bug 670099 has been marked as a duplicate of this bug. ***
Comment 22 jameshusby 2011-01-18 13:32:25 EST
Package: openoffice.org-calc-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Hybernate
2.restore
3.crash
Comment 23 Lari Tanase 2011-01-19 08:05:50 EST
Package: openoffice.org-calc-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. After update of linux one pop-up with logout/login appeared
2. click on logout
3. some of the documents wasn't saved - and in that moment crashed
4. after login - was able to recover at previous state
Comment 24 todd.heidenthal 2011-01-19 11:23:10 EST
Package: openoffice.org-brand-1:3.3.0-18.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Happened many days ago, I can't remember
2.
3.
Comment 25 David Tardon 2011-01-22 01:58:23 EST
*** Bug 671604 has been marked as a duplicate of this bug. ***
Comment 26 David Tardon 2011-01-22 01:58:48 EST
*** Bug 671605 has been marked as a duplicate of this bug. ***
Comment 27 David Tardon 2011-01-28 10:14:46 EST
*** Bug 673523 has been marked as a duplicate of this bug. ***
Comment 28 Tad 2011-02-01 09:49:38 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
t
Comment 29 David Tardon 2011-02-01 11:38:57 EST
*** Bug 674368 has been marked as a duplicate of this bug. ***
Comment 30 jameshusby 2011-02-01 11:56:58 EST
Package: openoffice.org-writer-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.going into or out of hybernate
2.
3.
Comment 31 Tad 2011-02-02 03:45:22 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
a
Comment 32 Caolan McNamara 2011-02-02 10:39:51 EST
*** Bug 662053 has been marked as a duplicate of this bug. ***
Comment 33 Caolan McNamara 2011-02-02 11:27:37 EST
*** Bug 674604 has been marked as a duplicate of this bug. ***
Comment 34 Tad 2011-02-07 06:06:47 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
a
Comment 35 Tad 2011-02-07 06:07:28 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 36 Tad 2011-02-07 06:08:53 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 37 Tad 2011-02-07 06:10:12 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 38 Tad 2011-02-07 06:10:45 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 39 Bob Gustafson 2011-02-07 17:14:41 EST
(In reply to comment #38)
(In reply to comment #37)
(In reply to comment #36)
(In reply to comment #35)
(In reply to comment #31)
> Package: openoffice.org-brand-1:3.3.0-19.2.fc14
> Architecture: x86_64
> OS Release: Fedora release 14 (Laughlin)
> 
> 
> How to reproduce
> -----
> 1.
> 2.
> 3.
> a

It looks like you have an administrative script gone wild..

Looking over the 'How to reproduce' already given, it seems that you can reproduce the problem by:

1. Run OpenOffice (with the Quickstarter active)
2. Shutdown your system
3. Watch the crash.
Comment 40 Caolan McNamara 2011-02-08 10:38:05 EST
*** Bug 676001 has been marked as a duplicate of this bug. ***
Comment 41 Piotr Kolaczek 2011-02-08 10:39:42 EST
Package: openoffice.org-brand-1:3.3.0-19.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.

n
Comment 42 Piotr Kolaczek 2011-02-08 11:19:46 EST
Package: openoffice.org-brand-1:3.3.0-17.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 43 Caolan McNamara 2011-02-08 15:32:37 EST
*** Bug 676087 has been marked as a duplicate of this bug. ***
Comment 44 David Tardon 2011-02-10 00:07:52 EST
*** Bug 676433 has been marked as a duplicate of this bug. ***
Comment 45 Bob Gustafson 2011-02-11 12:51:25 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Have OpenOffice Quickstarter running
2. Shutdown your system
3. Watch Crash


Comment
-----
I have automatic upgrades enabled. When one batch was finished, it said I needed to logoff to complete the upgrade installation.

Before the logoff was completed, I was in this Automatic Bug Reporting tool - downloading debug versions of all the libraries. This is about the 6th time I have done this for this same bug.. It takes a long time.
Comment 46 David Juran 2011-02-12 09:08:09 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. The systray quickstarter is running 
2. I logged out of the machine
Comment 47 Jeffrey S Austin 2011-02-13 16:00:36 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Crashed upon login on to the workstation.
Comment 48 Jeffrey S Austin 2011-02-13 18:05:30 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Crashed upon login.
Comment 49 Jeffrey S Austin 2011-02-13 21:41:44 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Logging off.
Comment 50 David Tardon 2011-02-15 11:01:40 EST
*** Bug 677690 has been marked as a duplicate of this bug. ***
Comment 51 Dave Galloway 2011-02-16 04:56:14 EST
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. installing faxtalk
2.
3.
Comment 52 Alexey Larkov 2011-02-18 01:26:33 EST
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Launch failed
2.
3.
Comment 53 Tad 2011-02-24 02:03:57 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
During turn off computer
Comment 54 Scott Castaline 2011-02-24 10:10:40 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Logging out or shutting down
2.
3.


Comment
-----
Everytime I either log off or the logging off during shutdown process I will get an alert. Now everytime I log in I get the recovery dialog with "Untitled 1" needing to be recovered. I have the quickstart set to launch at login, which immediately gives me the recovery dialog. When I do select the file and click start recovery nothing appears to happen, the dialog box just goes away.
Comment 55 Jeffrey S Austin 2011-03-10 17:28:14 EST
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
Don't Know.
Comment 56 Caolan McNamara 2011-03-11 14:55:05 EST
*** Bug 684306 has been marked as a duplicate of this bug. ***
Comment 57 David Tardon 2011-03-12 12:35:32 EST
*** Bug 684436 has been marked as a duplicate of this bug. ***
Comment 58 David Tardon 2011-03-12 12:35:40 EST
*** Bug 684435 has been marked as a duplicate of this bug. ***
Comment 59 Bob Gustafson 2011-03-19 14:20:10 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I downloaded updates, which requested a logout
2. I logged out, (crash there too), then logged back in
3. When I was logged in, but before starting back up many applications, I did a reboot
4. On the reboot, openxx crashed again, but at least I was able to send this report.


Comment
-----
See above
Comment 60 Caolan McNamara 2011-03-21 16:35:50 EDT
*** Bug 689587 has been marked as a duplicate of this bug. ***
Comment 61 Bob Gustafson 2011-03-25 12:25:05 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. logged out user
2. The automatic bug reporting tool did not have enough time to do its job
3. I logged back in
4. I manually initiated a restart
5. Now I am in the middle of the automatic bug reporting tool
6. After sending this, I will continue through the restart


Comment
-----
See above
Comment 62 Bob 2011-03-30 06:00:14 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Crashed on shutdown?
2.
3.
Comment 63 Roger E. Ouellette 2011-04-05 11:35:06 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I was in the process of downloading packages to send a report on OpenOffice when there was a crash. 
2.
3.
Comment 64 jameshusby 2011-04-13 23:24:15 EDT
Package: openoffice.org-writer-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. shutdown
2. restart
3. open open office
Comment 65 Ray 2011-04-14 08:53:38 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. whenever I access my open office program - it will require me to recover a corrupted file and the error message will appear once I click proceed
2.
3.
Comment 66 Caolan McNamara 2011-04-17 17:28:22 EDT
*** Bug 697337 has been marked as a duplicate of this bug. ***
Comment 67 Patrick Pichon 2011-04-21 09:45:10 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
aa
Comment 68 Tad 2011-04-22 05:19:41 EDT
Package: openoffice.org-brand-1:3.3.0-20.2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
n
Comment 69 David Tardon 2011-05-04 02:55:20 EDT
*** Bug 701792 has been marked as a duplicate of this bug. ***
Comment 70 Ronald Canete 2011-05-12 14:32:57 EDT
Package: openoffice.org-calc-1:3.3.0-20.5.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. open the application and close it then crash.
2.
3.
Comment 71 Ronald Canete 2011-05-12 14:34:28 EDT
Package: openoffice.org-writer-1:3.3.0-20.5.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. open the apps and close it then crash.
2.
3.
Comment 72 David Tardon 2011-05-17 00:21:41 EDT
*** Bug 705197 has been marked as a duplicate of this bug. ***
Comment 73 Ken Jones 2011-05-23 12:59:29 EDT
Package: openoffice.org-brand-1:3.3.0-20.5.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Was not at machine when crash happened. Screensaver had kicked in.
2.
3.


Comment
-----
Leave the machine, go to the restroom, go to bosses office, then return to workstation.
Comment 74 Matthew Saltzman 2011-05-26 04:53:50 EDT
Package: openoffice.org-brand-1:3.3.0-20.5.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Crash occurred during shutdown.  Not sure if it's reproducible.
2.
3.
Comment 75 David Tardon 2011-06-07 06:25:11 EDT
*** Bug 711271 has been marked as a duplicate of this bug. ***
Comment 76 Caolan McNamara 2011-06-07 12:07:21 EDT
this is really a grabbag of problems around autorecovery. I'll try and fix the immediately crash if an exception of the offending type is thrown during autorecovery
Comment 77 Ken Jones 2011-06-07 13:11:45 EDT
Package: openoffice.org-brand-1:3.3.0-20.5.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.No idea, was not at machine and console was locked.
2.
3.
Comment 78 Caolan McNamara 2011-06-08 04:58:33 EDT
lets have a shot at fixing the crashes on exceptions in autorecovery which I can semi-reproduce/emulate by forcing exceptions to be thrown everytime on a recovery attempt.

Fix for that will be in >= openoffice.org-3.3.0-20.6 and I'll bubble it into libreoffice as well
Comment 79 Fedora Update System 2011-06-09 04:24:07 EDT
openoffice.org-3.3.0-20.6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-20.6.fc14
Comment 80 Fedora Update System 2011-06-11 00:28:28 EDT
Package openoffice.org-3.3.0-20.6.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openoffice.org-3.3.0-20.6.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/openoffice.org-3.3.0-20.6.fc14
then log in and leave karma (feedback).
Comment 81 Hector Davie 2011-06-11 19:10:00 EDT
Package: openoffice.org-writer-1:3.3.0-20.5.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Closing a mail attachment
2.
3.
Comment 82 Fedora Update System 2011-06-21 13:14:30 EDT
openoffice.org-3.3.0-20.6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.