Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 661562 - [abrt] java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14: os::abort: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java was killed by signal 6 (SIGABRT)
Summary: [abrt] java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14: os::abort: Process /usr/li...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: tuxguitar
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:495d2d461956823ff89d91951d3...
: 644219 658322 664207 665068 678773 683124 691932 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-09 00:10 UTC by Nicolás Martín Acosta Corin
Modified: 2012-03-31 02:49 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-31 02:49:22 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (41.55 KB, text/plain)
2010-12-09 00:10 UTC, Nicolás Martín Acosta Corin
no flags Details

Description Nicolás Martín Acosta Corin 2010-12-09 00:10:29 UTC
abrt version: 1.1.14
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/java -Xmx512m -cp ::/usr/share/tuxguitar/tuxguitar.jar:/usr/lib/java/swt.jar:/usr/share/java/itext.jar:/usr/share/tuxguitar/ -Dtuxguitar.share.path=/usr/share/tuxguitar/ -Djava.library.path=/usr/lib/tuxguitar/:/lib:/usr/lib:/usr/lib/jni:/usr/local/lib:/usr/lib/mozilla org.herac.tuxguitar.gui.TGMain '' '' /usr/share/tuxguitar/tuxguitar.tg
component: java-1.6.0-openjdk
crash_function: os::abort
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java
kernel: 2.6.35.9-64.fc14.i686
package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
rating: 3
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1291852290
uid: 500

How to reproduce
-----
1.I open TuxGuitar
2.The TuxGuitar's splash window appeared
3.The crash ( error )

Comment 1 Nicolás Martín Acosta Corin 2010-12-09 00:10:33 UTC
Created attachment 467630 [details]
File: backtrace

Comment 2 Deepak Bhole 2010-12-09 03:05:19 UTC
The trace shows that the error originated from Java_org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem_findPorts()

That is part of tuxguitar code, and this bug should therefore be filed against tuxguitar as there is nothing we can do about it on the JVM side.

Comment 3 Orcan Ogetbil 2010-12-09 03:12:12 UTC
Deepak,
This package (tuxguitar) works fine in F-13. On F-14, it works fine on x86_64 but not on i686.

Since we did not change anything in the code of this package between F-13 and F-14, I really suspect that the bug is in openjdk, which is updated a lot.

Do you know what changed in openjdk's JNI side between F-13 and F-14?

Comment 4 Deepak Bhole 2010-12-09 05:03:48 UTC
Hi Orcan. I am unsure as to what changed w.r.t JNI in OpenJDK, however that trace does not seem indicative of a JNI issue. The call stack is:

Java_org_herac_tuxguitar_player_impl_midiport_alsa_MidiSystem_findPorts() ->
snd_seq_query_next_client (@ seq.c:1811) ->
unknown ->
<signal handler>

seq.c:1811 is:
return seq->ops->query_next_client(seq, info);

It is very likely that one of those variables above is null. Assuming this issue is reproducible, I'd try OpenJDK from F13 on an F14 box

If no error is thrown, we can be certain that OpenJDK is the problem. If not, the problem must lie in tuxguitar/alsa/kernel driver.

Comment 5 Orcan Ogetbil 2010-12-10 05:27:30 UTC
Hi Deepak, what is the easiest and the least painful way of installing F-13's openjdk to F-14 ? rpm -Uvh --force ?

Comment 6 Deepak Bhole 2010-12-22 14:13:46 UTC
Hi Orcan. Yes, Uvh --force should do it. Once testing is done, you can --force install f14 rpms back.

Comment 7 Deepak Bhole 2010-12-22 14:14:04 UTC
*** Bug 644219 has been marked as a duplicate of this bug. ***

Comment 8 Deepak Bhole 2010-12-22 14:14:50 UTC
*** Bug 664207 has been marked as a duplicate of this bug. ***

Comment 9 Deepak Bhole 2010-12-22 14:15:06 UTC
*** Bug 658322 has been marked as a duplicate of this bug. ***

Comment 10 Deepak Bhole 2010-12-23 14:46:45 UTC
*** Bug 665068 has been marked as a duplicate of this bug. ***

Comment 11 Johannes Schmid 2010-12-24 10:51:45 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started tuxguitar and it crashed inside java.


Comment
-----
This is on my netbook. On my desktop with 64-bit it just worked.

Comment 12 random4ever 2010-12-28 23:23:15 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.tried to load a up gutiarTux and it crashes
2.
3.

Comment 13 Orcan Ogetbil 2010-12-28 23:59:44 UTC
Hi folks, 
I don't have any means of testing this on an i686.

Can any of you downgrade openjdk to F-13's openjdk and see if tuxguitar works? Unfortunately, the crash can't be fixed until someone takes the time to do this test.

Thanks.

Comment 14 Johannes Schmid 2010-12-29 09:41:31 UTC
@Orcan: Can you give me the command line I need to enter to downgrade to F13's openjdk? Comment 5/6 don't give me much clue and my machine never had F13 installed.

Thanks!

Comment 15 Orcan Ogetbil 2010-12-29 19:59:48 UTC
Hi Johannes,
Searching for java-1.6.0-openjdk in koji gave me this result:
   http://koji.fedoraproject.org/koji/packageinfo?packageID=5920

Now what you need to do is to pick up a fc13 build from the list (preferably not the newest ones). When you click on the link of the fc13 build, you will see the list of RPMs available. I would pick the 41.b18.fc13 release because this is what tuxguitar-1.2-3.fc14 was built against.

Under the list of i686 RPMS, you will need to download the main openjdk RPM. Something like:
   java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.i686.rpm 

You will probably need to download the browser plugin RPM too
   java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.i686.rpm

After that, go to the downloads directory in your computer where these two files are, then as root, do

   rpm -Uvh --oldpackage java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.i686.rpm

If this complains about plugin dependency, do (one line)
   rpm -Uvh --oldpackage java-1.6.0-openjdk-1.6.0.0-41.b18.fc13.i686.rpm java-1.6.0-openjdk-plugin-1.6.0.0-41.b18.fc13.i686.rpm

Still you might get complaints about openjdk subpackages. If that's the case you will just need to download the corresponding subpackage from the above page and append it to you rpm -Uvh line. I think you get the idea.

When you are done downgrading, fire tuxguitar.

Comment 16 Johannes Schmid 2010-12-29 20:18:40 UTC
Hi Orcan!

OK, I followed these steps but tuxguitar still crashes in the same way as before.

Comment 17 Orcan Ogetbil 2010-12-29 20:45:56 UTC
oh geez. We need to find out now what else has changed between F-13 and F-14 that tuxguitar needs.

Comment 18 random4ever 2010-12-31 22:52:59 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.tried to load a up gutiarTux and it crashes
2.
3.

Comment 19 Jason 2011-01-01 06:37:16 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Crashed opening Tuxguitar
2.
3.

Comment 20 Jean-frederic Clere 2011-01-04 17:13:01 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. running mvn install
2.
3.


Comment
-----
It doesn't happend often....

Comment 21 azneto 2011-01-06 22:49:02 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Trying to open tuxguitar
2.
3.

Comment 22 Deepak Bhole 2011-01-06 23:23:13 UTC
Can someone please try with an F13 kernel on an F14 system? The packages are here:

http://koji.fedoraproject.org/koji/packageinfo?packageID=8

The latest for F13 is kernel-2.6.34.7-66.fc13

Be sure to use rpm -ivh when installing the kernel, otherwise it will overwrite the existing one.

Comment 23 Jason 2011-01-12 08:38:01 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Crashed opening Tuxguitar
2.
3.


Comment
-----
Opened Tuxguitar

Comment 24 Jason 2011-01-12 08:41:07 UTC
(In reply to comment #22)
> Can someone please try with an F13 kernel on an F14 system? The packages are
> here:
> 
> http://koji.fedoraproject.org/koji/packageinfo?packageID=8
> 
> The latest for F13 is kernel-2.6.34.7-66.fc13
> 
> Be sure to use rpm -ivh when installing the kernel, otherwise it will overwrite
> the existing one.

Hi, tried to but wouldn't let me, saying a newer kernel was already installed, please advise, thanks,

Jason

Comment 25 Deepak Bhole 2011-01-12 14:27:08 UTC
(In reply to comment #24)
> 
> Hi, tried to but wouldn't let me, saying a newer kernel was already installed,
> please advise, thanks,
> 
> Jason

Hi. You can try rpm --force -ivh <kernel rpm>

Be sure to choose the F13 kernel during boot after installation as it may not make it the default boot since it is older. If problems arise, you can boot back to the F14 kernel and uninstall the F13 one.

Comment 26 Jason 2011-01-12 15:01:03 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Start Tuxguitar
2.
3.


Comment
-----
kernel-2.6.34.7-66.fc13 installed but no difference, Tuxguitar crashed during start up

Comment 27 Orcan Ogetbil 2011-01-13 18:33:03 UTC
Can you folks try to downgrade to an F-13 version of tuxguitar? You can find the builds at
   http://koji.fedoraproject.org/koji/packageinfo?packageID=6908

For instance, you could try tuxguitar-1.2-2.fc13. If it works, can you tell us the latest tuxguitar version from that list that doesn't crash on start?

Comment 28 Kjartan Maraas 2011-01-13 23:20:14 UTC
The newest f13 build worked for me on an updated rawhide system.
http://koji.fedoraproject.org/koji/buildinfo?buildID=198489

That's tuxguitar-1.2-3.fc13

Comment 29 Jason 2011-01-14 01:23:08 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Start Tuxguitar
2.
3.


Comment
-----
kernel-2.6.34.7-66.fc13 installed but no difference, Tuxguitar crashed during start up

Comment 30 Jason 2011-01-14 01:26:54 UTC
(In reply to comment #28)
> The newest f13 build worked for me on an updated rawhide system.
> http://koji.fedoraproject.org/koji/buildinfo?buildID=198489
> 
> That's tuxguitar-1.2-3.fc13

Worked here too, latest f13 kernel and tuxguitar-1.2-3.f13 on f14, thanks

Comment 31 Jason 2011-01-14 01:28:51 UTC
(In reply to comment #30)
> (In reply to comment #28)
> > The newest f13 build worked for me on an updated rawhide system.
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=198489
> > 
> > That's tuxguitar-1.2-3.fc13
> 
> Worked here too, latest f13 kernel and tuxguitar-1.2-3.f13 on f14, thanks

Update, tuxguitar-1.2-3.f13 worked using the latest f14 kernel-2.6.35.10-74.fc14.i686 on f14

Comment 32 Orcan Ogetbil 2011-01-14 01:31:20 UTC
Deepak, what is your next guess? gcc? glibc?

Comment 33 Fabian A. Scherschel 2011-01-17 09:42:23 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-49.1.9.3.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started Minecraft
2. Played some time


Comment
-----
Minecraft crashed after about 10 mins of play.

Comment 34 Orcan Ogetbil 2011-02-19 14:51:27 UTC
*** Bug 678773 has been marked as a duplicate of this bug. ***

Comment 35 Mamoru TASAKA 2011-02-20 09:46:32 UTC
So I am using rawhide i686 system and

tuxguitar-1.2-3.fc13.i686 - works (gcc 4.4.5)
tuxguitar-1.2-3.fc14.i686 - doesn't work (gcc 4.5.1)
tuxguitar-1.2-3.fc15.i686 - doesn't work (gcc 4.5.1)
tuxguitar-1.2-4.fc15.i686 - works (gcc 4.6.0)

Also for F-14: build
When built with
* -O0 - works (would you try below?)
  http://koji.fedoraproject.org/scratch/mtasaka/task_2852189/
* -O1 - doesn't work

So I assume this is related to gcc / gcj  optimation issue (I am not sure
if codes in tuxguitar should be fixed, or this is due to gcc).

Comment 36 Nicolás Martín Acosta Corin 2011-02-20 12:38:32 UTC
Thanks for the answers, but I resolved the problem. I replaced the OpenJDK's Java console for the Oracle Sun Java's console and tuxguitar runs smoothly, without problems. I obtained the information of these pages http://www.chuda.org.ve/?p=568, and here with images http://tuxfedorablog.blogspot.com/2010/12/instalacion-de-sunoracle-java-jrejdk-en.html (these pages are in spanish because I live in Chile, but you can use the Google Traductor for web pages, because the important information are the commands that you need)
   Bless

PS: Excuse my english...but I'm studying the language. Thanks

Comment 37 Mamoru TASAKA 2011-02-24 05:40:11 UTC
Orcan, can you try my scratch build (on F-13 i686 live, for example)?

Comment 38 Orcan Ogetbil 2011-02-24 12:24:27 UTC
F-13 i686 live, on my x86_64 hardware? Sure, I'll try that. I can't get to it before the weekend though.

Comment 39 Benjamín Valero Espinosa 2011-03-17 18:33:28 UTC
(In reply to comment #31)
> Update, tuxguitar-1.2-3.f13 worked using the latest f14
> kernel-2.6.35.10-74.fc14.i686 on f14

I confirm that, also with a newer kernel 2.6.35.11-83.fc14.i686 and the F13 version of TuxGuitar. Thanks for the workaround.

Comment 40 Deepak Bhole 2011-03-29 22:13:48 UTC
*** Bug 691932 has been marked as a duplicate of this bug. ***

Comment 41 Jason 2011-04-10 06:22:44 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-52.1.9.7.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.start tuxguitar
2.
3.

Comment 42 Martin Weiss 2011-04-14 15:08:22 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-52.1.9.7.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Every time i start tuxguitar it just hangs
2. When started from console this shows up :)
3.

Comment 43 Kjartan Maraas 2011-12-14 20:27:42 UTC
This is working for me now.

Comment 44 abrt-bot 2012-03-20 16:06:32 UTC
*** Bug 683124 has been marked as a duplicate of this bug. ***

Comment 45 abrt-bot 2012-03-30 13:28:19 UTC
Backtrace analysis found this bug to be similar to some already closed bugs from other components. You might want to check those bugs for additional information.

Bugs which were found to be similar to this bug: 
  eclipse: bug #562764
  java-1.6.0-openjdk: bug #618319, bug #622517, bug #637359, bug #665068, bug #668507, bug #676318, bug #676442, bug #683124

This comment is automatically generated.

Comment 46 Orcan Ogetbil 2012-03-31 02:49:22 UTC
Reports show that this crash does not occur anymore. It looks like this got fixed somehow. I am closing this bug now. If the crash happens again, please file a new bug.


Note You need to log in before you can comment on or make changes to this bug.