Bug 67495 - OpenOffice components abort after start-up
OpenOffice components abort after start-up
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
: 67868 67928 68081 68138 68587 69030 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-06-26 09:15 EDT by Alexander Farley
Modified: 2008-05-01 11:38 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 10:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
openoffice log (23.61 KB, text/plain)
2002-07-10 13:23 EDT, Josep L. Guallar-Esteve
no flags Details
gdb backet (2.13 KB, text/plain)
2002-07-21 07:24 EDT, Sarantis Paskalis
no flags Details
gdb backtrace (2.13 KB, text/plain)
2002-07-21 07:24 EDT, Sarantis Paskalis
no flags Details

  None (edit)
Description Alexander Farley 2002-06-26 09:15:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020528

Description of problem:
The OpenOffice(.org) packages abort after execution. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.execute OpenOffice component from menu or "/usr/bin/ooxxxx"
2.system finds installation
3.system starts program then aborts.

Actual Results:  The program aborted.

Expected Results:  The program would completely execute.

Additional info:
There is no trace, the system only says "Aborted."
The splashscreen does come up before the program aborts.
I have a feeling that the problem is due to an incompatibility with GNOME 2.0,
since this started happening when I upgraded to GNOME 2.  I did not have any
problems with the 641 releases or 1.0 release with GNOME 1.4.
Comment 1 rudi 2002-06-27 12:54:45 EDT
I can confirm this bug. It exhibits the same symptoms here, on a system updated
to Raw Hide 20020627 (i.e. today's packages). I switched to the Raw Hide OO RPM
only this week and it never worked for me; before that I installed the official
builds from OO's site, which had never given me problems. Thus I can't confirm
or deny that GNOME2 might be at fault.

Initially, I had problems with fonts, or so I thought. chkfontpath reported a
bogus empty line in the font path. I fixed that and made sure that the font
server sees OO's OpenSymbol font, but it only seemed to postpone the crash a
bit.

For what it's worth, here are the last lines from the output of the command
"strace ooffice":

open("/usr/lib/openoffice/program/libi18n641li.so", O_RDONLY) = 13
read(13, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0P!\1\000"..., 1024) = 1024
fstat64(13, {st_mode=S_IFREG|0755, st_size=841160, ...}) = 0
old_mmap(NULL, 784784, PROT_READ|PROT_EXEC, MAP_PRIVATE, 13, 0) = 0x462ab000
mprotect(0x462d5000, 612752, PROT_NONE) = 0
old_mmap(0x462d5000, 614400, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED, 13,
0x29000) = 0x462d5000
close(13)                               = 0
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
kill(26003, SIGABRT)                    = 0
--- SIGABRT (Aborted) ---
rt_sigaction(SIGABRT, {SIG_DFL}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [ABRT], NULL, 8) = 0
kill(26003, SIGABRT)                    = 0
--- SIGABRT (Aborted) ---
+++ killed by SIGABRT +++
Comment 2 Bernhard Rosenkraenzer 2002-07-02 07:30:35 EDT
Quick workaround: Rebuild the package disabling the application of 
"openoffice-1.0-braindamage.patch". 
Comment 3 Bernhard Rosenkraenzer 2002-07-03 11:11:29 EDT
*** Bug 67868 has been marked as a duplicate of this bug. ***
Comment 4 Bernhard Rosenkraenzer 2002-07-03 11:14:14 EDT
Sopwith: This is a beehive problem. The fixed package 
(porkchop:~brosenkr/openoffice-1.0.0-4.src.rpm) builds perfectly outside of 
beehive (both as root and as user), but fails when in beehive. 
 
Please take a look at it.
Comment 5 Elliot Lee 2002-07-03 11:40:13 EDT
I need build logs or something that points at beehive as the problem. If you
could save those it would be helpful. I can't do anything at all about the
problem otherwise - I'm not going to sit through an OO build just to get logs :)
Comment 6 Bill Nottingham 2002-07-06 03:49:39 EDT
*** Bug 67928 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2002-07-06 03:49:51 EDT
*** Bug 68081 has been marked as a duplicate of this bug. ***
Comment 8 Thornton Prime 2002-07-06 23:00:39 EDT
I rebuilt from the src.rpm both with and without the
'openoffice-1.0-braindamage.patch' on a freshly installed Limbo box. Neither
resulted in a working OpenOffice.

The OpenOffice.org binaries from the OO website don't work either, but they
break  a little further in, with a mysterious error dialog. Debugging shows
threads dying without leaving any indication why.
Comment 9 Bill Nottingham 2002-07-08 01:47:47 EDT
*** Bug 68138 has been marked as a duplicate of this bug. ***
Comment 10 Thomas Dodd 2002-07-08 14:40:07 EDT
My install is missing several files from  /usr/lib/openoffice/user/config/
that appear to be in the package list ('rpm -qlp openoffice*.rpm' shows them)
so the initial user config skips some .so[cedh] files.

Running oo* shows the splash screen athen exits with
"SIOCGIFADDR got 00:00:00:00:00:00"
That looks like a MAC address, but that box is ppp only,
no NIC.

Comment 11 Thomas Dodd 2002-07-09 12:20:39 EDT
rpm -V reported no problems.
I reinstalled openoffice
using --replacepkgs and the missing files got are now there.
I wonder how many other packages are not complete.
(re reinstalled mozilla and it fixed a menyu problem)
Why didn't -V catch the missing files?

Still, now the frist run doesn't report missing files,
but openoffice exits with the same SICCGIFADDR again.

Comment 12 Josep L. Guallar-Esteve 2002-07-10 13:23:14 EDT
Created attachment 64617 [details]
openoffice log
Comment 13 Josep L. Guallar-Esteve 2002-07-10 13:24:36 EDT
Maybe this will help. I have redirected the output from openoffice to a file.
Check the previous attachement.

OpenOffice version:
openoffice-1.0.0-4
Comment 14 Bill Nottingham 2002-07-12 00:09:29 EDT
*** Bug 68587 has been marked as a duplicate of this bug. ***
Comment 15 Need Real Name 2002-07-15 10:08:00 EDT
I've used gdb to debug the program, here is the
debug infomation:
------------------------------------------------
[chluo@LuoChong .openoffice]$ gdb /usr/local/OpenOffice.org1.0/program/soffice.bin
GNU gdb Red Hat Linux (5.1.92-3)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(gdb) run
Starting program: /usr/local/OpenOffice.org1.0/program/soffice.bin
[New Thread 1024 (LWP 13199)]
[New Thread 2049 (LWP 13200)]
[New Thread 1026 (LWP 13201)]
[New Thread 2051 (LWP 13202)]
[New Thread 3076 (LWP 13203)]
[New Thread 4101 (LWP 13206)]
Program received signal SIGBUS, Bus error.
[Switching to Thread 1024 (LWP 13199)]
0x47687834 in __bam_read_root ()
   from /usr/local/OpenOffice.org1.0/program/libdb-3.2.so
(gdb)
(gdb)
(gdb)
(gdb)
(gdb) continue
Continuing.

Program received signal SIGABRT, Aborted.
0x42027811 in kill () from /lib/i686/libc.so.6
(gdb)
(gdb) quit
The program is running.  Exit anyway? (y or n) y
[chluo@LuoChong .openoffice]$
----------------------------------------------------------
Comment 16 Bill Nottingham 2002-07-17 21:49:48 EDT
*** Bug 69030 has been marked as a duplicate of this bug. ***
Comment 17 Bill Nottingham 2002-07-17 21:51:23 EDT
*** Bug 68138 has been marked as a duplicate of this bug. ***
Comment 18 Need Real Name 2002-07-18 00:41:45 EDT
OpenOffice.org 1.0.1 has been released.
Is it usable in Redhat limbo?
Comment 19 Reid Rivenburgh 2002-07-18 00:46:44 EDT
Version 1.0.1 downloaded from www.openoffice.org doesn't work for me with limbo.
 openoffice-1.0.0-7.i386.rpm (and the associated i18n and libs rpms), new in
rawhide, does work for me.
Comment 20 Need Real Name 2002-07-18 04:41:44 EDT
Does that mean the guys of Redhat have solved the problem? 
That's a good news.
But my connection to internet is too slow, I can't afford to download those
three big files. Perhaps I have to wait until the release of Redhat 8.0 (or
7.4?) to enjoy working with openoffice. :-(
Comment 21 Need Real Name 2002-07-18 08:08:02 EDT
Hi, eveyone, I've found a way to solve the problem!
1. Install db3-3.2.9-4.i386.rpm from Redhat 7.2.
2. Use /usr/lib/libdb_cxx-3.2.so and /lib/libdb-3.2.so to replace the
corresponding file under /usr/local/OpenOffice.org1.0/program/.
3. start openoffice.
Then everything is OK!
Comment 22 Sarantis Paskalis 2002-07-18 08:38:32 EDT
openoffice-1.0.0-7 still does not start up
$ ooffice
Checking for existing user installation ...   ...   NOT FOUND
Performing first-time installation for user ...   /usr/bin/ooffice: line 40:
20278 Segmentation fault      /usr/lib/openoffice/program/setup
-R:/etc/openoffice/autoresponse.conf
...   FAILED
Comment 23 Need Real Name 2002-07-18 09:37:54 EDT
I didn't test the openoffice-1.0.0-4.i386.rpm shipped with redhat limbo,
instead I've tested the one from www.openoffice.org.

Comment 24 Need Real Name 2002-07-20 16:15:49 EDT
Just another data point.   
The Limbo RPMs did not work for me either. I tried the new OO-1.0.1   
binaries form www.openoffice.org on my Limbo installation to no avail.  
I got the SIOCGIFADDR message and then nothing (no NIC here). Just  
removing the libdb-3.2.so and libdb_cxx-3.2.so libraries from  
/usr/local/OpenOffice.org1.0/program did the trick. The SIOCGIFADDR  
message is still here.  
Comment 25 Jakub Jelinek 2002-07-20 17:17:02 EDT
1) those who are seeing hangs or crashes in libdb with OOo binaries, it is
   because they have miscompiled libdb-3.2.so (calls mmap64 with random
   upper 32-bits of offset) - simply remove libdb-3.2.so and let it use the
   system one
2) SIOCGIFADDR got 00:00:00:00:00:00 at least from my reading of the code
   should definitely not be a problem - it just means OOo will use random
   6 bytes for UUID instead of ethernet address
3) to askalis@di.uoa.gr: are you sure you have
   a) /proc mounted
   b) /etc/mtab present
   ? If yes, can you ulimit -c unlimited and attach gdb backtrace?
Comment 26 Sarantis Paskalis 2002-07-21 07:23:04 EDT
Yes, /proc is mounted, /etc/mtab exists.  gdb backtrace attached below.
Comment 27 Sarantis Paskalis 2002-07-21 07:24:00 EDT
Created attachment 66186 [details]
gdb backet
Comment 28 Sarantis Paskalis 2002-07-21 07:24:05 EDT
Created attachment 66187 [details]
gdb backtrace
Comment 29 Josep L. Guallar-Esteve 2002-07-22 15:27:07 EDT
The package openoffice-1.0.0-7.src.rpm has been tested internaly. It works and
should become available with next public beta.

If development agrees, this bug can be closed.
Comment 30 Thomas Dodd 2002-08-01 10:36:37 EDT
Version in second limbo worked after a clean install.

Note You need to log in before you can comment on or make changes to this bug.