Bug 68130 - Some umlauts in mc are displayed incorrectly on console
Some umlauts in mc are displayed incorrectly on console
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Brock Organ
triage|leonardjo|closed|rawhide
:
: 71954 (view as bug list)
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-07-06 15:37 EDT by Bernd Bartmann
Modified: 2013-07-02 18:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.6.1-0.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 12:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-07-06 15:37:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
During installation I selected german as my default language. During system
startup I see lots of wrong text characters. German umlauts are not displayed
correctly. The borders of mc are totally wrong characters.
In /etc/sysconfig/i18n I found that my default font is now LatArCyrHeb-16, on
RedHat 7.3 this was Lat0-sun16 which is now not even installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install LIMBO with german as default language
2. After install watch all the wrong text when the system starts up
3. Start mc and watch the bad borders...
	

Additional info:
Comment 1 Jeremy Katz 2002-07-07 00:10:55 EDT
LatArCyrHeb-16 is the only font out there with decent utf8 coverage
Comment 2 Peter van Egdom 2002-07-07 15:28:07 EDT
I can imagine having a console-font which can display native Arabic
characters (and other languages?) better than the old font is
important for non-English speakers, but is it worth the trouble for
the rest of us?

For example :

On my computer, the text based 'hardware discovery utility' which
appears when installing e.g. a new network card, looks absolutely
unreadable. 

And normal usage (reading manpages ("man ls") on e.g. /dev/tty4 is
almost impossible right now), let alone some often used program
like the Midnight Commander.

For me this means use of this Red Hat Linux is _unsuitable_ for 
tasks the way I use it now.

I sincerely hope this gets fixed in the next beta.
Comment 3 Bill Nottingham 2002-07-08 01:51:33 EDT
vt2-vt6 being unusable doesn't really have anything to do with the font, AFAICT.
The bug is elsewhere.
Comment 4 Peter van Egdom 2002-07-08 12:38:37 EDT
Hmm.. it seems you're right. I changed the console-font in "/etc/sysconfig/i18n"
(replaced line SYSFONT="LatArCyrHeb-16" with SYSFONT="lat1u-16"), but the
problem still occurs.

ps.1 for me this problem (the 'unreadableness' of "man ls") also occurs on vt1.

ps.2 with the font "LatArCyrHeb-16" also the output of commands like "ls"
     generate 'Russian-like' characters. Selecting "lat1u-16" resolved this
     somewhat, although Midnight Commander still has weird borders.

Comment 5 Need Real Name 2002-07-08 20:02:32 EDT
FWIW, selecting US English as the system language creates same trouble.  vt1
seems OK, others are bad.  Problem is that any colored text is hosed.  regular
text, e.g. color of regular files in 'ls' is fine, while e.g. color of directory
items in 'ls /' looks vaguely like russian...  Wild guess: Perhaps color escape
codes are being interpreted somewhere as unicode?
Comment 6 Michael Knepher 2002-07-12 00:34:55 EDT
I have the same issue with a mishmash of cyrillic and other typefaces on the
colored text in vt2-vt6 on a US English install.
Comment 7 Need Real Name 2002-07-16 17:48:53 EDT
I get the same problem with a "standard" everything install, english language.
Comment 8 Bill Nottingham 2002-07-16 18:23:16 EDT
A workaround is in the latest kbd package in rawhide.
Comment 9 Bernd Bartmann 2002-07-17 15:15:43 EDT
Updating to kdb-1.06-20.i386.rpm still does not solve this problem. I couldn't
find a newer version. Rawhide was last updated on 13. July.
Comment 10 Bill Nottingham 2002-07-17 15:22:05 EDT
Which particular aspects of the problem are not solved for you with the new kbd?
Comment 11 Bernd Bartmann 2002-07-17 15:30:24 EDT
No problem is solved at all. I still see lots of wrong characters instead of
german umlauts and the border lines of mc. Here is my complete
/etc/sysconfig/i18n which was created during limbo installation:

LANG="de_DE.UTF-8@euro"
SUPPORTED="en_US.UTF-8:en_US:en:de_DE.UTF-8@euro:de_DE:de_DE.UTF-8:de"
SYSFONT="LatArCyrHeb-16"
Comment 12 Bill Nottingham 2002-07-17 15:42:26 EDT
What version of slang, newt, and mc do you have installed?
Comment 13 Bernd Bartmann 2002-07-17 15:49:38 EDT
I've installed the packages that came with the limbo beta release:

slang-1.4.5-7
slang-devel-1.4.5-7
compat-slang-1.4.5-2

newt-0.50.39-1
newt-devel-0.50.39-1

mc-4.5.55-7
Comment 14 Bill Nottingham 2002-07-17 15:54:01 EDT
Installing the latest slang and mc packages from rawhide (1.4.5-10, and
4.5.55-10) should resolve some of the issues you're seeing in MC. The latest
rawhide initscripts should avoid changes in things like the [ OK ] labels at
boot up.

(The main issue is that the initial bugreport actually refers to various
separate issues.)
Comment 15 Bernd Bartmann 2002-07-17 16:11:26 EDT
Sorry, but I still see the same problems after updating to:

initscripts-6.85-1
slang-devel-1.4.5-10
slang-1.4.5-10
mc-4.5.55-9 (version -10 is not yet available via rawhide)

Even if mc will be ok in version -10, all german initscript messages that
contain german umlauts are displayed wrong.
Comment 16 Bernd Bartmann 2002-07-21 11:26:33 EDT
mc borders are now ok in Gnome Terminal (mc-4.5.55-10), but still broken on the
console
Comment 17 Curtis Nelson 2002-08-08 16:18:46 EDT
I think I'm having similar problems.  After a default "English" install.  Lots
of fuzzy characters and the font type seems to be switching back and forth for
different applications and scripts.  Especially at boot-up.

Using 'setfont' without any parameters seems to reset the conslole properly for
the user who's logged in -- but for that login session only.  As soon as I
logout, the console fonts revert.
Comment 18 Bill Nottingham 2002-08-13 17:07:31 EDT
With a current tree for me, and LANG=de_DE.UTF-8, mc borders appear fine on the
console.

Some of the issue was with the @euro in the locale; this was fixed in
initscripts-6.88-1. (And anaconda no longer writes @euro anyway.)
Comment 19 Bernd Bartmann 2002-08-13 17:32:54 EDT
Indeed, confirmed for Limbo2. The borders are now correct on the console, but
german umlauts in mc's menus are still broken. Each umlaut shows up as two
completely different characters.
Comment 20 Bill Nottingham 2002-08-13 17:50:39 EDT
Confirmed. Oddly, thje umlaut in Men| is ok, while the one in the menus
themselves isn't. I presume this is something odd with MC itself.
Comment 21 Havoc Pennington 2002-08-14 01:05:31 EDT
cc'ing jakub
Comment 22 Ivo Sarak 2002-08-14 04:40:50 EDT
Strangely I still get a mess out of mc despite Limbo2 and updates to it:

http://www.vendomar.ee/~ivo/mc_bordermess.png

If this is any help then output of env&set:

[IS@haskaa IS]$ env
KDE_MULTIHEAD=false
SSH_AGENT_PID=1321
HOSTNAME=haskaa
PVM_RSH=/usr/bin/rsh
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
GTK_RC_FILES=/etc/gtk/gtkrc:/home/IS/.gtkrc:/home/IS/.gtkrc-kde
GS_LIB=/home/IS/.kde/share/fonts
QTDIR=/usr/lib/qt-3.0.5
USER=IS
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
GDK_USE_XFT=1
PVM_ROOT=/usr/share/pvm3
SSH_AUTH_SOCK=/tmp/ssh-XXMDxwPo/agent.1301
SESSION_MANAGER=local/haskaa:/tmp/.ICE-unix/1390
KONSOLE_DCOP=DCOPRef(konsole-1502,konsole)
MAIL=/var/spool/mail/IS
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/IS/bin
KONSOLE_DCOP_SESSION=DCOPRef(konsole-1502,session-1)
INPUTRC=/etc/inputrc
PWD=/home/IS
XMODIFIERS=@im=none
LANG=en_US
LAMHELPFILE=/etc/lam/lam-helpfile
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=4
HOME=/home/IS
XPVM_ROOT=/usr/share/pvm3/xpvm
LOGNAME=IS
LESSOPEN=|/usr/bin/lesspipe.sh %s
DISPLAY=:0.0
COLORTERM=
XAUTHORITY=/home/IS/.Xauthority
_=/bin/env
OLDPWD=/home/IS
[IS@haskaa IS]$ set
BASH=/bin/bash
BASH_VERSINFO=([0]="2" [1]="05b" [2]="0" [3]="1" [4]="release"
[5]="i686-pc-linux-gnu")
BASH_VERSION='2.05b.0(1)-release'
CHARSET=8859-1
COLORS=/etc/DIR_COLORS.xterm
COLORTERM=
COLUMNS=70
DIRSTACK=()
DISPLAY=:0.0
EUID=500
GDK_USE_XFT=1
GROUPS=()
GS_LIB=/home/IS/.kde/share/fonts
GTK_RC_FILES=/etc/gtk/gtkrc:/home/IS/.gtkrc:/home/IS/.gtkrc-kde
HISTFILE=/home/IS/.bash_history
HISTFILESIZE=1000
HISTSIZE=1000
HOME=/home/IS
HOSTNAME=haskaa
HOSTTYPE=i686
IFS=$' \t\n'
INPUTRC=/etc/inputrc
KDE_MULTIHEAD=false
KONSOLE_DCOP='DCOPRef(konsole-1502,konsole)'
KONSOLE_DCOP_SESSION='DCOPRef(konsole-1502,session-1)'
LAMHELPFILE=/etc/lam/lam-helpfile
LANG=en_US
LESSOPEN='|/usr/bin/lesspipe.sh %s'
LINES=22
LOGNAME=IS
LS_COLORS='no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:'
MACHTYPE=i686-pc-linux-gnu
MAIL=/var/spool/mail/IS
MAILCHECK=60
OLDPWD=/home/IS
OPTERR=1
OPTIND=1
OSTYPE=linux-gnu
PATH=/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/IS/bin
PIPESTATUS=([0]="0")
PPID=1502
PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\007"'
PS1='[\u@\h \W]\$ '
PS2='> '
PS4='+ '
PVM_ROOT=/usr/share/pvm3
PVM_RSH=/usr/bin/rsh
PWD=/home/IS
QTDIR=/usr/lib/qt-3.0.5
SESSION_MANAGER=local/haskaa:/tmp/.ICE-unix/1390
SHELL=/bin/bash
SHELLOPTS=braceexpand:emacs:hashall:histexpand:history:interactive-comments:monitor
SHLVL=4
SSH_AGENT_PID=1321
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SSH_AUTH_SOCK=/tmp/ssh-XXMDxwPo/agent.1301
SUPPORTED=en_US:en:et_EE:et
TERM=xterm
UID=500
USER=IS
XAUTHORITY=/home/IS/.Xauthority
XMODIFIERS=@im=none
XPVM_ROOT=/usr/share/pvm3/xpvm
_=env
i=/etc/profile.d/xpvm.sh
langfile=/home/IS/.i18n
mc ()
{
    mkdir -p $HOME/.mc/tmp 2>/dev/null;
    chmod 700 $HOME/.mc/tmp;
    MC=$HOME/.mc/tmp/mc-$$;
    /usr/bin/mc -P "$@" >"$MC";
    cd "`cat $MC`";
    /bin/rm -f "$MC";
    unset MC
}
[IS@haskaa IS]$
Comment 23 Havoc Pennington 2002-08-15 17:05:35 EDT
ivo I think you are seeing a konsole problem that is supposed to be fixed in
newer Qt/kdebase, which is separate from the mc issue on the linux console. i.e. 
konsole != console. ;-)
Comment 24 Ivo Sarak 2002-08-15 17:13:54 EDT
mc on console is a mess, too: all horizontal lines are 'D', vertical lines are
subscript '3'.
Comment 25 Bernd Bartmann 2002-08-20 09:18:03 EDT
The german umlauts in mc's menus are still broken in (Null) either on the
console but also in gnome-terminal. At least mcedit seems to work now...
Comment 26 Peter van Egdom 2002-08-21 14:25:25 EDT
I noticed too that "mc" is still not working correctly in KDE's Konsole or a
virtual console in Red Hat Linux 'null'.

The only way "mc" works correctly is by starting Midnight Commander with
"mc -a".


Comment 27 Havoc Pennington 2002-08-21 19:51:22 EDT
*** Bug 71954 has been marked as a duplicate of this bug. ***
Comment 28 Karsten Hopp 2002-08-23 08:39:19 EDT
added a fix for german umlauts and tested in several languages on console,
konsole and gnome-terminal.
looks almost ok now, some minor glitches p.e. with LANG=cs_CZ.UTF-8 are still
there.

slang-1.4.5-11
slang-devel-1.4.5-11
newt-0.51.0-1
newt-devel-0.51.0-1
mc-4.5.55-12
kbd-1.06-21
initscripts-6.90-1
Comment 29 Bernd Bartmann 2002-08-24 10:01:12 EDT
Looks a lot better after upgrading to the above mentioned packages, but some
german umlauts are still not correct:
Befehl --> Lvschen r|ckgangig
Optionen --> Nachfragen
Optionen --> Tasten lernen (no umlaut problem, but the text is too wide for the
dialog box)
Comment 30 Bernd Bartmann 2002-08-24 10:07:22 EDT
Some umlauts in menu "Sortierung" are also broken.
Comment 31 Jay Turner 2002-08-29 22:46:18 EDT
Things are looking pretty good with mc-4.5.55-12.  Please reopen if there are
still outstanding issues.
Comment 32 Bernd Bartmann 2002-08-30 14:09:03 EDT
As stated above I've already updated to mc-4.55-12 and there are still some
issues. Please read my former comment again.
Comment 33 Miloslav Trmac 2002-09-18 16:58:32 EDT
FWIW, mc has huge problems in utf-8 in most areas (try LC_ALL=cs_CZ.utf8):
* when column headings contain multi-byte characters, the headins don't line up
  with the columns below
* in full view, dates are drawn wrong (try to move the "cursor" up and down a few  
  times, the dates contain multibyte characters, mc thinks that they are long and
  doesn't draw enough of them
* try to view/edit an utf-8 file (/usr/share/comps/comps.xml, search for xml:lang)

OTOH, these are arguably too massive changes for RH to do when the upstream
package clearly doesn't support utf-8. Still, it would be nice to have.
Comment 34 Leonard den Ottolander 2004-10-26 12:42:56 EDT
Most issues with UTF-8 should be fixed with the latest patches.
Closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.