Bug 68144 - mc eats all my memory and then seg faults when trying to edit a file
Summary: mc eats all my memory and then seg faults when trying to edit a file
Status: CLOSED DUPLICATE of bug 66794
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mc (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
: 70257 (view as bug list)
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-07-06 23:00 UTC by Bernd Bartmann
Modified: 2007-04-18 16:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-06 21:47:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bernd Bartmann 2002-07-06 23:00:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
When trying to edit a file mc crashes either instantly with a seg fault or first
eats all my memory and then seg faults.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start mc and try to edit a file
2.
3.
	

Additional info:

Comment 1 Peter van Egdom 2002-07-07 20:18:53 UTC
This also happens on my computer.

("mcedit foo.bar" when in X makes the system swap like crazy
 and after a while this process gets killed.

 Running "mcedit in a virtual console (like /dev/tty1)
 immediately gives a Segmentation fault).



Comment 2 Nathan G. Grennan 2002-07-07 20:36:37 UTC
Reproduced, mcedit foo.bar segmentation faults.

Comment 3 Havoc Pennington 2002-07-15 04:15:52 UTC
Maybe a gpm or slang/curses/utf-8 thing?

Comment 4 Bill Nottingham 2002-07-15 04:20:04 UTC
Maybe. It appears to happen with all the latest versions of slang/newt/etc.,
which should have most of the problems fixed.

Comment 5 Bernd Bartmann 2002-07-21 15:23:51 UTC
Still broken in mc-4.5.55-10


Comment 6 Bernd Bartmann 2002-07-30 11:00:00 UTC
mc in limbo beta2 still crashes when trying to edit a file.

Comment 7 Ivo Sarak 2002-07-30 11:36:01 UTC
This is maybe not related, but when trying to copy a file with mc (mc-4.5.55-7),
it will segfault. When to upgrade to mc-4.5.55-11 from Raw Hide it is OK.

Comment 8 Peter van Egdom 2002-07-31 18:18:09 UTC
Confirm Midnight Commander crash in Limbo 7.3.93.

After starting "mcedit <somefile>" the virtual memory grows from 30 MB to
100+ MB, the system gets *really* slow and unresponsive for a couple of
minutes, then the Midnight Commander process gets killed).

This is in a GNOME 2 terminal window.


Comment 9 Havoc Pennington 2002-08-01 02:17:00 UTC
*** Bug 70257 has been marked as a duplicate of this bug. ***

Comment 10 Need Real Name 2002-08-06 21:47:04 UTC
Doesn't happen in GNOME2 Terminal only. Even on the real console mcedit dies
trying to open a file.

Even an ordinary HelloWorld.c forces mcedit to consume all available RAM until
Linux starts swapping till all swap is full and then the kernel kills mcedit.

Comment 11 Havoc Pennington 2002-08-08 02:53:02 UTC
see bug #71039

*** This bug has been marked as a duplicate of 66794 ***


Note You need to log in before you can comment on or make changes to this bug.