Bug 68355 - internationalized keyboard gets 'lost'
internationalized keyboard gets 'lost'
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-keyboard (Show other bugs)
limbo
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
: 69683 70341 70356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-09 11:23 EDT by udippel
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 07:21:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description udippel 2002-07-09 11:23:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
Install as keyboard sg (swiss-german) results in 'sg' for root, but 'us' for all
other users.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. install keyboard 'sg'
2. create users
3. log on as user
	

Actual Results:  default keyboard 'us'

Expected Results:  logically, when install is internationalized, the default
user should find the same setting

Additional info:
Comment 1 Brent Fox 2002-07-09 18:09:46 EDT
Does this happen for the user on X or the console or both?
Comment 2 udippel 2002-07-11 00:36:23 EDT
Thanks for asking, once again I was not quite correct:
The shells are okay for any user; the X are 'us' for everyone.
Sorry for the wrong info. So it has to do with X not using the default settings
Comment 3 Alexandre Oliva 2002-07-31 14:05:58 EDT
Either redhat-config-keyboard should change /etc/X11/XF86Config, or it should
tell the user to run redhat-config-xfree86 to update the X configuration. 
Problem is, redhat-config-xfree86 doesn't seeem to look at
/etc/sysconfig/keyboard, so the only way to modify the keyboard configuration
for X11 (short of reinstalling) is to edit the X11 configuration file.  Eek.
Comment 4 Brent Fox 2002-08-01 08:17:59 EDT
In earlier builds of redhat-config-keyboard, I was munging the XF86Config file
by hand.  It worked, but it was a little ugly.  I just committed a patch that
uses pyxf86config (which redhat-config-xfree86 uses) to change the keyboard in
the XF86Config file.  Seems to work ok now.  

Should be fixed in redhat-config-keyboard-0.9.7-1.  Thanks for your report.
Comment 5 Brent Fox 2002-08-01 08:19:23 EDT
*** Bug 69683 has been marked as a duplicate of this bug. ***
Comment 6 Brent Fox 2002-08-01 21:31:18 EDT
*** Bug 70356 has been marked as a duplicate of this bug. ***
Comment 7 Alexander Larsson 2002-08-07 07:20:50 EDT
*** Bug 70341 has been marked as a duplicate of this bug. ***
Comment 8 Jay Turner 2002-08-08 09:45:29 EDT
Closing this out, as with redhat-config-keyboard-0.9.7-2, we are indeed updating
/etc/X11/XF86Config with the keyboard change.  Please note that #71067 still
needs to be resolved.

Note You need to log in before you can comment on or make changes to this bug.