Bug 68575 - fileutils not upgraded cleanly
Summary: fileutils not upgraded cleanly
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: fileutils   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 67739 69814 70156 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-11 12:26 UTC by Michael Young
Modified: 2007-04-18 16:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 18:36:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Young 2002-07-11 12:26:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
I upgraded my system from 7.3 to limbo, and have just noticed I have 2 fileutils
packages, fileutils-4.1-10 and fileutils-4.1.8-1.
The following errors are in upgrade.log

Upgrading fileutils-4.1.8-1.
install-info: menu item `yes' already exists, for file `sh-utils'
execution of %post scriptlet from fileutils-4.1.8-1 failed, exit status 1

Steps to Reproduce:
1. upgrade 7.3 to limbo
2. rpm -q fileutils

Actual Results:  Two fileutils packages

Expected Results:  fileutils-4.1-10 should have been replaced by fileutils-4.1.8-1

Comment 1 Karsten Hopp 2002-07-12 12:29:04 UTC
fileutils needs to conflict with sh-utils < 2.0.12, the coreutils.info file moved from  
one package to the other.  
I'm not sure if this was the reason why you had two versions of the same package  
installed or if this is a rpm problem. I'm reassigning to the rpm maintainer for confimation

Comment 2 Jeff Johnson 2002-07-12 14:03:43 UTC
A failed %post scriptlet can/will result
in 2 database entries for a package.

Fix by upgrading to a later version, or
by erasing using --allmatches (tricky for
fileutils), or by re-installing with --force.

Comment 3 Jay Turner 2002-07-25 18:37:45 UTC
*** Bug 69814 has been marked as a duplicate of this bug. ***

Comment 4 Michael Young 2002-07-25 19:05:01 UTC
This is still a problem when upgrading to fileutils-4.1.9-3 and
sh-utils-2.0.12-1. Probably something in the install process of one or other
package should remove the obsolete sh-utils entries in the info configuration file.

Comment 5 Michael Young 2002-07-25 20:28:51 UTC
More precisely, sh-utils-2.0.11-14 only runs install-info --delete in the
preuninstall script if it is being removed, not if it is being upgraded. But the
info entries have moved to fileutils, so need to be deleted by one of the new
packages before the sh-utils.info.gz file is removed - perhaps this should
happen in the sh-utils-2.0.12-x preinstall script. This would break 7.3 ->
7.3.92 -> milan upgrades, but I doubt you care about that.

Comment 6 Michael Young 2002-07-26 08:50:00 UTC
If you remove the sh-utils info entries by hand, and try to re-install
fileutils-4.1.9-3 you get the error
install-info: menu item `wc' already exists, for file `textutils'
error: execution of %post scriptlet from fileutils-4.1.9-3 failed, exit status 1
ie. the same type of crash against the textutils package.

Comment 7 Michael Young 2002-07-26 10:00:51 UTC
Ditto for the old fileutils info file - the error is
install-info: menu item `vdir' already exists, for file `fileutils'
error: execution of %post scriptlet from fileutils-4.1.9-3 failed, exit status 1

After fixing this, fileutils finally upgraded cleanly.

Comment 8 Mike McLean 2002-07-30 21:48:22 UTC
*** Bug 70156 has been marked as a duplicate of this bug. ***

Comment 9 Preston Brown 2002-08-14 01:09:55 UTC
*** Bug 67739 has been marked as a duplicate of this bug. ***

Comment 10 Göran Uddeborg 2002-08-19 14:54:21 UTC
Couldn't this be resolved by using "grep -v" to remove any lines containing
"(sh-utils)", "(fileutils)" or "(textutils)" from /usr/share/info/dir?  Placed
in the postinstall script before the install-info command.  Or would this break
in some situation?


Comment 11 Tim Waugh 2002-08-21 16:31:05 UTC
Just '|| :' on the end is sufficient for the upgrade to succeed, although of 
course it doesn't resolve the issue entirely. 
  
I've added '|| :' to fileutils-4.1.9-7.

Comment 12 Tim Waugh 2002-08-21 16:55:11 UTC
goeran@uddeborg.pp.se: Yes, your suggestion works, at least for me.  Fixed 
package is fileutils-4.1.9-8.

Comment 13 Michael Young 2002-08-21 18:36:40 UTC
I agree that this solution is more practical than using install-info scripts,
since you don't need to co-ordinate the package installs so much, and the
scripts are less complicated, particularly since the info files in 6.2 and 7.3
are in different places.

Comment 14 Jay Turner 2002-09-03 15:50:54 UTC
Fix confirmed with fileutils-4.1.9-11.


Note You need to log in before you can comment on or make changes to this bug.