Bug 690895 - [abrt] xfce4-panel-4.8.2-2.fc15: strcmp: Process /usr/bin/xfce4-panel was killed by signal 11 (SIGSEGV)
[abrt] xfce4-panel-4.8.2-2.fc15: strcmp: Process /usr/bin/xfce4-panel was kil...
Status: CLOSED DUPLICATE of bug 768521
Product: Fedora
Classification: Fedora
Component: xfce4-panel (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:97c3e9597f744046a18b34ea392...
:
: 710919 715321 758394 758395 765711 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-25 14:08 EDT by Richard W.M. Jones
Modified: 2012-03-21 11:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 11:11:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.61 KB, text/plain)
2011-03-25 14:08 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2011-03-25 14:08:06 EDT
abrt version: 1.1.17
architecture: x86_64
Attached file: backtrace, 74356 bytes
cmdline: xfce4-panel
comment: Just clicking on the Application Menu triggered a segfault.
component: xfce4-panel
Attached file: coredump, 43057152 bytes
crash_function: strcmp
executable: /usr/bin/xfce4-panel
kernel: 2.6.38-1.fc15.x86_64
package: xfce4-panel-4.8.2-2.fc15
rating: 4
reason: Process /usr/bin/xfce4-panel was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1301076244
uid: 500

How to reproduce
-----
1. Clicked on the Applications Menu
2. Panel disappeared then reappeared
3. (that's it)
Comment 1 Richard W.M. Jones 2011-03-25 14:08:10 EDT
Created attachment 487630 [details]
File: backtrace
Comment 2 Kevin Fenzi 2011-03-25 16:50:54 EDT
Interesting. This might be in garcon... it looks like it was reading icons when it happened. 

I'll try and see what can be made of this. Thanks for the backtrace... 

Can you duplicate it? Or it just happened the one time?
Comment 3 Richard W.M. Jones 2011-03-25 18:20:36 EDT
Definitely it's not happening now.

F15's i915 driver is very hairy.  When this bug hit was just after
I'd tried and failed to watch a video using VLC, and the i915 driver
was showing issues.  About an hour later I had to reboot the whole
laptop.

I really have no idea if the X driver stuff is related to this bug.
Comment 4 Kevin Fenzi 2011-03-26 13:31:12 EDT
It could well be. :( 

I've also seen weird behavior with the intel driver of late... 

I can try and see what upstream makes of this, but the backtrace is pretty weird. garcon was trying to build a menu, reading an svg icon and then boom.
Comment 5 Christoph Wickert 2011-11-29 13:57:51 EST
*** Bug 715321 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Wickert 2011-11-29 14:02:44 EST
*** Bug 758394 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2011-11-29 14:02:48 EST
*** Bug 758395 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2011-11-29 14:03:38 EST
Not sure if bug 710919 is another duplicate.
Comment 9 Christoph Wickert 2011-12-09 03:49:30 EST
*** Bug 765711 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Wickert 2011-12-09 03:49:44 EST
*** Bug 710919 has been marked as a duplicate of this bug. ***
Comment 11 David Chin 2011-12-16 11:49:23 EST
Package: xfce4-panel-4.8.6-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Tried to add a Launcher to XFCE panel.
Comment 12 abrt-bot 2012-03-21 11:11:33 EDT
Backtrace analysis found this bug to be similar to bug #768521, closing as duplicate.

Bugs which were found to be similar to this bug: 
  control-center: bug #548503
  evolution: bug #608960
  gcompris: bug #563786
  gnome-shell: bug #737314
  rhythmbox: bug #568324
  totem: bug #544810
  xfce4-panel: bug #715321, bug #758394, bug #758395, bug #765711, bug #768521

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 768521 ***

Note You need to log in before you can comment on or make changes to this bug.