Bug 6970 - SIS 5598 and XFree
Summary: SIS 5598 and XFree
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 5409 7406 7503 7769 8304 8554 8640 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-13 01:31 UTC by hansen
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 20:44:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hansen 1999-11-13 01:31:35 UTC
Upgraded from 6.0 to 6.1
TXPRO II with on board SIS 5598 video chip
ADI Microscan 3E monitor
Can not get video to work, worked fine in 6.0
Text fields blank in some graphics, like printer config

Comment 1 Simon Oldfield 1999-11-15 02:35:59 UTC
I recently installed RedHat 6.1 on a machine with an ASUS motherboard with an
inbuilt SiS5598 graphics adapter.  I had to use the text install as the
graphical version displayed all text (text fields, button text, tree control
item text, etc) as black on black.  Similarly once I got through to the X
configuration it did the same thing.  I ended up removing the XFree86_SVGA
server from the XFree86-3.3.5 and re-installing the XFree86-3.3.1 (I think) from
the RedHat 6.0 installation and the X server then worked ok.

Comment 2 Ronald Bruintjes 2000-01-10 11:10:59 UTC
Same thing here, on a HP Vectra using the SiS6205 chipset. Thru fiddling with
the XF86Config I'm down to only black on black in some screens (like the
Control Panel Printer Configuration tool's error messages), but with the
default configuration everything was black on black.
I'v added the option "no_pixmap_cache", which resulted in one line in the
Printer Configuration being displayed correctly (the others still are black on
black).
"no_accel" seems to be mandatory to get any text...:)
I'll try to reinstall the XF server included in 6.0 to see if that helps
anything.

Comment 3 Preston Brown 2000-01-13 16:19:59 UTC
*** Bug 7503 has been marked as a duplicate of this bug. ****** Bug 7769 has been marked as a duplicate of this bug. ***

Comment 4 Preston Brown 2000-01-14 16:55:59 UTC
*** Bug 7406 has been marked as a duplicate of this bug. ***

Comment 5 Preston Brown 2000-01-14 17:03:59 UTC
*** Bug 5409 has been marked as a duplicate of this bug. ***

Comment 6 Preston Brown 2000-01-18 15:51:59 UTC
adding Options "xaa_no_color_exp" to your XF86Config file will cure the problem.

Comment 7 Preston Brown 2000-01-18 15:52:59 UTC
*** Bug 8554 has been marked as a duplicate of this bug. ***

Comment 8 Ronald Bruintjes 2000-01-19 10:24:59 UTC
Hmm... xaa_no_color_exp doesn't help much.
The first screen in the Print Tool from the Control Panel shows the message
informing me that I don't have access to Novell printqueues mostly in black on
black. However, this seems to be the only place that happens. Could be a bug in
the Print Tool.

Comment 9 Preston Brown 2000-01-19 18:47:59 UTC
try Option no_accel then and see if it works.

Comment 10 Ronald Bruintjes 2000-01-20 11:24:59 UTC
See Comment as of 01/10/00 06:10. I currently have the following options
defined:
  no_accel
  no_pixmap_cache
  xaa_no_color_exp
I've also forced the VideoRam to 1024 (just to be sure). It still gives the
black-on-black in Print Tools.

Comment 11 Preston Brown 2000-01-24 21:32:59 UTC
*** Bug 8640 has been marked as a duplicate of this bug. ***

Comment 12 Preston Brown 2000-01-24 21:33:59 UTC
*** Bug 8304 has been marked as a duplicate of this bug. ***

Comment 13 fourcs 2000-02-03 20:34:59 UTC
Xserver lost connection to xfont server. Had to replace reference to "unix" in
XFConfig file with a reference to location of the fonts to make it work.

Comment 14 Preston Brown 2000-02-04 20:44:59 UTC
SiS cards are fixed in 3.3.6, available in rawhide or with the forthcoming RHL
6.2 release.

Comment 15 Richard Elkins 2000-02-23 19:06:59 UTC
This might help some of you with the same graphics chipset.
I have an HP Pavilion 6350 which has SiS 5598 imbedded
in the mobo.  By the way, HP claims that Linux is not supported
on the HP Pavilion [(^;].

I was using Redhat Linix 6.0 [XFree86 3.3.3] without problems.
As soon as I upgraded to Redhat Linix 6.1 [XFree86 3.3.5],
I started getting intermittent black screens and consistent black boxes
where graphic images should have been.  The only thing I could do was
operate in command mode.

It turns out that the XFree86 device driver support for SiS 5597/5598
was fixed at version 3.3.3 from earlier problems and re-broken at
version 3.3.5.  Such is life!  Me?  I never create bugs in my code
[(^;].

Anyways, here is a recipe for upgrading Redhat Linux 6.0 to 6.1 for SiS
5597/5598 users which works on the HP Pavilion and hopefully elsewhere:

   1) You're on a stable 6.0 with XFree86 version 3.3.3.
        You can use the RPM utility to verify this.
   2) Put the 6.1 installation CD in the drive and shutdown/reboot.
   3) Select UPGRADE.
   4) Select CUSTOMISE PACKAGES.
   5) Go to the end of the package list.
        Only for the X device handling, decline to install it (blank
        out the '*').
   6) Complete the installation.  You are now (hopefully) upgraded
without the 3.3.5  X device handler (like me).

My system is stable and I can type this posting with Netscape 4.7.

I do not know if the future Redhat 6.2 which is rumoured to use XFree86
3.3.6 will be okay with this graphics chipset.  Time will tell.

-Richard


Note You need to log in before you can comment on or make changes to this bug.