Bug 701218 - [abrt] octave-6:3.2.4-4.fc14: LockSemaphoreInfo: Process /usr/bin/octave-3.2.4 was killed by signal 6 (SIGABRT)
Summary: [abrt] octave-6:3.2.4-4.fc14: LockSemaphoreInfo: Process /usr/bin/octave-3.2....
Keywords:
Status: CLOSED DUPLICATE of bug 655569
Alias: None
Product: Fedora
Classification: Fedora
Component: octave
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:28f2d1077c4e5454022caa15853...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-02 06:49 UTC by Michael Kopinsky
Modified: 2012-03-20 16:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-20 16:47:31 UTC


Attachments (Terms of Use)
File: backtrace (28.63 KB, text/plain)
2011-05-02 06:49 UTC, Michael Kopinsky
no flags Details

Description Michael Kopinsky 2011-05-02 06:49:55 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 29314 bytes
cmdline: octave
comment: I got the same result several times with a jpg as well as a png. I did not try multiple files or other file types.
component: octave
Attached file: coredump, 41246720 bytes
crash_function: LockSemaphoreInfo
executable: /usr/bin/octave-3.2.4
kernel: 2.6.35.12-88.fc14.i686
package: octave-6:3.2.4-4.fc14
rating: 4
reason: Process /usr/bin/octave-3.2.4 was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1304318181
uid: 500

How to reproduce
-----
octave:1> I=imread("car-insurance-policy.jpg");
octave: magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (SemaphoreInfo *) ((void *)0)' failed.
panic: Aborted -- stopping myself...
Aborted (core dumped)

Comment 1 Michael Kopinsky 2011-05-02 06:49:58 UTC
Created attachment 496170 [details]
File: backtrace

Comment 2 David C 2011-06-18 21:05:03 UTC
Package: octave-6:3.2.4-4.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Install octave , octave-forge on FC14 machine
2. start octave
3. open image with scu=imread('twilight_sculler_jonathan_bowcott_rescan_v3.png')

Crashes....
 [phdgc@desktop ~]$ octave
GNU Octave, version 3.2.4
Copyright (C) 2009 John W. Eaton and others.
This is free software; see the source code for copying conditions.
There is ABSOLUTELY NO WARRANTY; not even for MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.  For details, type `warranty'.

Octave was configured for "i386-redhat-linux-gnu".

Additional information about Octave is available at http://www.octave.org.

Please contribute if you find this software useful.
For more information, visit http://www.octave.org/help-wanted.html

Report bugs to <bug@octave.org> (but first, please read
http://www.octave.org/bugs.html to learn how to write a helpful report).

For information about changes from previous versions, type `news'.

warning: mark_as_command is obsolete and will be removed from a future version of Octave
warning: addpath: /usr/local/share/octave/2.1.72/site/m/octave-forge/: No such file or directory
warning: EXEC_PATH is now a function instead of a built-in variable.  By assigning to EXEC_PATH, you have created a variable that hides the function EXEC_PATH.  To remove the variable and restore the function, type "clear EXEC_PATH"
octave:1> scu=imread('twilight_sculler_jonathan_bowcott_rescan_v3.png')
octave: magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (SemaphoreInfo *) ((void *)0)' failed.
panic: Aborted -- stopping myself...
Aborted (core dumped)
[phdgc@desktop ~]$

Comment 3 abrt-bot 2012-03-20 16:47:31 UTC
Backtrace analysis found this bug to be similar to bug #655569, closing as duplicate.

Bugs which were found to be similar to this bug: bug #623112, bug #655569, bug #665774, bug #693556, bug #741408

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 655569 ***


Note You need to log in before you can comment on or make changes to this bug.