Bug 71386 - OpenOffice.org 1.0.1 menu font has poor legibility
OpenOffice.org 1.0.1 menu font has poor legibility
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
http://www.vendomar.ee/~ivo/oo101unde...
:
: 81631 (view as bug list)
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-12 17:27 EDT by Ivo Sarak
Modified: 2007-04-18 12:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-27 10:45:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2002-08-12 17:27:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Nothing to say: default font is bad!
Even worse is that I can not figure out from were I might adjust OpenOffice.org
menu font. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install OpenOffice.org 1.0.1 and try to run it under KDE.

Actual Results:  Unreadable menu fonts.

Expected Results:  No problem with fonts.

Additional info:

I installed all sorts of fonts I managed to find on RedHat Limbo II.

rpm -qa|grep openoffice
openoffice-1.0.1-3
openoffice-i18n-1.0.1-3
openoffice-libs-1.0.1-3

rpm -qa|grep kde
kdesdk-devel-2.2.2-1
kde-i18n-Polish-3.0.2-2
kdepim-cellphone-3.0.2-3
kdepim-pilot-3.0.2-3
kdeartwork-3.0.2-3
kdesdk-kbabel-3.0.2-2
kdebindings-python-2.2.2-1
kde-i18n-Chinese-Big5-3.0.2-2
kdeadmin-3.0.2-3
kdemultimedia-devel-3.0.2-3
kdeaddons-kicker-3.0.2-3
kdegames-3.0.2-2
kde1-compat-1.1.2-11
kdebindings-perl-2.2.2-1
kde-i18n-Estonian-3.0.2-2
lockdev-devel-1.0.0-20
licq-kde-1.2.0a-1
kdeaddons-noatun-3.0.2-3
kdelibs-devel-3.0.2-5
kdeaddons-knewsticker-3.0.2-3
kdebindings-3.0.2-3
kde-i18n-Xhosa-2.2.2-2
kdetoys-3.0.2-2
kdemultimedia-libs-3.0.2-3
switchdesk-kde-3.9.8-7
kdesdk-kmtrace-3.0.2-2
kde-i18n-Bulgarian-2.2.2-2
kde-i18n-Hebrew-3.0.2-2
kdemultimedia-arts-3.0.2-3
kdepim-devel-3.0.2-3
kdebase-3.0.2-7
kdeaddons-konqueror-3.0.2-3
kdenetwork-libs-3.0.2-3
kdesdk-kapptemplate-3.0.2-2
lockdev-1.0.0-20
kdebindings-devel-3.0.2-3
kdesdk-kompare-3.0.2-2
unixODBC-kde-2.2.2-1
kdevelop-2.1.2-3
kdeaddons-kate-3.0.2-3
kdebindings-kmozilla-3.0.2-3
kdelibs-3.0.2-2
kdesdk-kspy-3.0.2-2
kde1-compat-devel-1.1.2-11
kde-i18n-Lithuanian-2.2.2-2
kdeartwork-locolor-3.0.2-3
kde2-compat-2.2.2-7
kdepim-3.0.2-3
kdebase-devel-3.0.2-7
kdesdk-kbugbuster-3.0.2-2
Comment 1 Preston Brown 2002-08-21 23:36:53 EDT

*** This bug has been marked as a duplicate of 68953 ***
Comment 2 Ivo Sarak 2002-09-03 16:19:31 EDT
With RedHat Beta Null I still have this problem:

http://www.vendomar.ee/~ivo/oo101-5underKDE.png
Comment 3 Need Real Name 2002-09-06 01:19:37 EDT
Under the Tools -> Options dialog, you will find Font Replacement. The standard
font replacement table has Andale Sans UI being replaced by Luxi Sans. If you
can find a better sans font than Luxi, (perhaps a true-type one), then use it.
You can change or disable the font substitution to get a better result.

If you don't have access to a better font you can scale the existing one by 120%
to get a more legible rendition. Under Tools -> options, select View and adjust
the "scale" window from 100% up to 120%.
Comment 4 Ivo Sarak 2002-09-06 08:54:38 EDT
What are the actual UI fonts OOo is using?

Font replacement menu default settings:
http://www.vendomar.ee/~ivo/oo101-5underKDEfontsrepDefault.png

Fonts with letter 'a':
http://www.vendomar.ee/~ivo/oo101-5underKDEfontsrep.png
Comment 5 Jakub Jelinek 2002-09-06 09:59:19 EDT
Have you rm -rf ~/.sversionrc ~/.openoffice during the upgrade?
Without that most of the changes which went in between 1.0.1-3 and 1.0.1-7
don't take any effect. From the pictures it looks like you're actually using
Andale Sans UI -> Mincho font replacement (or with no replacement for some
reason you get this by default).
For latin languages newer ooffice scripts will default to Luxi Sans as UI font,
which looks completely different than on your pictures.
Comment 6 Ivo Sarak 2002-09-06 10:46:43 EDT
After rm -rf ~/.openoffice this menu issue has resolved:
http://www.vendomar.ee/~ivo/oo101-5underKDEafterRM.png
Comment 7 Bill Nottingham 2003-02-11 00:44:23 EST
*** Bug 81631 has been marked as a duplicate of this bug. ***
Comment 8 Dan Williams 2004-02-27 10:45:05 EST
Please try current OOo 1.1.0, and reopen if problem still occurs

Note You need to log in before you can comment on or make changes to this bug.