Bug 72125 - perldoc prints wrong characters in UTF-8 environment
perldoc prints wrong characters in UTF-8 environment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
: 72630 (view as bug list)
Depends On:
Blocks: 67218 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-08-21 06:01 EDT by Harald Hoyer
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-30 08:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2002-08-21 06:01:15 EDT
SSIA
Comment 1 Chip Turner 2002-08-22 13:59:42 EDT
what should it print instead?  I'm no *roff expert.  if you can suggest what it
should be doing, I can fix it, but not without knowing the exact problem.
Comment 2 Harald Hoyer 2002-08-23 07:18:26 EDT
well, e.g.
$ perldoc open
gives me an ugly formatted screen in a UTF-8 capable terminal, where I can see
the escape sequences...
Comment 3 Gordon Messmer 2002-08-25 13:48:23 EDT
This may be related to bug 71913.  Perhaps the problem lies in the "less"
package?  I first saw this in (null), someone should see what's changed since
the second beta.
Comment 4 Chip Turner 2002-08-29 14:18:02 EDT
the issue is inside of groff, it seems.  florian is looking into it.
Comment 5 Florian La Roche 2002-09-01 03:38:59 EDT
Either set an option to not use the new ansi escaping in groff or add an
option to the pager to display them correctly like done in man ("less -isr")

Florian La Roche
Comment 6 Chip Turner 2002-09-01 18:02:28 EDT
*** Bug 72630 has been marked as a duplicate of this bug. ***
Comment 7 Chip Turner 2002-09-02 20:49:39 EDT
fixed in rawhide, less -isr now used as default perl pager
Comment 8 Wade Minter 2002-09-05 13:58:59 EDT
I just downloaded -51 from rawhide, and the problem is still there.  I've done
everything except reboot the box.  

Curiously enough, if I run "less -isr /tmp/filename" while perldoc is open, I
see the correct output.

Do I need to get another package in addition to perl-5.8.0-51.i386.rpm, or is
this not completely fixed?
Comment 9 Chip Turner 2002-09-05 16:32:43 EDT
this is fixed in our latest internal build, -55, but hasn't made it to rawhide
yet.  will investigate why it isn't there.
Comment 10 Rob McMillin 2002-12-30 09:50:41 EST
Re comment 3, I would go so far as to say it's in fact a duplicate of bug 71913.
Comment 11 Scott R. Godin 2003-01-21 17:49:17 EST
line 584 in perldoc: 

changed
    my $cmd = catfile($bindir, $pod2man) . " --lax $file | $opt_n -man";

to
    my $cmd = catfile($bindir, $pod2man) . " --lax $file | $opt_n -man -c";

problem with escape sequences being viewable in less went away.

(by the way my env var for LESS = "CegMS" )

don't know if this is THE solution, but it's a workable one. :-)
Comment 12 Chip Turner 2003-02-20 12:43:22 EST
can anyone confirm if they are still having difficulties with the latest
rawhide?  I'm not seeing this problem any longer
Comment 13 Harald Hoyer 2003-10-30 08:24:41 EST
seems to be fixed :)

Note You need to log in before you can comment on or make changes to this bug.