Bug 743157 - Save as Approved on last entry of a page should not move to next page
Save as Approved on last entry of a page should not move to next page
Status: CLOSED WONTFIX
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Patrick Huang
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-03 22:56 EDT by Noriko Mizumoto
Modified: 2013-11-26 23:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 23:10:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2011-10-03 22:56:10 EDT
Description of problem:
Saving the last entry automatically moves to the top entry of next page. This makes translator unable to check the string just saved. 

Version-Release number of selected component (if applicable):
Zanata version 1.4 (20111003-1100)

How reproducible:
Always

Steps to Reproduce:
1. Go to the last entry of the page
2. Make a change and save it
3. The top entry of next page appears
  
Actual results:
Saving the last entry moves to the top entry of next page. To check the last entry just saved, translator needs to go back manually.

Expected results:
Saving the last entry does not move to the top entry of next page.

Additional info:
Comment 1 Ding-Yi Chen 2011-10-19 02:38:59 EDT
Hmm, it actually contradict what is described in bug 740166.

One workaround is: you Save as NeedReview (Fuzzy), once Bug 746870 is fixed, you should be able to do the necessary edit and check, and "Save as Approved" when you are satisfied the translation.

IMHO, Save as Approved should be reserved to the works you deem completed and no more effort and editing are required.

Runa, what do you think?
Comment 2 Runa Bhattacharjee 2011-10-20 01:21:30 EDT
There seems to be two different navigation issues here and in bug 740166:

1. Movement to the first entry of the next page due to saving of the last entry of the previous page

2. Movement to the last entry of the previous page/first entry of the next page due to the explicit usage of the navigation shortcut.


So the translator would have two options when they reach the end of the page. They can either:
1) press the keyboard shortcut/button to save the cell and stay on the same page (to take a quick look at all the entries) and then move to the next page using the navigation buttons

or

2) press the keyboard shortcut to save the cell and move to the next/previous entry in the next/previous page

Noriko, can you please confirm if this is the use case for the issue here?

Thanks
Comment 3 Noriko Mizumoto 2011-10-20 04:14:23 EDT
Current behaviour:
At the last cell of 1st page, pressing ctrl+enter to save automatically moves and shows 2nd page. To start first cell of 2nd page, user must click in the cell explicitly.

* Currently it seems no option to save and stay, nor to save and move next page top cell. 

Desirable behaviour with two different shortcuts:
A shortcut - save and stay on the same page.
B shortcut - save and move to the top cell of next page.
Comment 4 Runa Bhattacharjee 2011-10-24 13:37:34 EDT
(In reply to comment #3)

> Desirable behaviour with two different shortcuts:
> A shortcut - save and stay on the same page.

This can possibly be included in the new navigation mode, but will need some thinking so as not to mess up the navigation.

> B shortcut - save and move to the top cell of next page.

This may not be possible currently due to bug 739422
Comment 5 Runa Bhattacharjee 2012-07-30 09:54:39 EDT
Request for technical evaluation.
Comment 6 Patrick Huang 2012-09-25 22:09:57 EDT
can not reproduce in 2.0 new editor. I remember I had to fix something while implementing the new editor. The issue is occasionally we are comparing source sting and target string on different row. i.e. comparing A source to B target during switching rows. Anyway it seems fixed.
Comment 7 Patrick Huang 2012-09-25 22:11:22 EDT
(In reply to comment #6)
> can not reproduce in 2.0 new editor. I remember I had to fix something while
> implementing the new editor. The issue is occasionally we are comparing
> source sting and target string on different row. i.e. comparing A source to
> B target during switching rows. Anyway it seems fixed.

DOH!! ignore this comment. I was talking about another bug.
Comment 8 Ding-Yi Chen 2012-09-27 22:06:46 EDT
Noriko, the current title "Saving the last entry automatically moves to the top entry of next page" sounds like you actualy want the cursor to move after save.

Perhaps I should changed the title as "Save as Approved on last entry of a page should not move to next page"
Comment 9 Ding-Yi Chen 2012-09-27 22:17:18 EDT
Actually, we do support save an stay, i.e. Save as Fuzzy (Ctrl-S).

A new shortcut key only for "Stay at the last entry after Save as Approved" has several drawback:
1) It is likely to clash with keyboard shortcut for desktop environment and browsers and possibly their plugins. Both Firefox and Chrome have lots of shortcuts, and many of them do not intersect.

2) Translators need to change the shortcuts which they used to.


Correct me if I am wrong, but isn't the idea of "Save as approved" that you think the translation is correct thus no need to check again?
Comment 10 Ding-Yi Chen 2013-01-08 00:23:50 EST
Given Bug 746870 is fixed, do you think the cursor should stay at current entry when you "Save as Approved" on last entry of the page?
Comment 11 Noriko Mizumoto 2013-01-08 02:32:45 EST
If zanata can detect last cell and 'save and stay' only for last entry (with ctrl+enter) while for non-last cells it still 'save and move next cell' (with same ctrl+enter), it would be nice. Otherwise, it seems resonable to wait for the introduction of the ability to set own preference of page size.

If page size can be set to '50' as user's default preference than '10' of current global default, the occurence of 'save and move to next page' will be reduced to one-fifth. So that it becomes less annoying.
Comment 12 Ding-Yi Chen 2013-09-26 00:49:00 EDT
Noriko, how about a toggle in preference which stated:

Ctrl-Enter does not move to next page
Comment 13 Noriko Mizumoto 2013-10-01 22:17:37 EDT
Ding-Yi

It sounds nice, but one concern.

Currently, Ctrl-Enter moves to immediate next string (thus if it is last entry, it moves to next page). 

If toggling it in preference as "ctrl-enter does not move to next page", then won't it change its behaviour to 'not move to immediate next and stay' as well?
If this is true, it is not nice.

Btw, now setting page size to '50' as user's default available, and this bug now annoy me less. If no one other than me do care this bug, I am happy to close as 'won't fix'.

Thanks again Ding-Yi.

noriko

Note You need to log in before you can comment on or make changes to this bug.