Status: CLOSED DUPLICATE of bug 72587
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
: 75028 77729 80426 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-10-01 15:39 EDT by Ed
Modified: 2007-04-18 12:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:49:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ed 2002-10-01 15:39:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
System freezes on init while trying to bring up the loopback interface. 
Interface eth0 is loaded, then loopback interface locks.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Upgrade 7.3 install to 8.0
2.Boot system

Actual Results:  Init freezes on loopback interface activation

Expected Results:  Init freezes on loopback interface activation

Additional info:

Running a Sony Vaio PCG-GRX570 with a Pentium 4m.
This system ran Red Hat 7.3 very well.

Further troubleshooting: I booted a 2.4.19rc2 kernel I compiled under RH 7.3
with no problems.  Then I compiled the i686 2.4.18-14 from scratch
(/usr/src/linux-2.4/configs/kernel-2.4.18-14.i686.config file).

I installed the newly compiled kernel.  Rebooted.  Same problem with that kernel.
Comment 1 Ed 2002-10-01 16:28:03 EDT
Narrowed this down to the /etc/init.d/network script.  It's locking up on this 

action $"Bringing up loopback interface: " ./ifup ifcfg-lo

It does not get past this line.
Comment 2 Edward Simmonds 2002-10-02 11:48:32 EDT
Did a clean install on the same machine (not an upgrade of 7.3).  Same problem
occurred.  This is a complete show-stopper.  

I narrowed the hang down to this section in /sbin/ifup:

if ! ip link set ${REALDEVICE UP} ; then
    echo $"Failed to bring up ${DEVICE}."
    exit 1

Also, if I totally disable the network during init, the init crashes loading pcmcia.

Comment 3 Need Real Name 2002-10-09 17:22:56 EDT
I have the same problem with a HP Pavilion ZE1230 (mobile Athlon XP 1500).  If I
do the interactive startup, and skip the "start service network",(and PCMCIA,
but that's another one), then the system starts up ok, but I cannot access the LAN.

It worked fine with Redhat 7.3, but freezes with 8.0 at this point.  

Also, when frozen, a CTRL/ALT/DEL will wake it up and cause it to restart, but
it does that same thing.
Comment 4 Samuel Alpher 2002-10-11 13:21:03 EDT
same behavior with a Sony Vaio PCG-GR370 pentium 3m 1.13GHz fresh install.  
Worked great with RH 7.2 and 7.3. 
note that at least in my case, once booted through interactive boot (no pcmcia 
or network), manually insmodding pcmcia modules (yenta_socket etc...) will 
hang. ifconfig will also hang. 
-Tried after removing pcmcia cards and found no change in behavior.
Comment 5 Need Real Name 2002-10-29 04:22:31 EST
try to disable kudzu service
Comment 6 Need Real Name 2002-10-30 16:19:53 EST
I am installing RedHat 8.0 on a Sony Vaio PCG-GRX570 and I see exactly the same 
problem. I am completely dead in the water.
Comment 7 Need Real Name 2002-10-30 16:24:12 EST
As stated by, if you skip the kudzu service this problem does 
not occur.
Comment 8 Need Real Name 2002-10-30 17:02:29 EST
Being relatively new to Linux, how do I skip kudzu service?   Do I just do it
through interactive startup?  Also,how do I install new hardware?  Do I just run
kudzu manually?  Thanks, Will
Comment 9 Ed 2002-10-30 17:30:46 EST
Install RH 8.0 and boot 'I'nteractive. do NOT activate Kudzu.  The system will
start just fine.  Then disable kudzu with chkconfig or ntsysv.

Worked for me anyways.
Comment 10 Bill Nottingham 2002-10-30 22:23:57 EST
Do you have an alias for iee1394-controller in your /etc/modules.conf?

What happens if you change the alias to 'off'?
Comment 11 Ed 2002-10-31 16:14:02 EST
Here's my module.conf (no ieee1394 entry that I can see):

# more modules.conf
alias parport_lowlevel parport_pc
alias eth0 eepro100
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 |
| :
alias usb-controller usb-uhci
Comment 12 Bill Nottingham 2002-11-12 01:32:42 EST
*** Bug 75028 has been marked as a duplicate of this bug. ***
Comment 13 Ben Levenson 2002-12-03 18:13:11 EST
*** Bug 77729 has been marked as a duplicate of this bug. ***
Comment 14 Steve Cronk 2002-12-25 23:33:44 EST
*** Bug 80426 has been marked as a duplicate of this bug. ***
Comment 15 Steve Cronk 2002-12-25 23:52:01 EST
i also have a sony grx550 laptop and have the same problems with 8.0.
i have tried to disable kudzu but have problems with glide point mouse..very 
erratic response..but disabling kudzu does allow me to boot into 8.0..but with 
the mouse wierd response..this problem is still a show stopper for me.
i have since downgraded to 7.3.
Comment 16 Monte Smith 2002-12-27 12:56:30 EST
A solution was posted to Google Groups by crywolf.  This at least allows you to 
get past the boot.  The rest will have to wait for a Red Hat Patch.  Boot and 
use the I option (interactive boot), Do not run kudzu.  Then you can turn off 
kudzu as per below.
"looks like kudzu has a problem with certain hardware.
go into runlevel 1 and turn kudzu off
/sbin/chkconfig --level 345 kudzu off
and you should be up and running"
Comment 17 Samuel Alpher 2002-12-27 20:54:21 EST
I found another way around this bug as I would rather not have kudzu disabled. 
Pulling the ieee1394 directory from /lib/modules/2.4.18-my-ver allowed kudzu to
run and did not hang the init.  note:: I did not see firewire or ieee1394
mentioned in /etc/modules.conf so I did not try to go about this in a clean
fashion.  So for myself and anyone else who is not dependant on firewire
peripherals this might be a good way to get around this issue.  
Comment 18 Bill Nottingham 2003-01-14 00:24:33 EST
This is a kernel bug in that loading the firewire modules appears to greatly
destabilize the system.
Comment 19 Franklin Abud 2003-01-22 20:30:59 EST
Comment 20 Jeff Econ 2003-01-28 06:44:14 EST
using Ed's suggestion in comment#9, I went into chkconfig and turned off Kudzu
(after booting interactively and not starting Kudzu)typing the following:

chkconfig -level 345 kudzu off

My VAIO GRX550 laptop boots fine with RH 8.0 (kernel 2.14.18)
Comment 21 Cliff Diamond 2003-02-20 05:38:43 EST
Is this definitely a bug in kudzu and, if so, will it get fixed? This has been 
at NEW status since October!
Comment 22 Steve Cronk 2003-03-03 19:24:25 EST
Is anyone actively looking into this problem?  I have since removed RH 8.0 from 
my laptop, there are several temp fixes for this problem listed in this 
ticket...but they are temporary.  This is very poor customer 
released an operating system that does not install unless finagle with the boot 
process..even windows installs without this much headache.
At the very least this status should not be NEW!

Steve Cronk
Comment 23 Alan Cox 2003-06-05 08:03:20 EDT
Not only has it been looked at it may also work fine with the newer errata kernels.
Does it ?
Comment 24 Alan Cox 2003-06-07 22:07:20 EDT

*** This bug has been marked as a duplicate of 72587 ***
Comment 25 Red Hat Bugzilla 2006-02-21 13:49:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.