Bug 749618 - Mimetype tree is not a DAG!" errors + crashes when using SMI 0.91
Mimetype tree is not a DAG!" errors + crashes when using SMI 0.91
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdepimlibs (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 739659 742367 (view as bug list)
Depends On:
Blocks: F16Blocker/F16FinalBlocker
  Show dependency treegraph
 
Reported: 2011-10-27 13:02 EDT by Rex Dieter
Modified: 2011-10-29 02:31 EDT (History)
16 users (show)

See Also:
Fixed In Version: kdepimlibs-4.7.2-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-29 02:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2011-10-27 13:02:46 EDT
kdepimlibs akonadi-using functions (kaddressbook in particular) crashes on almost any usage with shared-mime-info 0.91 where text/directory
was replaced with text/vcard (which was made an alias).

See also upstream bug,
https://bugs.kde.org/show_bug.cgi?id=283615
Comment 1 Rex Dieter 2011-10-27 13:08:56 EDT
*** Bug 739659 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2011-10-27 13:09:56 EDT
*** Bug 742367 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2011-10-27 13:32:19 EDT
kdepimlibs-4.7.2-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kdepimlibs-4.7.2-2.fc16
Comment 4 Rex Dieter 2011-10-27 13:33:41 EDT
Patched build confirmed mmm, mmm good.

Nominating for blocker, as kaddressbook on kde-live will crash on pretty much any attempt to actively use it.
Comment 5 Jan Simonson 2011-10-27 14:44:08 EDT
Using kdepimlibs-4.7.2-2.fc16 has solved the problem with kaddressbook crashing as soon as a new contact is added on my virtual machine (x86_64). Also the group import into kmail works now.
Comment 6 Peter Gückel 2011-10-27 15:38:51 EDT
I updated to these new kdepimlibs packages and kaddressbook now works correctly.

Unfortunately, it does not solve the knotes problem.

I have created an akonadi notes resource and configured it to use the file /home/peter/Documents/personal/notes.ics. When I open Knotes, there is nothing shown, even though when I open notes.ics in kwrite, I can see all of my information.
Comment 7 Rex Dieter 2011-10-27 15:41:28 EDT
any bugs filed for knotes? (hint hint... :)
Comment 8 Rex Dieter 2011-10-27 15:44:09 EDT
fwiw, notes I create land in ~/.kde/share/apps/knotes/ by default.
Comment 9 Peter Gückel 2011-10-27 18:35:49 EDT
(In reply to comment #7)
> any bugs filed for knotes? (hint hint... :)

bz#749688
Comment 10 Adam Williamson 2011-10-28 01:49:10 EDT
CCing people for blocker votes. I'm +1 blocker per criterion "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items".
Comment 11 Kamil Páral 2011-10-28 06:46:36 EDT
+1 blocker
Comment 12 Jared Smith 2011-10-28 11:29:11 EDT
+1 blocker
Comment 13 Tim Flink 2011-10-28 12:35:18 EDT
+1 blocker

Since we're now at +4 blocker, accepting
Comment 14 Fedora Update System 2011-10-28 17:32:32 EDT
Package kdepimlibs-4.7.2-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdepimlibs-4.7.2-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15042
then log in and leave karma (feedback).
Comment 15 Adam Williamson 2011-10-28 18:44:12 EDT
Update looks like a good fix to me, Peter also confirmed the fix, so setting VERIFIED.
Comment 16 Fedora Update System 2011-10-29 02:31:10 EDT
kdepimlibs-4.7.2-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.