Bug 766333 - Rebase Samba4 libraries to pick up functionality required for IdM
Rebase Samba4 libraries to pick up functionality required for IdM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba4 (Show other bugs)
6.0
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
Namita Soman
: Rebase
Depends On: 766334 766335 766336 767672
Blocks: 791327 840699
  Show dependency treegraph
 
Reported: 2011-12-11 13:20 EST by Dmitri Pal
Modified: 2013-02-21 03:45 EST (History)
7 users (show)

See Also:
Fixed In Version: samba4-4.0.0-24.el6.rc1
Doc Type: Release Note
Doc Text:
Updated samba4 Libraries Provide Cross Realm Kerberos Trust Functionality The samba4 libraries (provided by the samba4-libs package) have been upgraded to the latest upstream version to improve the interoperability with Active Directory (AD) domains. SSSD now uses the libndr-krb5pac library to parse the Privilege Attribute Certificate (PAC) issued by an AD Key Distribution Center (KDC). The Cross Realm Kerberos Trust functionality provided by Identity Management, which relies on the capabilities of the samba4 client library, is included as a Technology Preview. This functionality uses the libndr-nbt library to prepare Connection-less Lightweight Directory Access Protocol (CLDAP) messages. Additionally, various improvements have been made to the Local Security Authority (LSA) and Net Logon services to allow verification of trust from a Windows system. Because the Cross Realm Kerberos Trust functionality is considered a Technology Preview, selected samba4 components are considered to be a Technology Preview. For more information on which Samba packages are considered a Technology Preview, refer to Table 5.1, “Samba4 Package Support ”. Table 5.1. Samba4 Package Support Package Name New Package in 6.4? Support Status samba4-libs No Technology Preview, except functionality required by OpenChange samba4-pidl No Technology Preview, except functionality required by OpenChange samba4 No Technology Preview samba4-client Yes Technology Preview samba4-common Yes Technology Preview samba4-python Yes Technology Preview samba4-winbind Yes Technology Preview samba4-dc Yes Technology Preview samba4-dc-libs Yes Technology Preview samba4-swat Yes Technology Preview samba4-test Yes Technology Preview samba4-winbind-clients Yes Technology Preview samba4-winbind-krb5-locator Yes Technology Preview
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:45:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2011-12-11 13:20:12 EST
Cross Realm Kerberos Trust functionality relies on the capabilities of the samba4 client library. Rebasing samba4 package to include the functionality we have been developing upstream for a year is a dependency for the IdM in RHEL6.3
Comment 2 Suzanne Yeghiayan 2012-01-31 16:17:54 EST
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.
Comment 4 RHEL Product and Program Management 2012-07-10 03:49:56 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:54:01 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 10 Andreas Schneider 2012-09-24 12:44:42 EDT
There are package changes in Samba4:

ldb-tools, libldb and libldb-devel are standalone packages now (see #859229).

There are several new subpackages, the layout tries to match the samba packages so you we can conflict correctly. Most of them will be unsupported.

Packages required by openchange (we support only the required functionality):
samba4-libs
samba4-pidl

Packages required by freeipa (we support only the required functionality):
samba4
samba4-libs
samba4-common               (NEW)
samba4-python               (NEW)
samba4-winbind              (NEW)

The following packages are new but unsupported (tech preview only):
samba4-client               (NEW)
samba4-dc                   (NEW)
samba4-dc-libs              (NEW)
samba4-swat                 (NEW)
samba4-test                 (NEW)
samba4-winbind-clients      (NEW)
samba4-winbind-krb5-locator (NEW)
Comment 11 Andreas Schneider 2012-09-24 12:50:17 EDT
UPDATE!!!

There are package changes in Samba4:

ldb-tools, libldb and libldb-devel are standalone packages now (see #859229).

There are several new subpackages, the layout tries to match the samba packages so you we can conflict correctly. Most of them will be unsupported.

Packages required by openchange (we support only the required functionality):
samba4-libs
samba4-pidl

Packages required by freeipa (we support only the required functionality):
samba4
samba4-client               (NEW)
samba4-libs
samba4-common               (NEW)
samba4-python               (NEW)
samba4-winbind              (NEW)

The following packages are new but unsupported (tech preview only):
samba4-dc                   (NEW)
samba4-dc-libs              (NEW)
samba4-swat                 (NEW)
samba4-test                 (NEW)
samba4-winbind-clients      (NEW)
samba4-winbind-krb5-locator (NEW)
Comment 15 Namita Soman 2012-11-30 15:05:02 EST
# rpm -qa | grep samba
samba4-swat-4.0.0-46.el6.rc4.x86_64
samba4-4.0.0-46.el6.rc4.x86_64
samba4-dc-libs-4.0.0-46.el6.rc4.x86_64
samba4-libs-4.0.0-46.el6.rc4.x86_64
samba4-client-4.0.0-46.el6.rc4.x86_64
samba4-python-4.0.0-46.el6.rc4.x86_64
samba4-dc-4.0.0-46.el6.rc4.x86_64
samba4-winbind-krb5-locator-4.0.0-46.el6.rc4.x86_64
samba4-winbind-4.0.0-46.el6.rc4.x86_64
samba4-test-4.0.0-46.el6.rc4.x86_64
samba4-common-4.0.0-46.el6.rc4.x86_64
samba4-winbind-clients-4.0.0-46.el6.rc4.x86_64


# rpm -qi samba4-libs
Name        : samba4-libs                  Relocations: (not relocatable)
Version     : 4.0.0                             Vendor: Red Hat, Inc.
Release     : 46.el6.rc4                    Build Date: Thu 15 Nov 2012 12:26:16 PM EST
Install Date: Thu 29 Nov 2012 10:38:12 AM EST      Build Host: x86-023.build.eng.bos.redhat.com
Group       : Applications/System           Source RPM: samba4-4.0.0-46.el6.rc4.src.rpm
Size        : 16558690                         License: GPLv3+ and LGPLv3+
Signature   : RSA/8, Mon 19 Nov 2012 01:01:34 PM EST, Key ID 938a80caf21541eb
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.samba.org/
Summary     : Samba libraries
Description :
The samba4-libs package contains the libraries needed by programs that
link against the SMB, RPC and other protocols provided by the Samba suite.
Comment 17 errata-xmlrpc 2013-02-21 03:45:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0506.html

Note You need to log in before you can comment on or make changes to this bug.