Bug 79829 - 'logout' takes ages to work
'logout' takes ages to work
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-session (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
: 75163 80859 81533 82362 (view as bug list)
Depends On: 84291
Blocks: 79578
  Show dependency treegraph
 
Reported: 2002-12-17 03:52 EST by Tim Waugh
Modified: 2007-04-18 12:49 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 17:53:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages before logout screen appears (9.85 KB, text/plain)
2003-02-14 07:14 EST, Stefan Schwandter
no flags Details
messages after logout (19.45 KB, text/plain)
2003-02-14 07:16 EST, Stefan Schwandter
no flags Details

  None (edit)
Description Tim Waugh 2002-12-17 03:52:51 EST
Description of problem:
After selecting 'logout' from the menu, it takes about a minute, and sometimes
longer, before the confirmation dialog appears.

Version-Release number of selected component (if applicable):
gnome-session-2.1.2-2
gnome-panel-2.1.4-2
redhat-menus-0.30-1

How reproducible:
Happens every time.
Comment 1 Havoc Pennington 2002-12-17 13:35:35 EST
Do you have any apps open?
Comment 2 Tim Waugh 2002-12-17 13:38:54 EST
No.
Comment 3 Havoc Pennington 2003-01-02 16:04:05 EST
*** Bug 80859 has been marked as a duplicate of this bug. ***
Comment 4 Havoc Pennington 2003-01-02 16:52:23 EST
*** Bug 80968 has been marked as a duplicate of this bug. ***
Comment 5 Miloslav Trmac 2003-01-04 12:18:01 EST
Happened again on RHL 8.0. I logged in at a VT and ran 'killall kdeinit'. The logout at X immediately finished then.
Comment 6 Havoc Pennington 2003-01-09 23:41:21 EST
*** Bug 81533 has been marked as a duplicate of this bug. ***
Comment 7 Michal Jaegermann 2003-01-17 18:39:17 EST
> it takes about a minute

When I managed to logout, eventually, it took me over five minutes
to logout which took me quite by surprise.  I was already convinced
that nothing will happen.  I repeated that experiment twice in a row
with the same results.

BTW - this bug seems to be really quite different than bug 80968
and independent.  See more information there.
Comment 8 Havoc Pennington 2003-01-20 12:19:38 EST
Can people report on results with gnome-session 2.1.90 and other new packages
from the latest beta?
Comment 9 Tim Waugh 2003-01-20 12:34:10 EST
I haven't seen this problem in a while.
Comment 10 Marius Andreiana 2003-01-31 06:55:40 EST
With a clean install of phoebe2, this happened today to me ( tried logout
several times, it won't work ). I couldn't replicate it. Any more info I could
provide?
Comment 11 Havoc Pennington 2003-01-31 10:37:06 EST
All I can think of is that it's related to which apps are running, or bugs in
those apps.
Comment 12 Marius Andreiana 2003-01-31 10:57:29 EST
couldn't gnome-session simply kill the apps which don't respond in several
seconds? getting the logout dialog is more important than saving current session.
Comment 13 Havoc Pennington 2003-01-31 11:30:36 EST
It could/is supposed to, there is probably something more complicated going on.
Comment 14 John J. Germs 2003-01-31 21:07:00 EST
I have had this in Gnome a total of five times now ...
It generally happens when I log in and decided to log
out within somewhere around 30 - 60 seconds of
logging in. 
This is after It appears to have completely logged in.
(ie. the splash screen is gone, the desktop icons are
visible and the taskbar is drawn)
When this happens it will sit for about  2-3 minutes
before the logout prompt shows up...  You either wait
or do a CTRL-ALT-BCKSPCE.
I'm not sure ... maybe there is a process hanging or
something. 
Not sure if it'll work, but next time it happens I'm gonna try
to go to another virtual console .. login real quick and run
'top' ... maybe I can see if a process vanishes from the list??
Just a thought..
   
Comment 15 Larry Troan 2003-02-02 22:41:59 EST
FROM ISSUE TRACKER 13277 -- severity 4
this still happens with beta 4.
Comment 16 Havoc Pennington 2003-02-02 23:56:26 EST
Larry: does issue tracker reporter give some reliable way to reproduce the 
problem? Please ask them how they are testing.
Comment 17 Havoc Pennington 2003-02-05 18:18:49 EST
Possible clue: http://bugzilla.gnome.org/show_bug.cgi?id=105338
Comment 18 Bill Nottingham 2003-02-11 00:12:38 EST
*** Bug 75163 has been marked as a duplicate of this bug. ***
Comment 19 Marius Andreiana 2003-02-12 09:42:43 EST
Havoc, any info we could provide when it happens which might help debugging this?

About being related to the apps running, when I logout I usually have open the
apps which are started by gnome session, no other strange programs. When the
logout didn't worked I closed all of them, but it still didn't work (
gnome-panel and applets still running though ).
Comment 20 Havoc Pennington 2003-02-12 13:31:52 EST
I think I'm just going to have to debug it; hopefully I can get the problem to
happen, if I can, I should be able to debug it OK. If not, it'll be hard to figure
out a fix.
Comment 21 Havoc Pennington 2003-02-12 13:43:54 EST
*** Bug 82362 has been marked as a duplicate of this bug. ***
Comment 22 Havoc Pennington 2003-02-13 17:13:52 EST
In simple attempts (log in, log out) I'm not seeing this happen, unfortunately.
No one has any reliable way to reproduce?

There is a "GSM_VERBOSE_DEBUG" env variable that can be set prior to running
gnome-session, perhaps add "GSM_VERBOSE_DEBUG=1 exec gnome-session" to 
.Xclients, chmod +x .Xclients, then log in as session "Default"
I'm not sure the verbose mode is that helpful but perhaps it would be.
Comment 23 Stefan Schwandter 2003-02-14 07:14:27 EST
Created attachment 90085 [details]
messages before logout screen appears
Comment 24 Stefan Schwandter 2003-02-14 07:16:18 EST
Created attachment 90086 [details]
messages after logout
Comment 25 Stefan Schwandter 2003-02-14 07:21:04 EST
I think I should add that I use redhat 8.0, not rawhide or phoebe. but it looks
like the same bug, so I hope the files are helpful...
Comment 26 Larry Troan 2003-02-14 08:31:51 EST
NOTE FROM HP....
fixed in gingin prebeta5.
CLOSED ISSUE TRACKER 13277.
Comment 27 Alexander Larsson 2003-02-19 15:32:03 EST
hp: This is fixed? If so we should close this bug.
Comment 28 Gene Czarcinski 2003-02-19 15:52:22 EST
I do not see this as originally reported.

I do see that logout "hangs" (not the confirmation) for a long time (usually
longer than I want to wait and I alt-ctl-backspace).  This happens when I have
been logged on for a long time.  If I login, wait for all applications etc to
start and then logout, it works fine.

SHould I put this in as another (different) report.  This occurs on 8.0.94.
Comment 29 Havoc Pennington 2003-02-19 16:09:14 EST
I don't really know if it's fixed, as I've never been able to reproduce it anyhow.
#84291 was just one theory I had.
Comment 30 Alexander Larsson 2003-02-20 10:54:32 EST

Hmm. I have seen this before, but not after upgrading gnome-panel and
gnome-applets. So it might indeed be fixed.
Comment 31 Havoc Pennington 2003-02-20 15:03:46 EST
Let's assume fixed pending reports otherwise.
Comment 32 Havoc Pennington 2003-02-21 18:30:55 EST
We have now reproduced slow logout as follows:

 - start xmms
 - log out saving session 
 - log in
 - "gnome-session-save --gui" or log out

If other people were or were not running xmms that would be helpful 
confirmation. Investigating the issue now. (xmms wasn't necessarily 
running, but if you had it in your ~/.gnome2/session maybe that would 
be enough)
Comment 33 Marius Andreiana 2003-02-24 06:56:04 EST
I am running xmms all the time and noticed this bug
Comment 34 Alexander Larsson 2003-02-25 06:10:28 EST
I reproduced this again. And that machine never ran xmms.
Comment 35 Need Real Name 2003-02-26 16:23:07 EST
i've been seeing the same problem and if i bail out quickly with
ctrl-alt-backspace, there will be a vestigial /usr/libexec/gconfd-2 process left
over that will stick around for a few minutes and then go away.  looks like this
is the culprit that's clogging the works when trying to log out. 
Comment 36 Havoc Pennington 2003-02-26 18:19:57 EST
No, gconfd isn't related to logout; it's not connected to the session manager or
the login session in any way, that's why it persists. It simply exits 2 minutes
after all applications a user is running anywhere stop using it. So if 
all your apps exit gconfd will exit shortly thereafter. But if you're logged 
in twice, you have to log out of both sessions before gconfd will exit.
Comment 37 Kostas Zorbadelos 2003-03-08 07:33:51 EST
I reproduce the logout problem in the following way. I have standard Redhat
Linux 8.0 (with applied erradata from Redhat).
I login from gdm. Everything starts nicely. When everything has started I try to
logout (that is logout is the first thing I do). No logout dialog appears for a
while. If I start the control-center (from the menu Preferences | Control
center) the logout dialog appears immediately. I agree that it was waiting for
something. If I cancel, the behaviour of logout is restored to normal.
I hope this helps.
Comment 38 Kostas Zorbadelos 2003-03-08 09:58:53 EST
I just want to add that I can "wake" the logout dialog not only with the control
center but with most items of the preferences menu, and other non-gnome
applications (like for example the tora database tool based on Qt).
I find that very confusing...
Comment 39 Stefan Schwandter 2003-03-10 13:07:24 EST
I've found a way to reproduce the bug: I only have to add some app to the
"Additional startup programs", then I logout.

login

immediately logout 
-> stalled

I can make the logout screen appear immediately by selecting an item in the
preferences menu, as someone else has said before.

but: I've encountered the bug before I've tried adding programs to the
additional startup programs, so there apparently are other possibities to
trigger the bug...

but maybe the bug has something to do with saving the session when non-gnome
apps are running?
Comment 40 Stefan Schwandter 2003-03-10 13:18:36 EST
ok, immediately after having written the last entry, I tried out the other
"variant" of this bug:

having xmms running and saving the session

after the next login I again had to wait for the logout. but the "preferences"
menu trick didn't work then.

I closed xmms.

still no logout

then I looked into the running programs in "current session" - and xmms was
still there! removed xmms from the session, pressed apply -> the logout screen
appeared

I'm going to try to find other apps that cause this behaviour. 
Comment 41 David Kaplan 2003-04-02 20:27:12 EST
I have the same problem and it was caused by fooling around with my startup
applications.  Did anyone ever find a way to fix this problem?  It is really a drag.
Comment 42 Havoc Pennington 2003-04-02 20:56:25 EST
The generic fix is probably to shorten the timeout, but at some point it's short
enough that apps could be killed instead of saved when they were legitimately 
still busy saving.

Another option might be to provide some kind of progress indicator for which 
app is being saved currently so you can know which app to blame.

Anyhow, short of those things it's just a matter of fixing specific apps.
Comment 43 Stefan Schwandter 2003-04-03 04:28:34 EST
in my experience, this bug only shows up when you try to save a session
consisting of apps that metacity recognizes as not session management aware, but
that are in spite of that restarted on the next login. examples seem to be xmms,
gkrellm.

or if you add startup applications.

the fix can't be "make all apps session management aware", can it?
Comment 44 Havoc Pennington 2003-04-03 10:20:41 EST
If they aren't SM-aware at all the session manager should (and I think does) 
ignore them so there's no problem. The problem is something like xmms was:
session aware but _broken_. I fixed xmms. I don't know how many other apps 
out there try to do SM but fail.

If you add something as a "startup program" I wonder if the session manager does 
something really silly and just adds the app as if it were session aware, 
if so that would break.
Comment 45 Bill Nottingham 2003-07-28 17:53:17 EDT
Closing some bugs that have been in MODIFIED for a while. Please reopen if the
problem persists.
Comment 46 Stefan Schwandter 2003-09-09 02:44:46 EDT
I have found another app that makes "logout take ages to work". it's gkrellm. on
severn.

Note You need to log in before you can comment on or make changes to this bug.