Bug 798517 - sudo fails with unknown symbol
sudo fails with unknown symbol
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sudo (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Daniel Kopeček
Fedora Extras Quality Assurance
:
: 798579 798663 798722 798802 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 01:31 EST by Rudd-O DragonFear
Modified: 2012-03-01 20:16 EST (History)
7 users (show)

See Also:
Fixed In Version: sudo-1.8.3p1-6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 05:07:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudd-O DragonFear 2012-02-29 01:31:56 EST
Description of problem:

/@karen.dragonfear 
Comment 1 Anton Arapov 2012-02-29 02:30:31 EST
After the update to:
 sudo       x86_64     1.8.3p1-5.fc17        updates-testing     552 k
$ sudo -i
sudo: unable to dlopen /usr/libexec/sudoers.so: /usr/libexec/sudoers.so: undefined symbol: sss_sudo_sudo_free_result

And roll back (Downgrading):
 sudo       x86_64     1.8.3p1-4.fc17        fedora             552 k
# sudo ls
anaconda-ks.cfg  grouplist  install.log  install.log.syslog

works like a charm... sssd info:
# rpm -qa | grep sss
sssd-client-1.8.0-5.fc17.beta3.1.x86_64
libsss_sudo-1.8.0-5.fc17.beta3.1.x86_64
sssd-1.8.0-5.fc17.beta3.1.x86_64
docbook-style-dsssl-1.79-13.fc17.noarch
Comment 2 Rudd-O DragonFear 2012-02-29 03:09:56 EST
I confirm downgrade to p1-4 fixes on my computer.  p1-5, according to koji, is a patch to sssd.
Comment 3 Fedora Update System 2012-02-29 04:32:41 EST
sudo-1.8.3p1-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/sudo-1.8.3p1-6.fc17
Comment 4 Rudd-O DragonFear 2012-02-29 05:06:24 EST
the updates do not show this submission yet.
Comment 5 Rudd-O DragonFear 2012-02-29 05:07:55 EST
This fixed the bug, downloaded directly from bodhi.
Comment 6 Daniel Kopeček 2012-02-29 05:13:55 EST
*** Bug 798579 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Kopeček 2012-02-29 09:58:32 EST
*** Bug 798663 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2012-02-29 11:33:47 EST
*** Bug 798722 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Kopeček 2012-03-01 02:03:54 EST
*** Bug 798802 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-03-01 20:16:29 EST
sudo-1.8.3p1-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.