Bug 80416 - rhythmbox fails to play audio files
rhythmbox fails to play audio files
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 81216 (view as bug list)
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-12-25 20:29 EST by Mark Cooke
Modified: 2016-11-24 10:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 19:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-12-25 20:29:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Trying to play either mp3 (with is probally disabled) or ogg's with rhythmbox
doesn't output any sound.

All the menu items work and other icons and options, but clicking on play fails
to play the selected music and the time elapsed bar fails to move as well.

Running it with the '-d' option for debugging, fails to produce any useful output.

These files work fine in nautilus with the mouse over and also in xmms.

All volumes is turned up and esd enabled

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open rhythmbox and choose Organise | Add to Library
2. Select files/files
3. Hit play and nothing happens
    

Actual Results:  nothing
(sorry but no usefull debugging info)

Expected Results:  Play selected files

Additional info:
Comment 1 Bill Nottingham 2002-12-31 00:36:29 EST
Running it with LD_ASSUME_KERNEL=2.2.5 set should work. This is an issue with
NPTL, as I recall.
Comment 2 Mark Cooke 2003-01-02 13:48:05 EST
Adding LD_ASSUME_KERNEL=2.2.5 before running rhythmbox now starts playing the
song (i.e the slider bar and time playing now moves), 
but sound still fails to come out.
I have enabled esd and turned up the volume for psm in gnome-volume-control.

If I open the same song with xmms, it plays perfectly.
This is an ogg format song encoded to 320 kb/s
Comment 3 George Karabin 2003-01-03 17:50:59 EST
I get sound out on my box when I pick up the LD_ASSUME_KERNEL=2.2.5 variable. If
this can't be fixed upstream in time for release, an easy hack workaround for
the gnome panel was to replace rhythmbox with a shell script that sets the
variable before running it. (An obvious hack, but I thought it was better to
mention it than not).
Comment 4 Bill Nottingham 2003-01-06 17:56:13 EST
*** Bug 81216 has been marked as a duplicate of this bug. ***
Comment 6 Warren Togami 2003-02-04 00:09:19 EST
rhythmbox was removed from Rawhide recently right?
Comment 7 Bill Nottingham 2003-02-10 23:45:45 EST
Yes, but we'd still like it to work. ;)
Comment 8 Ulrich Drepper 2003-04-17 13:45:12 EDT
Try with glibc 2.3.2-27.9.  I think I remember there were some issues with
condvars in this package.  This glibc version has a condvar implementation which
should work fine.
Comment 9 Jonathan Blandford 2003-07-30 19:29:41 EDT
Rythmbox has been forked twice since this bug, and gstreamer has been reved a
number of versions.  We also don't ship it. Closing.
Comment 10 George Karabin 2003-07-30 19:49:37 EDT
While gstreamer has revved, it's not yet in Severn or Rawhide. FWIW, I added an
RFE in Bug #101342 for gstreamer 0.6.2 just now.


Note You need to log in before you can comment on or make changes to this bug.