Bug 804216 - pungi doesn't use yum transactions, which is a problem with langpacks
Summary: pungi doesn't use yum transactions, which is a problem with langpacks
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs
: 803255 803257 (view as bug list)
Depends On: 813429 816315
Blocks: F17Blocker, F17FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2012-03-16 20:39 UTC by Bill Nottingham
Modified: 2014-03-17 03:30 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-05-01 19:20:34 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2012-03-16 20:39:52 UTC
(This isn't a "bug" as much as "a problem we need a solution for.")

pungi assembles its package set without actually using a yum transaction. In general, this is fine. However, in F-17 and derived distributions, we've dropped all the conditional langpack packages from comps, and rely on the yum-langpacks plugin to pull them in.

pungi, because of this change to comps, no longer pulls in any of them.

Options include:
- explicitly adding <blah>-* to pungi kickstarts (ick)
- working langpacks into pungi somehow
- your idea here

Comment 1 Bill Nottingham 2012-04-11 19:46:22 UTC
Just to be clear, the impact of this is likely that most langpacks aren't going to be on the install DVD.

Comment 2 Bill Nottingham 2012-04-11 20:08:20 UTC
*** Bug 803255 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2012-04-11 20:08:37 UTC
*** Bug 803257 has been marked as a duplicate of this bug. ***

Comment 4 Adam Williamson 2012-04-11 20:09:46 UTC
Nominating as a Beta blocker, we can argue whether this makes the system sufficiently broken if you don't speak English. The 'langpacks' that are missing apparently include at least man-pages translations, libreoffice translations, KDE desktop translations and hunspell translations. Bill says that yum doesn't install the missing translations on first update because it only does it at install time, not update time. I'm going to confirm the impact of this, but AIUI, it basically means if you say, do, a KDE install from the DVD in, oh, French or something, your desktop, libreoffice, and man pages will all be in English. We don't really have criteria that this hits; we only require all critical path actions be translated, at Final time. You could only argue it's a conditional breakage of the 'usable desktop' criterion in the case that you don't speak English, but that's something of a stretch. My instinct is -1 beta blocker, but...





-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Ben Williams 2012-04-11 20:19:16 UTC
i dont see this as a beta blocker but +1 as a final blocker

Comment 6 Dennis Gilmore 2012-04-11 20:22:58 UTC
-1 to this being a beta blocker

Comment 7 Bill Nottingham 2012-04-11 20:32:00 UTC
I'd be -1 beta +1 final.

Comment 8 Tim Flink 2012-04-11 21:03:03 UTC
If there is a way to install the langpacks after the initial install, I'm -1 beta blocker, +1 final blocker

Comment 9 Kamil Páral 2012-04-12 08:46:37 UTC
Meeting minutes says this has been rejected for Beta [1]. Changing to Final blocker and adding CommonBugs.

[1] http://meetbot.fedoraproject.org/fedora-meeting-1/2012-04-11/f17_beta_go_no_go_meeting.2012-04-11-21.00.html

Comment 10 Bill Nottingham 2012-04-17 15:13:51 UTC
Added explicit langpack wildcards to fedora-install-fedora.ks.  Will work on the l10n kickstarts next.

Comment 11 Adam Williamson 2012-04-20 20:49:48 UTC
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Accepted as a blocker per final criterion "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use".

Comment 12 Bill Nottingham 2012-04-25 19:40:31 UTC
(In reply to comment #10)
> Added explicit langpack wildcards to fedora-install-fedora.ks.

This got broken by bug 816315 (if we're using that version to compose.)

> Will work on the l10n kickstarts next.

Fixed with a livecd-tools change, and updating the docs in spin-kickstarts.

Comment 13 Dennis Gilmore 2012-05-01 19:20:34 UTC
fixed in comps


Note You need to log in before you can comment on or make changes to this bug.