This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 804216 - pungi doesn't use yum transactions, which is a problem with langpacks
pungi doesn't use yum transactions, which is a problem with langpacks
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 803255 803257 (view as bug list)
Depends On: 813429 816315
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-03-16 16:39 EDT by Bill Nottingham
Modified: 2014-03-16 23:30 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-01 15:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-03-16 16:39:52 EDT
(This isn't a "bug" as much as "a problem we need a solution for.")

pungi assembles its package set without actually using a yum transaction. In general, this is fine. However, in F-17 and derived distributions, we've dropped all the conditional langpack packages from comps, and rely on the yum-langpacks plugin to pull them in.

pungi, because of this change to comps, no longer pulls in any of them.

Options include:
- explicitly adding <blah>-* to pungi kickstarts (ick)
- working langpacks into pungi somehow
- your idea here
Comment 1 Bill Nottingham 2012-04-11 15:46:22 EDT
Just to be clear, the impact of this is likely that most langpacks aren't going to be on the install DVD.
Comment 2 Bill Nottingham 2012-04-11 16:08:20 EDT
*** Bug 803255 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2012-04-11 16:08:37 EDT
*** Bug 803257 has been marked as a duplicate of this bug. ***
Comment 4 Adam Williamson 2012-04-11 16:09:46 EDT
Nominating as a Beta blocker, we can argue whether this makes the system sufficiently broken if you don't speak English. The 'langpacks' that are missing apparently include at least man-pages translations, libreoffice translations, KDE desktop translations and hunspell translations. Bill says that yum doesn't install the missing translations on first update because it only does it at install time, not update time. I'm going to confirm the impact of this, but AIUI, it basically means if you say, do, a KDE install from the DVD in, oh, French or something, your desktop, libreoffice, and man pages will all be in English. We don't really have criteria that this hits; we only require all critical path actions be translated, at Final time. You could only argue it's a conditional breakage of the 'usable desktop' criterion in the case that you don't speak English, but that's something of a stretch. My instinct is -1 beta blocker, but...





-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Ben Williams 2012-04-11 16:19:16 EDT
i dont see this as a beta blocker but +1 as a final blocker
Comment 6 Dennis Gilmore 2012-04-11 16:22:58 EDT
-1 to this being a beta blocker
Comment 7 Bill Nottingham 2012-04-11 16:32:00 EDT
I'd be -1 beta +1 final.
Comment 8 Tim Flink 2012-04-11 17:03:03 EDT
If there is a way to install the langpacks after the initial install, I'm -1 beta blocker, +1 final blocker
Comment 9 Kamil Páral 2012-04-12 04:46:37 EDT
Meeting minutes says this has been rejected for Beta [1]. Changing to Final blocker and adding CommonBugs.

[1] http://meetbot.fedoraproject.org/fedora-meeting-1/2012-04-11/f17_beta_go_no_go_meeting.2012-04-11-21.00.html
Comment 10 Bill Nottingham 2012-04-17 11:13:51 EDT
Added explicit langpack wildcards to fedora-install-fedora.ks.  Will work on the l10n kickstarts next.
Comment 11 Adam Williamson 2012-04-20 16:49:48 EDT
Discussed at 2012-04-20 blocker review meeting - http://meetbot.fedoraproject.org/fedora-bugzappers/2012-04-20/fedora-bugzappers.2012-04-20-17.01.log.txt . Accepted as a blocker per final criterion "All critical path actions on release-blocking desktop environments should correctly display all sufficiently complete translations available for use".
Comment 12 Bill Nottingham 2012-04-25 15:40:31 EDT
(In reply to comment #10)
> Added explicit langpack wildcards to fedora-install-fedora.ks.

This got broken by bug 816315 (if we're using that version to compose.)

> Will work on the l10n kickstarts next.

Fixed with a livecd-tools change, and updating the docs in spin-kickstarts.
Comment 13 Dennis Gilmore 2012-05-01 15:20:34 EDT
fixed in comps

Note You need to log in before you can comment on or make changes to this bug.