Bug 804742 - Please update Remmina in f17
Please update Remmina in f17
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
: 806997 813907 813968 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 13:43 EDT by Mads Kiilerich
Modified: 2012-04-25 01:08 EDT (History)
7 users (show)

See Also:
Fixed In Version: remmina-1.0.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-25 01:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2012-03-19 13:43:51 EDT
FreeRDP is eager to be updated, but there is an API change that requires Remmina to be updated too.

EPEL without Remmina dependency has already been updated (bug 790855).

http://autoqa.fedoraproject.org/results/306246-autotest/virt06.qa/depcheck/results/freerdp-1.0.1-5.fc17.html
Comment 1 Christoph Wickert 2012-03-19 16:56:49 EDT
Thanks for the reminder. Unfortunately I am currently traveling and very busy. Would you like to do the update? If so, just apply for commit access in packagedb and I will grant it.
Comment 2 Mads Kiilerich 2012-03-19 22:35:20 EDT
Hmm. I have never tried remmina and would rather stay clear of it.

But with freerdp in buildoverride I made the scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=3911748

Many major changes are necessary, so I would not just commit it even if I could. Please fetch the srpm and review the changes carefully.

The biggest change is that the plugins now apparently are bundled with remmina itself, so the most obvious solution would be to merge the two packages again...
Comment 3 Christoph Wickert 2012-04-13 15:14:41 EDT
(In reply to comment #2)
> Many major changes are necessary, so I would not just commit it even if I
> could. Please fetch the srpm and review the changes carefully.

Sorry Mads, do you still have the srpm available somewhere? I am stuck with a DSO linkage problem. How did you fix it? The cmake files in 1.0.0 don't know linker flags.
Comment 4 Morten Kramer 2012-04-13 15:29:00 EDT
I compiled Remmina from source a while ago under Fedora16


needed to add

-lgcrypt -lglib-2.0 -lpango-1.0 -lcairo -latk-1.0 -lssh -lgcrypt -lX11 -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lpthread

to remmina/CMakeFiles/remmina.dir/link.txt


for Remmina to compile.


Hope this helps.
Comment 6 Christoph Wickert 2012-04-13 19:46:13 EDT
*** Bug 806997 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Wickert 2012-04-18 14:15:14 EDT
*** Bug 813907 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Wickert 2012-04-18 19:55:10 EDT
*** Bug 813968 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2012-04-22 19:27:29 EDT
remmina-1.0.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/remmina-1.0.0-1.fc17
Comment 10 Fedora Update System 2012-04-22 21:24:02 EDT
Package remmina-1.0.0-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing remmina-1.0.0-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6440/remmina-1.0.0-1.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-04-25 01:08:51 EDT
remmina-1.0.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.