Bug 806586 - iwl4965: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/include/net/mac80211.h:3618 rate_control_send_low+0x23e/0x250 [mac80211]()
iwl4965: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:9773e484892465b130b23d969cc...
:
: 806608 807799 808613 809593 828613 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 23:25 EDT by matszyeung
Modified: 2012-10-05 08:29 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 08:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matszyeung 2012-03-24 23:25:59 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.2.10-3.fc16.x86_64 root=UUID=8b159375-e195-4175-8e1c-f5acd7583f52 ro rd.md=0 rd.lvm=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8
event_log:      2012-03-25-11:24:31> Smolt profile successfully saved
kernel:         3.2.10-3.fc16.x86_64
reason:         WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/include/net/mac80211.h:3618 rate_control_send_low+0x23e/0x250 [mac80211]()
time:           Sunday, March 25, 2012 AM11:23:50 HKT

backtrace:
:WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/include/net/mac80211.h:3618 rate_control_send_low+0x23e/0x250 [mac80211]()
:Hardware name: HP Compaq 2510p Notebook PC
:Modules linked in: rfcomm bnep btusb bluetooth ppdev parport_pc lp parport fuse be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio fcoe ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables binfmt_misc arc4 snd_hda_codec_analog hp_accel lis3lv02d input_polldev snd_hda_intel snd_hda_codec snd_hwdep snd_seq iwl4965 snd_seq_device iwlegacy snd_pcm mac80211 cfg80211 hp_wmi e1000e snd_timer snd sparse_keymap soundcore snd_page_alloc joydev rfkill microcode iTCO_wdt serio_raw iTCO_vendor_support uinput firewire_ohci sdhci_pci sdhci firewire_core pata_acpi mmc_core crc_itu_t yenta_socket ata_generic wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1330, comm: Xorg Not tainted 3.2.10-3.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff8106e72f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106e78a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa023b4ce>] rate_control_send_low+0x23e/0x250 [mac80211]
: [<ffffffffa02f0895>] il4965_rs_get_rate+0x65/0x1c0 [iwl4965]
: [<ffffffffa023b85e>] rate_control_get_rate+0xae/0x180 [mac80211]
: [<ffffffffa024765f>] invoke_tx_handlers+0x6ff/0x13e0 [mac80211]
: [<ffffffff814c8e1d>] ? dev_alloc_skb+0x1d/0x40
: [<ffffffff81056d54>] ? check_preempt_curr+0x84/0xa0
: [<ffffffffa0226dcc>] ? sta_info_get+0x6c/0x80 [mac80211]
: [<ffffffff81056dad>] ? ttwu_do_wakeup+0x3d/0x120
: [<ffffffffa0248490>] ieee80211_tx+0x60/0xc0 [mac80211]
: [<ffffffffa0248571>] ieee80211_xmit+0x81/0xd0 [mac80211]
: [<ffffffffa024957f>] ieee80211_tx_skb_tid+0x5f/0x70 [mac80211]
: [<ffffffffa022df21>] ieee80211_send_bar+0xe1/0x100 [mac80211]
: [<ffffffffa022667e>] ieee80211_tx_status+0x8de/0xbe0 [mac80211]
: [<ffffffff812cc481>] ? list_del+0x11/0x40
: [<ffffffffa0224ee9>] ieee80211_tasklet_handler+0x179/0x180 [mac80211]
: [<ffffffffa02eadf0>] ? il4965_irq_tasklet+0x1e0/0x480 [iwl4965]
: [<ffffffff810756f8>] tasklet_action+0x78/0x140
: [<ffffffff81075d58>] __do_softirq+0xb8/0x230
: [<ffffffff810a1424>] ? tick_program_event+0x24/0x30
: [<ffffffff815eed2c>] call_softirq+0x1c/0x30
: [<ffffffff810162f5>] do_softirq+0x65/0xa0
: [<ffffffff8107616e>] irq_exit+0x9e/0xc0
: [<ffffffff815ef6ce>] smp_apic_timer_interrupt+0x6e/0x99
: [<ffffffff815ed59e>] apic_timer_interrupt+0x6e/0x80
: <EOI> 

smolt_data:
:
:
:General
:=================================
:UUID: 852d84f0-d0a5-4b65-8912-9c40fc32bc1b
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 2128.22
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     U7500  @ 1.06GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 1068
:System Memory: 1980
:System Swap: 1905
:Vendor: Hewlett-Packard
:System: HP Compaq 2510p Notebook PC F.0F
:Form factor: Notebook
:Kernel: 3.2.10-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10752:4156:12489) pci, agpgart-intel, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:10320:4156:12489) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10257:4156:12489) pci, None, PCI/ISA, 82801HBM (ICH8M-E) LPC Interface Controller
:(32902:4169:4156:12489) pci, e1000e, ETHERNET, 82566MM Gigabit Network Connection
:(4480:2082:4156:12489) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:(32902:9288:4156:12489) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10289:4156:12489) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:10288:4156:12489) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10290:4156:12489) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(4480:1142:4156:12489) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(32902:10294:4156:12489) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(32902:10298:4156:12489) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(4480:2098:4156:12489) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(32902:10754:4156:12489) pci, i915, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (primary)
:(32902:10755:4156:12489) pci, None, VIDEO, Mobile GM965/GL960 Integrated Graphics Controller (secondary)
:(32902:10303:0:0) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4156:12489) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10756:4156:12489) pci, None, SIMPLE, Mobile PM965/GM965 MEI Controller
:(32902:10759:4156:12489) pci, serial, 16550_SERIAL, Mobile PM965/GM965 KT Controller
:(32902:10758:4156:12489) pci, ata_generic, STORAGE, Mobile PM965/GM965 PT IDER Controller
:(32902:10292:4156:12489) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(32902:10293:4156:12489) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:(32902:10315:4156:12489) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:16937:32902:4096) pci, iwl4965, NETWORK, PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda5 / ext4 4096 4096 5613322 1168903 1112712 1409024 1267875 1267875
:
Comment 1 Dave Jones 2012-03-26 11:01:03 EDT
*** Bug 806608 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2012-03-26 11:01:45 EDT
different hardware, but similar trace to bug 786609. dupe ?
Comment 3 Stanislaw Gruszka 2012-03-27 02:52:41 EDT
Let's keep it separate.
Comment 4 Dave Jones 2012-03-28 15:51:17 EDT
*** Bug 807799 has been marked as a duplicate of this bug. ***
Comment 5 Dave Jones 2012-04-02 11:38:47 EDT
*** Bug 808613 has been marked as a duplicate of this bug. ***
Comment 6 Stanislaw Gruszka 2012-04-04 08:41:16 EDT
*** Bug 809593 has been marked as a duplicate of this bug. ***
Comment 7 Stanislaw Gruszka 2012-04-04 09:35:26 EDT
There are at lest two instances for this warning one is started at: ieee80211_send_bar(), second at: ieee80211_mgd_probe_ap_send(). Let's make this bug trace ieee80211_send_bar() and bug 786609 ieee80211_mgd_probe_ap_send() case.
Comment 8 Stanislaw Gruszka 2012-07-13 09:10:34 EDT
*** Bug 828613 has been marked as a duplicate of this bug. ***
Comment 9 Stanislaw Gruszka 2012-10-05 08:29:22 EDT
This must be fixed now.

Note You need to log in before you can comment on or make changes to this bug.