Bug 806632 - [abrt] yum-3.4.3-7.fc16: progress.py:271:_do_update:IOError: [Errno 5] Input/output error
[abrt] yum-3.4.3-7.fc16: progress.py:271:_do_update:IOError: [Errno 5] Input/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-urlgrabber (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
abrt_hash:8d5a76365663623223ad8952df0...
:
: 810637 811041 828141 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-25 10:32 EDT by jarodpt81
Modified: 2014-01-21 18:21 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 20:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jarodpt81 2012-03-25 10:32:25 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/yum update
executable:     /usr/bin/yum
kernel:         3.2.9-1.fc16.i686.PAE
reason:         progress.py:271:_do_update:IOError: [Errno 5] Input/output error
time:           Qui 08 Mar 2012 17:53:50 WET
uid:            0
username:       root

backtrace:
:progress.py:271:_do_update:IOError: [Errno 5] Input/output error
:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1695, in _progress_update
:    self.opts.progress_obj.update(downloaded)
:  File "/usr/share/yum-cli/output.py", line 74, in update
:    TextMeter.update(self, amount_read, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 141, in update
:    self._do_update(amount_read, now)
:  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 271, in _do_update
:    self.fo.flush()
:IOError: [Errno 5] Input/output error
:
:Local variables in innermost frame:
:ui_time: '     08:36'
:text: 'google-chrome-stable-17.0.963.78-125577.i386.rpm'
:fread: '2.5 M'
:ui_rate: '  69 kB/s'
:blen: 15
:ui_size: ' | 2.5 MB'
:out: 'google-chrome-stable-17.0  6% [=              ]  69 kB/s | 2.5 MB     08:36 ETA \r'
:self: <output.YumTextMeter instance at 0x87d968c>
:ui_bar: ' [=              ]'
:etime: 36.25198698043823
:tl: <urlgrabber.progress.TerminalLine instance at 0x9653a2c>
:ui_pc: '  6%'
:frtime: '08:36'
:amount_read: 2643830.0
:frac: 0.06733907682937766
:sofar_size: None
:now: 1331229230.622017
:ui_sofar_pc: ''
:rtime: 516.8717349286275
:bar: '='
:fetime: '00:36'
:ave_dl: '69 k'
:ui_end: ' ETA '

smolt_data:
:
:
:Geral
:=================================
:UUID: f4862e3f-52f1-45da-8c8d-cea662d001cb
:SO: Fedora release 16 (Verne)
:Nível de execução por omissão: Unknown
:Língua: pt_PT.utf8
:Plataforma: i686
:BogoMIPS: 4788.48
:Fabricante do CPU: GenuineIntel
:Modelo do CPU: Intel(R) Core(TM)2 Duo CPU     T8300  @ 2.40GHz
:Versão do CPU: 6
:Família do CPU: 6
:Número do modelo do CPU: 23
:Número de CPUs: 2
:Velocidade do CPU: 2401
:Memória do sistema: 3030
:Swap do sistema: 5087
:Fabricante: TOSHIBA
:Sistema: Satellite A200 PSAE6E-0D5015PT
:Dimensões: Notebook
:Kernel: 3.3.0-4.fc16.i686.PAE
:SELinux activo: 1
:Política do SELinux: targeted
:SELinux Obrigatório: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(32902:10752:4473:65280) pci, None, HOST/PCI, Mobile PM965/GM965/GL960 Memory Controller Hub
:(32902:10753:4473:65280) pci, pcieport, PCI/PCI, Mobile PM965/GM965/GL960 PCI Express Root Port
:(4332:33078:4473:65280) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(32902:10302:4473:65280) pci, None, SERIAL, 82801H (ICH8 Family) SMBus Controller
:(32902:10281:4473:65280) pci, ahci, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller
:(32902:10320:4473:65280) pci, ata_piix, STORAGE, 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller
:(32902:10261:4473:65280) pci, None, PCI/ISA, 82801HEM (ICH8M) LPC Interface Controller
:(32902:9288:4473:65280) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10289:4473:65280) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #2
:(32902:10288:4473:65280) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #1
:(32902:10290:4473:65280) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #3
:(32902:10294:4473:65280) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #1
:(32902:10298:4473:65280) pci, ehci_hcd, USB, 82801H (ICH8 Family) USB2 EHCI Controller #2
:(32902:10307:4473:65280) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 3
:(32902:10309:4473:65280) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 4
:(32902:10303:4473:65280) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 1
:(32902:10305:4473:65280) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 2
:(32902:10311:4473:65280) pci, pcieport, PCI/PCI, 82801H (ICH8 Family) PCI Express Port 5
:(32902:10315:4473:65280) pci, snd_hda_intel, MULTIMEDIA, 82801H (ICH8 Family) HD Audio Controller
:(32902:17486:32902:17486) pci, None, MEMORY, Turbo Memory Controller
:(32902:10292:4473:65280) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #4
:(4172:32827:4473:65282) pci, tifm_7xx1, STORAGE, 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
:(32902:10293:4473:65280) pci, uhci_hcd, USB, 82801H (ICH8 Family) USB UHCI Controller #5
:(4098:43528:4098:43528) pci, snd_hda_intel, MULTIMEDIA, RV630/M76 audio device [Radeon HD 2600 Series]
:(4098:38273:4473:65280) pci, radeon, VIDEO, M76 [Radeon Mobility HD 2600 Series]
:(4172:32828:4473:65282) pci, sdhci-pci, BASE, PCIxx12 SDA Standard Compliant SD Host Controller
:(32902:16937:32902:4353) pci, iwl4965, NETWORK, PRO/Wireless 4965 AG or AGN
:(4172:32826:4473:65280) pci, firewire_ohci, FIREWIRE, PCIxx12 OHCI Compliant IEEE 1394 Host Controller
:(4172:32825:4473:65280) pci, yenta_cardbus, PCI/CARDBUS, PCIxx12 Cardbus Controller
:
:
:Informação do sistema de ficheiros
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_fedorento-lv_root / ext4 4096 4096 9523457 7638574 7543249 2383872 2211092 2211092
:/dev/sda4 WITHHELD fuseblk 4096 4096 34834687 6567107 6567107 26333964 26322769 26322769
:/dev/sda5 /boot ext4 1024 1024 508745 342960 317360 128016 127768 127768
:/dev/mapper/vg_fedorento-lv_home /home ext4 4096 4096 4743456 3722869 3484892 1191360 1178161 1178161
:
Comment 1 Zdeněk Pavlas 2012-03-27 04:03:50 EDT
:    self.fo.flush()
:IOError: [Errno 5] Input/output error

We got EIO writing to STDERR, probably because the PTY was closed.  Not sure why it's EIO instead of EPIPE- maybe a bug/feature in fflush()?

This seems to be the same problem as https://bugzilla.redhat.com/show_bug.cgi?id=596594
Comment 2 Zdeněk Pavlas 2012-04-10 02:51:57 EDT
*** Bug 810637 has been marked as a duplicate of this bug. ***
Comment 3 Zdeněk Pavlas 2012-04-10 02:58:18 EDT
*** Bug 811041 has been marked as a duplicate of this bug. ***
Comment 4 Zdeněk Pavlas 2012-06-04 06:58:09 EDT
*** Bug 828141 has been marked as a duplicate of this bug. ***
Comment 5 marita10001 2012-06-04 14:15:10 EDT
starting kde on new user

Package: yum-3.4.3-23.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Fedora Update System 2012-06-08 10:28:40 EDT
python-urlgrabber-3.9.1-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-12.fc17
Comment 7 Fedora Update System 2012-06-15 03:25:39 EDT
python-urlgrabber-3.9.1-13.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-urlgrabber-3.9.1-13.fc17
Comment 8 Fedora Update System 2012-06-15 19:48:36 EDT
Package python-urlgrabber-3.9.1-13.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-urlgrabber-3.9.1-13.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9500/python-urlgrabber-3.9.1-13.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-06-25 20:42:51 EDT
python-urlgrabber-3.9.1-13.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.