Bug 809852 - The problem with text selection.
The problem with text selection.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
: 807255 818160 819646 (view as bug list)
Depends On:
Blocks: 809861
  Show dependency treegraph
 
Reported: 2012-04-04 10:10 EDT by Mikhail
Modified: 2012-05-09 03:37 EDT (History)
9 users (show)

See Also:
Fixed In Version: gtkhtml3-4.4.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 19:04:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2012-04-04 10:10:09 EDT
Description of problem:
When I do mouse key down some text area before cursor already selected. 

This video demonstrate it: https://docs.google.com/open?id=0B0nwzlfiB4aQMUs1UGxSUnFSRDZBN0NvRFBocnk2dw
Comment 1 Milan Crha 2012-04-05 03:37:47 EDT
Thanks for a bug rpeort. I'm afraid this is related to lower libraries than to evolution. What is your version of gtk3, please? And when did you update to it (check with command like: cat /var/log/yum.log | grep gtk3 ). Does it help to downgrade to the previous version of gtk3, please? (yum downgrade gtk3).
Comment 2 Mark van Rossum 2012-04-12 05:27:27 EDT
I see this problem as well with
 evolution-3.4.0.1-1.fc17.x86_64
gtk3-3.4.0-1.fc17.x86_64

Unfortunately
yum downgrade gtk3
returns "nothing to do"

I have not seen this in any other applications,
if it were a gtk3 bug it should occur with many applications, no?
Comment 3 Milan Crha 2012-04-12 05:35:24 EDT
I can reproduce this with gtk3-3.4.0-1.fc17, gtk3-3.3.20-1, gtk3-3.3.18-1, all are reproducing the issue. If I downgrade to gtk3-3.3.14-1, then this behaviour is fixed again, no unexpected selection is made.

Mathias, are you aware of any exact change in gtk3 which would cause such behaviour in gtkhtml3, please? Note that this does it only with iframes, which is basically gtkhtml3 in gtkhtml3 (if I click in the header part, which is the master gtkhtml3 widget, then there is no unexpected selection being done; while if I click in message body, the inner gtkhtml3 widget, then the selection happens - it seems like some event processing got dropped in gtk3 development).
Comment 4 Matthias Clasen 2012-04-12 06:08:50 EDT
The only thing I could think off here is 

http://git.gnome.org/browse/gtk+/commit/?id=7b0fd635fa39a27693655171a4cdc0150ae476ed

But the details sound a little different here, so maybe this is something else after all.
Comment 5 Christoph Wickert 2012-04-13 04:35:27 EDT
*** Bug 807255 has been marked as a duplicate of this bug. ***
Comment 6 Milan Crha 2012-04-13 05:39:07 EDT
hrm, adding the patch didn't fix evolution.
Comment 7 Milan Crha 2012-04-13 06:56:56 EDT
I briefly checked differences between gtk-3.3.14 and 3.3.18 and the main change seems to be the move to XInput 2.2 (and removal of --enable-xinput completely). The code change set itself, which contains many changes in copyright notice, makes a patch with 47418 lines, thus it's hard to find what caused this for someone like me, whom doesn't know gtk internals. I can attach it here, is it helps, but I'm afraid it'll not help much.

The main question: is it intended to keep backward compatibility on gtk3 side with the move to XInput 2.2? If there are things missing in gtkhtml3 to be done to work correctly with this XInput, then I'm fine to do it, I'm only not aware of any such notice, which I could easily overlook.
Comment 8 Rui Matos 2012-04-13 07:20:53 EDT
You can check if running evolution with the env var GDK_CORE_DEVICE_EVENTS=1 fixes the issue. If it does then it's something in the XI 2.2 code.
Comment 9 Mikhail 2012-04-13 08:50:00 EDT
Running "$ GDK_CORE_DEVICE_EVENTS=1 evolution" not solve this problem
Comment 10 Matthias Clasen 2012-04-20 00:00:49 EDT
Upstream bug for this issue: https://bugzilla.gnome.org/show_bug.cgi?id=672582
Comment 11 Milan Crha 2012-05-03 02:48:15 EDT
*** Bug 818160 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2012-05-04 02:23:58 EDT
gtkhtml3-4.4.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-7255/gtkhtml3-4.4.1-2.fc17
Comment 13 Mark van Rossum 2012-05-04 13:16:43 EDT
This fixes it for me.
Comment 14 Fedora Update System 2012-05-04 19:04:37 EDT
gtkhtml3-4.4.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Milan Crha 2012-05-09 03:37:14 EDT
*** Bug 819646 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.